Duplicati and Google Drive paths


#1

I have been using Duplicati 2.x for some time now - very pleased! Amazing software.

I have run into an issue in using Google Drive (gdrive) to store the backups that I can’t quite understand. It has to do with the path names for folders and files as seen through the Google Gdrive web interface, and the names as created by Duplicati.

Suppose I ask Duplicati to create a folder (in the Destination) configuration called “MyServer”. The folder is created and is visible via the Google web interface. So far, so good.

However, if I create a folder using the web interface, and then tell Duplicati to use that folder, it claims the folder does not exist and creates another folder of exactly the same name. Clearly, under the covers, there is some sort of identifier for Google files and folders that is different than the names shown.

The reason this is a problem is because the mismatch extends to files. I have two GDrive accounts - one with 100 GB of storage and another with 1 TB of storage. The 100 GB drive was running low on space, so I decided to move my files to the 1 TB gdrive. This is not trivial, but I managed to accomplish it. However, even if I let Duplicati create the folder (say, MyServer) and then copy all of the many Duplicati data files into the folder that Duplicati created, when I try to get Duplicati to “see” the files (and recreate the local data base), Duplicati insists that no files are in the folder.

Is there any way to get Duplicati to see files and folders that have been created using Google’s GDrive tools (for moving and copying files within the drive)?


Gdrive (Google drive) and DB restore
#2

I don’t have a solution, sorry, but maybe some kind of confirmation.

Established a rather small and temporary personal backup, exclusively with Duplicati’s GUI. Created a folder on Google Drive directly (via the web interface). In addition, a folder of the same name from Duplicati (in expectation of overwriting or a corresponding note). Then I successfully performed Duplicati’s Backup. GDrive then displayed two empty folders with the same name. (Or after one of them was deleted? Which one came back?) Finally I deleted the folders and my local database, restarted: worked.


#3

Thanks for the confirmation - at least it proves that I’m not the only one to encounter this behaviour.

I suspect that I’ll have to look at the Google Drive programming interface to understand what is really going on here.

If anyone understands what is happening under the covers, please jump in!


#4

That would be @kenkendk, but he’s pretty busy so I’m not sure how soon he’ll see this.

My completely uneducated guess would be that Google stores content from “apps” in a different place than “users” but then tries to present them in a single unified structure to “make things easier”. Of course that’s just a guess…


#5

I think this is the source of the problems:

The name you set on a folder is just a label. All files and folders have an internal ID, so you can easily have multiple folders with the same name, although it is really confusing to browse it from the Web UI.

When you log in with via the OAuth handler, and choose “Google Drive” you only give Duplicati permissions to see/touch files it has created itself. Thus if you create a folder from the WebUI, Duplicati has not created it and is not allowed access to it.

“This is not a bug, its a feature”. Specifically, it is done to prevent a rogue Duplicati from wiping your Google Drive (extremely unlikely, but that is the idea).

If you do not like this, and want Duplicati to have full access to your Drive, you can use the button “Google Docs” (stupid name for this, I know) on the OAuth handler page. The generated AuthID here will grant full access to your Drive.


Is there a guide how to setup backup to google drive?
Files dissapeared in wasabi
One way sync and don't mirror?
#6

Thanks kenkendk - that is a super answer!

I was aware that the names on files and folders were just labels (and there was some underlying ID), but what I didn’t realize was that the default OAuth handler only gives Duplicati permissions to see and touch its own files. I agree this is a feature, not a bug - but perhaps it could be made a little more obvious. It might be worth putting some sort of note to that effect on the interface when a user performs the OAuth operation.

I’m sure this will fix my problem - many thanks!


#7

It worked for me, I could live with the fact that I only found the Duplicati-created folders when searching Gdrive, yet not when explicitly stepping down the drive folder tree.
The long story :
Since March 18 Google drive behavior changed and all my backup’s don’t work anymore. (Duplicati can’t find file/folder anymore it once created, must be related you @kenkendk ‘s statement “…only give Duplicati permissions to see/touch files it has created itself.”) I’ve seen no other option than redefining all backups again.
The sorter version:
I prefer seeing what I get – and would like to “want Duplicati to have full access to your Drive” and use the exact filepath I specifiy and I see. Yet, me being a newby with google drive, cannot find the “button “Google Docs” (…) on the OAuth handler page”


Startup error and can't auth google
#8

Since I wrote that, Google requested some updates to follow their “brand design guidelines” so the page now looks like this, and it should be easier to guess what the buttons do (I have circled the one you want):


#9

I don’t see this when I try to OAuth


#10

Thank you @kenkendk for your help, but neither do I see the options. Duplicati asks me to select the service first and then only calls the OAuth handler page for the dedicated service, which in my case is Google Cloud - limited access.


#11

Got it, copy the URL, remove the type=parameter and open in a separate window, copy the AuthID and it works


#12

I am new at Duplicat and find this is an great software product.
I have read the lines above, but i did not get my scenarion to run.
Duplicati on local PC > backup to google drive > shared to me section
My problem is that i have an small google account with the 15GB default size > is to small for my BAckup.
So i get an unlitted team Drive shared to > seen under shared with me.
My question is > how can use this space as backup target and which string must in target folder of the backup configuration?
I found nothing really helpful at google, only this thread in this forum.


#13

Hi @Timpeltu, welcome to the forum!

I believe Google Teamdrive support is still experimental. :frowning:


#14

Thanks for the quick answer. The hint with --googledrive-disable-teamdrive=true at default was very useful!
I Testet it with a new BAckup Configuration.

so i put a advanced option in
–googledrive-disable-teamdrive=false (disabled the checkbox)

The Path in gDrive is
Teamablagen/BCK_Holzhirsch.BCK/_BCK (german google account)

when i put this path in destination an click check > the path is not found.

i guess i have to use another string for the detination. Could anyone give me a hint?
The Screenshot shows the Gdrive

BCK%20%E2%80%93%20Google%20Drive
Thank you!


#15

For experimental purposes, test a path that is not so deep, such as trying a not-currently-present single-level, then let the “Test connection” button on the “Destination” screen make folders (which you can delete later) as needed. Duplicati’s default use of regular Google Drive (and I can’t say anything about Team Drives) only lets Duplicati access what it makes (security feature), and I’m not sure it can make multiple path levels in one shot.

Unable to restore from Google Drive talks about this more, and how security can be relaxed, if you prefer that.


#16

Hello Thank you for your suggestion.
I testet with
image
in destination field i put
Teamablagen
Team drives
Teamablagen/test
Team drives/Test
and all these were not found > so i let duplicati create Folders > they were created in meine Ablagen, so no Teamdrive Folder is used as base?

Is there any idea for the string which had to be brought in destination field?


#17

i forgot to mention that i used for the testing the Duplicati for Google Drive (full access) outh


#18

Another test:
When i put only ‘team drives’ in destination field > the process when test connection worked. The backup runs complete an the restore shows the files, but when i look at the teamdrive folder > i cant see any file? Where are they?


#19

The test shows that duplicati uses the space of gmail account > not the teamdrive. ;o(


Unable to restore from Google Drive
#20

I think it was thought to be experimental when developer access stopped working midstream somehow, but it might be worse than that. I’m not sure if I’ve ever heard of a report of an end user able to get Team Drive up.

For Team Drive access, there have been offers of assistance such as here and recently here by @Timpeltu however there might also be some lingering API questions from the lead developer (who is also super-busy).

Maybe a workaround can be built out of rclone support (see docs) and Duplicati using Rclone storage type?