Startup error and can't auth google


#1

When I launch the tray icon is red and the following is in the logs:

Mar 18, 2018 3:27 PM: Request for http://localhost:8200/api/v1/remoteoperation/test gave error
Mar 18, 2018 3:27 PM: Reporting error gave error

I can get an AuthID from google drive but test connection fails with

Failed to connect: Failed to authorize using the OAuth service: GetResponse timed out. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler

I got another authid as suggested in the error but that also fails to connect.

Using and old authid that used to work also fails.

Disconnect VPN (just trying things at random) does not help.


#2

What version of Duplicati are you using?

Up until the more recent Canary (and THE most recent Experimental) versions there was a failure scenario where if more than 50 usage log submissions were queued up it would cause problems.

That possibility combined with the OAUTH response timeout makes it sound like you might have a general DNS or connectivity issue maybe?


#3
  • 2.0.2.1_beta_2017-08-01

It started working. I find that no less disturbing. I tried it dozens of times over two days.

Back story:
I did a couple of fresh installs of Duplicati on this computer (another story). I was trying to restore backups from .json files. I had it working once, had to wipe my drive and reinstall. I could not get past Oauth.

I got the icon to change color by saving a dummy configuration. It failed at least once after that so no reason to think I solved anything.


#4

I believe there was a bug in the 2.0.2.1 beta (and a few later canaries) that caused the icon to show red after install until the first successful task action (such as a backup). Would explain your red icon experience?

As for the OAUTH issue, I believe that the authorization is done through the Duplicati OAUTH server were down (which happened a few weeks ago for a short while) everybody using OAUTH should have had issues. Since we didn’t see that (as far as I know) I think that points to an issue with your machine getting to the OAUTH server.

Granted, that’s no improvement - the end result is that you couldn’t use Duplicati for your backups. But it makes it harder to pin down the actual cause. If it happens again, do you have another machine you could test with?


Oh, this didn’t happen to start on March 16th, did it? It sounds like Google made some changes that might have tripped up Duplicati for a short while…


#5

Yes, it started about 3/16.
So we are assuming that Duplicati reacted to Google’s change and now everything is fine?


#6

I don’t know about the rest of “we”, but that’s my assumption at this point.

But be sure to let us know if it happens to you again, just in case I’m wrong.