Release: 2.0.2.17 (Canary), 2018-01-23

canary

#1

2018-01-23 - 2.0.2.17_canary_2018-01-23

  • Fixed a bug with the update packages having an invalid hash
  • Updated external links in the UI to be clearly marked
  • Experimental support for Google Team Drives
  • Fixed WEBDAV Test function, thanks @inat3k
  • Added an rclone backend, thanks @wjansenw
  • Fixed some broken error messages, thanks @JonMikeIV
  • Added a simple UI for exposing the --retention-policy option

Google Team Drives Setup
Problem applying latest canary
Is there a guide how to setup backup to google drive?
#2

Does anyone know where or what this change is? I haven’t been able to find anything different.


#3

I have just posted an announcement about this. It is a feature to delete older backups automatically in a way that you keep less backups the older they get.


#4

I’ve used retention policy - to be more clear, my question was about what is meant by “simple UI for exposing…”, as I still only see it as an advanced option with a single line text box.


#5

Oh, we have two options. One is just a smart retention policy with defaults. The other one is a custom policy that can be configured as you like.


#6

Ok, I see the answer to my question now: there are now new options inside the “backup retention” dropdown in the options screen. I hadn’t checked there, sorry.


#7

I understand. I have just written an announcement about this and pointed out that we introduced a “smart backup retention policy” that is a bit more that just deleting old backups after a specific time or number of backups.


#8

hmnm… I can’t find the “smart backup rentention” drop down menu on 2.0.2.17_canary_2018-01-23.
Have just upgraded from the previous canary


#9

As I mentioned in my comment above, it is now a new option within the “Backup Retention” dropdown, which is in the “Options” tab of the backup configuration wizard.


#10

Well, I dont have a “backup retention” option available at. Only “Keep this number of backups” below “Upload volume size” in the “Options” tab of the backup configuration wizard.


#11

Try doing a refresh (F5) or hard refresh (Ctrl-F5) of your main duplicati interface, then check again?


#12

Also, try to go to the “About” page to check that you are running 2.0.2.17.


#13

haha, this trick did it :slight_smile: Odd that i still had old browser cache data
Thanks!