Installing Duplicati on Linux (Ubuntu / LinuxLite)


#1

In this instance I’m using LinuxLite 3.6 for my #howto so your mileage may vary.

Disclaimer: This is what worked for me, hopefully it will work for you - if it doesn’t, please let us know so we can update this guide!

I strongly suggest glancing through this whole post before starting as there are instructions for both command line AND GUI processes.

As with pretty much any Linux app installation you may be prompted (mutliple times) to enter an admin password - so make sure you’ve got one. :slight_smile:

Until Duplicati gets added into standard packages, a manual install will have to be done - here are two different methods of getting it done.


Install (Ubuntu command line)

I’ve you’re familiar with the command line you could go with something like this:

  1. Open a command prompt
  2. Verify you have mono installed by running mono. If it’s not installed, install it by running sudo apt install mono-runtime. (Note that the apt version tends to be stale so you might be better off installing directly from the project website.)
  3. Use wget to download the latest install package (grab link from Duplicati, currently wget https://updates.duplicati.com/beta/duplicati_2.0.4.5-1_all.deb)
  4. Install Duplicati by running sudo dpkg -i duplicati_2.0.4.5-1_all.deb (or whatever version .deb file you downloaded).
  5. To run MANUALLY, execute duplicati
  6. To install as a service, execute systemctl enable duplicati.service or sudo systemctl enable duplicati.

Run automatically as service (Ubuntu command line)

To have Duplicati automatically run whether you’re logged in in or not (aka as a service):

  1. Open a console / shell / command prompt.
  2. Run sudo systemctl enable duplicati.
  3. To verify it’s running, in your console window you can:
    a. run sudo service duplicati status and look for “Server has started and is listenting”
    b. or run systemctl status duplicati and look for “Server has started and is listenting”
    c. or run htop
    … Press F4 (Filter) and type: duplicatiserver.
    … If you see anything like “DuplicatiServer” in the Command column then it’s running.
    … Press Esc then F10 to exit out of htop.
  4. Type exit to close the console window.
  5. If you like having the ‘task bar’ icon, see the section about having Duplicati automatically run when YOU log in.

Install (Linux-Lite GUI)

Details
  1. Verify you have mono installed by running “Menu -> System -> Install / Remove Software” (enter your password if prompted).
  2. Type “mono” (no quotes) in the “Quick filter” box and find the “mono-runtime” line - if it has an empty square next to it, click it and select “Mark for installation”.
  3. If prompted to “Mark additional required changes?”, click “Mark”.
    image
    image
  4. Click the “Apply” image button in the button bar, click “Apply” when prompted, and wait for the install to finish.
  5. Download the latest “Debian / Ubuntu” .deb file from Duplicati
    image
  6. If prompted by an “Open with” option, select “GDebi Package Installer (default)” (otherwise the just save the file then use your file browser to right-click on it and select "Open With “GDebi Package Installer”).
    image
    image
  7. When the “Package Installer - duplicati” window is open, wait for the “Install Package” button to become active and then click it.
    image
  8. Once installed, you can now MANUALLY run Duplicate via “Menu -> System -> Duplicati” (it is not yet set to auto-run).
    image

Run at user login (Linux-Lite GUI)

Details

To have Duplicati automatically run when YOU log in:

  1. Go to “Menu -> Settings -> Session and Startup”.
    image
  2. Select the “Application Autostart” tab.
  3. Click the “+ Add” button
  4. Enter a name (such as: Duplicati), Description (such as: Run Duplicati backup tool), and Command (such as: dulplicati), then click the “OK” button.
  5. To verify Duplicati starts at login, log off (or reboot) then log back in and confirm you see the icon in the tray by clock. image

Notes

a. It appears the service can be installed via systemctl enable duplicati.service in CentOS as well
b. A recent update of Linux-Lite caused my service to stop staring, however re-running systemctl enable duplicati seems to have resolved it.


How to give duplicati root permision on ubuntu
Duplicati on Ubuntu - No Backups Without A User Logged In
Duplicati's scheduler
Duplicati on Zentyal 5
"Invalid or missing backup id" after moving from tray to service
Linux installation instructions outdated
How to make Duplicati start automatically with Ubuntu?
Can't restore from linux to Windows
#2

I recommend that you install Mono from the project website, instead of using apt. The Mono version in the package managers is usually really old (especially for Debian based distros). Using the old versions mostly works, but later versions are more “user friendly”, e.g. setting up SSL certificates automatically.


#4

Yes, ENABLE service is correct if you want it to survive a reboot - thanks for catching that Derek!

As for “duplicati” vs “duplicati.service” I have found no difference, so I assume one is technically deprecated - though I don’t know which.


#6

My system is running Linux Mint 17.1, which is based on Ubuntu 14.1. I have followed the instructions under "Install (Ubuntu command line) precisely.
When I run step 5, manually launching duplicati, it launches without error. However, when I run step 6 to install as a service, both commands return the message “Failed to issue method call: No such file or directory.”

Is something missing from the instructions?


#7

Hi @Beckfield, welcome to the forum!

I’m no Linux expert but I think the systemd service manager (for which systemctl is the main control) didn’t get into Mint until version 18.

If systemd isn’t available I think you have to fall back to init.rc type scripting as mentioned here:

If that’s enough to get you going, please let me know what you used and I’ll update the initial post. :slight_smile:


#8

Agree with @JonMikelV that @Beckfield probably isn’t on systemd. Check PID 1. It will probably be upstart. Fortunately both newer systems provide support for old sysvinit scripts, and Duplicati source has an example.

Steps might be:

  1. cd /tmp

  2. curl --remote-name https://raw.githubusercontent.com/duplicati/duplicati/master/Installer/debian/init-script-example.sh

  3. who -r to see what run level you’re at. Maybe you’re at 5

  4. Look over script if you like. See at top it should start at 5

  5. chmod 755 init-script-example.sh

  6. sudo cp init-script-example.sh /etc/init.d/duplicati

  7. rm init-script-example.sh

  8. Restart

  9. ps -ef | grep DuplicatiServer

  10. If it didn’t come up, see if it’s in /etc/rc5.d. If not, try sudo update-rc.d duplicati defaults, then a restart

Alternatively, can you upgrade your OS, which is only supported until April 2019 (like its underlying Ubuntu)?


#9

A post was split to a new topic: “Database file is locked” during restore