Duplicati on Ubuntu - No Backups Without A User Logged In


#1

Team,

I am testing out Duplicati on Ubuntu and I noticed that no scheduled backups run when there is no user logged into the desktop. Is this normal behavior? I would prefer to have the backups run whenever the system is up, whether a user is logged in or not, is there a way to do this? I checked, and the Duplicati service appears to be running, so I am not sure where else to look.

Thank you in advance.

LA.

lajams@ubuntusrv2:~$ systemctl status |grep duplicati
           │ ├─duplicati.service
           │ │ └─839 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe
           │ │ └─1856 grep --color=auto duplicati
lajams@ubuntusrv2:~$

#3

Welcome to the Duplicati Forum @lajams!

It sounds like you’re running the Duplicati server which should be all that’s needed for backups to occur even if nobody is logged in.

The only thing I can think of is that perhaps you somehow have the service only starting at login?

Did you run sudo systemctl enable duplicati.service as described here?


#4

JonMikelV,

Thank you for your response. Yes, I verified that the service was configured per that document you mentioned. Just to be sure I re-ran the commands and bounced the system, and still the backups did not run at my specified time (noon every day). I am very confused by this. When I log into the system via the desktop, the backup immediately kicks off, so I know the configuration itself is working, but the backups do not appear to run once I log out.

LA.


#5

Did you start your installation as a “tray icon” install then change it to a service based one?

If so, then you may have a situation where your backups / schedules were created under the “tray icon” account, not the service account. If that’s the case, then the service is likely starting but doesn’t see anything scheduled to be done.

When you open the web GUI are you connecting to localhost:8200, localhost:8300, or something else?


#6

JonMikeIV,

I think you may be on to something. I used the Duplicati “app” that I found on the desktop, rather than the WebUI. I logged into the web UI and found nothing scheduled, so I am betting this is it. I created a new schedule there, and will delete the one in the app.

Thank you!

LA.


#7

You’re welcome! If you want to use the desktop “app” you can add the --no-hosted-server parameter to it (this tells the Tray Icon to connect to the service server instead of starting it’s own local-user instance server).

Note that if you’re using the service install then the “app” (with --no-hosted-server) is solely to provide:

  • a tray icon to easily see the status of a backup (different colors / images indicating inactive, backing up, paused, etc.)
  • a quick menu to open the web GUI & pause the server

So if you’re running the service, you don’t NEED to be running the tray icon “app” for backups jobs to run - however if you’re NOT running the service, then the tray icon “app” IS needed for the backup jobs (as the tray icon “server” he place of the service “server”).