Duplicati not starting on MacOS Monterey 12.3 on M1

After updating MacOS to version 12.3, Duplicati 2.0.6.3 will not start anymore. Any ideas on getting it back online?

3 Likes

Same issue here. Python 2.7 is no longer available after the update. I’ve used Homebrew to install Pyenv, then used Pyenv to install Python 2.7.18. I then needed to create a link from /usr/bin/python2.7 to /Users//.pyenv/versions/2.7.18/bin/python2.7. Duplicati is now up and running but I’m sure there must be a better solution.

Wait, Duplicati uses Mono and Python?

I tried to replicate your temporary solution, but when I try creating the symbolic link, I get “ln: /usr/bin/python2.7: Operation not permitted”, even when I use sudo. How did you do it?

Something odd going on. I got the parameters for the ln command the wrong way around so I didn’t get the same error but Duplicati still ran for about 20 minutes before crashing. I then realised my error with the ln parameters and now have the same issue as you - I’m still trying to figure it out. You can get around the “Operation not permitted” error by using “csrutil disable” from the terminal in recovery mode (disables security protection) but then you’ll find the filesystem is read only and still can’t create the link which is where I’m at now. I have just found that duplicati is running in the background though even without the link (no menu bar icon but I can go to 127.0.0.1:8200). I did create a link to /usr/local/bin/python2.7 earlier which might be why it’s working. Maybe the link to usr/bin isn’t needed at all and is misleading me.

Edit:
Maybe Python is only needed for the menu icon.
If I run /Applications/Duplicati.app/Contents/MacOS/duplicati-server from the terminal then go to 127.0.0.1:8200 I can see the backups running but as soon as the backups finish it disconnects. I’ve only been using Duplicati for 3 days so not had much chance to see how it’s supposed to work.

Edit 2:
I’ve put a copy of the “net.duplicati.server.plist” file from here into the root /Library/LaunchAgents to get the server component to start automatically and can access the GUI from 127.0.0.1:8200 so, no tray icon, but at least the backups are working.

7 Likes

Try running /Applications/Duplicati.app/Contents/MacOS/duplicati-server from the terminal then browse to 127.0.0.1:8200 to see if it is running.
If that works then add the plist file from my “Edit 2” above so that it runs automatically after reboot.

The update has removed python 2.7 in 13.2 so the menu bar tray icon doesn’t work but the core Duplicati service doesn’t appear to be affected.

4 Likes

Thanks for the tip. The service does run fine in the background.

Thanks for your support. The Github Site also features a file called net.duplicati.tray-icon.plist. Is this also supposed to go into /Library/LaunchAgents (maybe to get the tray icon working again)? Sorry, I’m not much of an MacOS expert, but I’ve been asked by somebody facing exactly this issue for help.

Thanks again :grinning:

“Duplicati needs to be updated” warning on upgrade to MacOS Monterrey 12.1 #4668
is my take on this (or start earlier) and there are people working on this issue there too.

Ultimately this requires community help (thanks to all who helped so far) to develop the
temporary workaround, and the long term solution. Ideally, it gets into the shipped code.

The long-term solution probably means abandoning Python 2 (which is kind of dead…).
This still leaves no Python (because Apple doesn’t ship Python 3 in default install either.

Python here is for macOS to work with a Tray Icon which different OSs handle differently.
Even though one can live without that, it would certainly be nice if it could be gotten back.

Ridiculously Uncomplicated macOS Python Statusbar apps
and I’m not sure why there are not more people asking about it, besides @bob787 for us.
Is Rumps Python 3 compatible? #180
I see some signs there that the answer is probably yes, but Duplicati (I think) does not run
exactly the shipped version, so some Python merging might be needed to maintain status.

I can’t seem to get this to work. I was originally able to connect at 127.0.0.1:8200 but after a reboot of the mac I can no longer connect. I just get an error that Safari can’t connect to 127.0.0.1.

If I try the terminal command I get this-

wgstarks@m1_mini ~ % /Applications/Duplicati.app/Contents/MacOS/duplicati-server 
Unable to start up, perhaps another process is already running?
Error message: System.Exception: The lock file was locked, but the locking process did not respond to the start command
  at Duplicati.Server.SingleInstance..ctor (System.String basefolder) [0x0025e] in <156011ea63b34859b4073abdbf0b1573>:0 
  at Duplicati.Server.Program.CreateApplicationInstance (System.Boolean writeConsole) [0x00005] in <156011ea63b34859b4073abdbf0b1573>:0 
wgstarks@m1_mini ~ % 

Edit: DISREGARD. I just needed to reboot again after the addition to Library/LaunchAgents/.

Thanks for the work around.

Thank you, Edit 2 is working for me on Mac OS Monterey on 2018 MacBook Air

Edit 2 works for me too - M1 Chip.

But is there a way I can have the tray icon too? It’s much easier to interact with it when the tray icon is on.

I’ve had the same issue, and “Edit 2” helped me running Duplicati at startup, but after a successful backup, Duplicati stops and I cannot access the GUI anymore, I have to start the server again via the terminal!
Anyone with an idea what could be wrong here? Thanks in advance.

I think I had this same issue several months ago. I placed the plist file in /Library/LaunchDaemons instead of /Library/LaunchAgents, it works and I didn’t bother investigating why. This is on a personal laptop so I don’t really care about the difference between the two.

This works! Thank you.