Duplicati won't run after upgrade to macOS 12.3

There is no error message on running from double click icon or run from Terminal with open command.

I cannot find any crashes or error related to the program itself. Any suggestion on how to gather related logs?

I tried on version v2.0.6.100- or v2.0.6.3-, but both versions have the same result.


1 Like

Welcome to the forum @SydneyTT

I don’t have a Mac, but I don’t think logs are relevant. Apple took Python away, which broke TrayIcon, however I think Duplicati itself is still running (aside from that…). The forum thread seeking fixes is at

Duplicati not starting on MacOS Monterey 12.3 on M1

There’s also a GitHub issue thread. If you happen to be good at Python, you can join in on the efforts.
This may need the Mac community to find a fix because the Duplicati project has no Mac person now.

I am more of a user to Dupicati, but still thanks for pointing me to the clues. Not sure if I can find the path where it asked for python, and I can edit it to look for python3 instead…

That by itself won’t suffice because the current script is for Python 2. Conversion might be possible,
however there is apparently now a new worry about how much Apple removed. See GitHub thread.

Remove python 2 dependencies #4690 was the thought needing Mac community before that worry.
If you have expertise in the area, please help over on GitHub work or previous technical forum topic.