Can't run duplicati on a Mac

I have Duplicati Beta installed on a Mac that I recently upgraded from Catalina to Monterey. Duplicati was working fine before the upgrade, but I can’t open it since the upgrade.

I’m used to seeing a Duplicati icon in the Mac menu bar, but since the upgrade, it’s not there. If I open Duplicati from an icon, I get no response, and if I open the Duplicati UI from a bookmarked URL, http://localhost:8200/ngax/index.html#/ my browser returns a “connection refused” error for localhost:8200 .

I suspect that the upgrade to Monterey is causing a permissions issue somewhere, but it’s not obvious to me just where that might be. My initial inclination is to check the Privacy tab in Security & Privacy, but checks of the settings for both Full Disk Access and Files and Folders both show full access granted to Duplicati. A browser error of this sort implies the possibility of firewall, but I still get the error with the firewall temporarily turned off.

Any ideas of what else might need attention? Is this something that an uninstall/reinstall might fix?


Followup item:

I just ran a check of logs, and I have the following excerpt from my launchd.log file. It looks like the Duplicati service is failing to launch, but I don’t know services handling enough to know how to troubleshoot.

2022-04-02 10:13:01.967202 (gui/501/ : internal event: WILL_SPAWN, code = 0
2022-04-02 10:13:01.967219 (gui/501/ : service state: spawn scheduled
2022-04-02 10:13:01.967224 (gui/501/ : service state: spawning
2022-04-02 10:13:01.967246 : Coalition Cache Hit: app<> [799]
2022-04-02 10:13:01.967329 (gui/501/ : launching: non-ipc demand
2022-04-02 10:13:01.968521 (gui/501/ [13796]) : xpcproxy spawned with pid 13796
2022-04-02 10:13:01.968575 (gui/501/ [13796]) : internal event: SPAWNED, code = 0
2022-04-02 10:13:01.968588 (gui/501/ [13796]) : service state: xpcproxy
2022-04-02 10:13:01.968658 (gui/501/ [13796]) : internal event: SOURCE_ATTACH, code = 0
2022-04-02 10:13:01.994326 (gui/501/ [13796]) : service state: running
2022-04-02 10:13:01.994346 (gui/501/ [13796]) : internal event: INIT, code = 0
2022-04-02 10:13:01.994351 (gui/501/ [13796]) : job state = running
2022-04-02 10:13:01.994383 (gui/501/ [13796]) : Successfully spawned duplicati[13796] because non-ipc demand
2022-04-02 10:13:06.561316 (gui/501/ [13796]) : exited due to exit(0)
2022-04-02 10:13:06.561339 (gui/501/ [13796]) : service state: exited
2022-04-02 10:13:06.561353 (gui/501/ [13796]) : internal event: EXITED, code = 0
2022-04-02 10:13:06.561358 (gui/501/ [13796]) : job state = exited
2022-04-02 10:13:06.561390 (gui/501 [100003]) : service inactive:
2022-04-02 10:13:06.561396 (gui/501/ [13796]) : service state: not running
2022-04-02 10:13:06.562067 (gui/501/ : removing job: caller = runningboardd
2022-04-02 10:13:06.562075 (gui/501 [100003]) : removing service:
2022-04-02 10:13:06.562140 (gui/501/ : internal event: PETRIFIED, code = 0
2022-04-02 10:13:06.562142 (gui/501/ : job state = removed

Welcome to the forum @wagner

The Mac community is trying to sort this out at Duplicati not starting on MacOS Monterey 12.3 on M1.
The primary trigger, as I understand it, came from Apple’s removing installed Python for macOS 12.3.
GitHub issue is “Duplicati needs to be updated” warning on upgrade to MacOS Monterrey 12.1 #4668

Thank you for the information. Is it just a matter of time before the Duplicati team figures out how to resolve the issue? Shall I try each day to open Duplicati? I am not particularly computer savvy so if it requires some technical finesse, I will need to request help.

Thanks again for helping me!


Duplicati team has no Mac (or Mac expert) now, which is why I saw this needs community.
You can watch progress on the other threads. Duplicati very much needs more volunteers.

If this is a Mac platform issue, as has been noted above, I’m not expecting a quick resolution.

If the Duplicati team had sufficient Mac capacity, we could watch for a potential fix coming from there, but that looks unlikely.

If the issues are coming as a result of Apple’s handling of Python, then about all we can do is wait to see if something else changes there. I’m sure that Apple has internal reasons for changing. It could be that they discover that those changes have broken enough things that they could restore removed capacities in a future release (possibly 12.4, but not 12.3.2, which should be limited to security fixes). Or it could be that they’re set enough on the changes that they made that their view is “if our updates break something, it’s up to developers to fix their code to match what we’re supporting”.

I suspect the latter to be the more likely of the two, but I could be wrong.

By the way, I’m running an Intel Mac, and even if the Mac community is looking primarily at M1, I don’t think it’s as much an M1 issue as it is for 12.3, regardless of platform.

In any case, I think it’s probably best to conclude that the combination of Duplicati running on Monterey 12.3 is pretty much dead, and that the only thing that will revive is either Apple restoring capacity in a future release (e.g., 12.4) or a Duplicati update, and quite possibly, both.

I really like the cross-platform capacities of Duplicati, where I’m running it on Windows, Mac and Linux (and writing to LAN-based storage), but for now, I’m going to have to move my Mac backups to something else, as I’m not planning to downgrade my Mac back to Big Sur.

Note that there’s a limited workaround posted here if you are willing to run Duplicati without a tray icon.

That mostly works. I’m fine without a tray icon – that’s mostly a convenience, and I have all of my browsers with bookmarks forhttp://localhost:8200/ngax/index.html#/ .

I’m still not quite getting things where Duplicati starts up automatically following a system restart, but I’m UNIX-fluent enough that I can from the command line and get things started. For now, I can live with that.

Even though the linked discussion includes M1 in the title, I don’t think this is processor-specific, because I’m having the same behavior on an Intel Mac.

Also, from interaction from a friend, it appears that the removed parts of Python were related to security issues, and unlikely to be restored by Apple. It would appear that any fixes are going to need to come from updates to Duplicati code. Or, making use of this kind of work-around.

there’s python via homebrew on the mac. not sure if that is of use to you. i use homebrew a lot but not for python (nor duplicati)

There are now two better workarounds that actually get things back to normal (after some doing).

Look here for steps that @bobm787 put together and tested based on the prior community efforts.

Just below that is a shorter variation from zahiar that restored Python 2 parts that Apple deleted.

I’m just reporting. Ask these folks questions if need be (and thanks to them!). We still need people
who have enough expertise (maybe including with installs) to figure out a method that’s less work.

1 Like