2 Windows service portable mode instances after 2.0.3.3 update

I’m running the Windows service in portable mode, and when I ran the GUI, it notified me that a new version is available, so I clicked the install button, and then the Activate button. However, it didn’t seem to actually install the update. The new files ended up in the updates folder, and the GUI even reported that it was running 2.0.3.3
However, in Task Manager, I right-clicked on the Duplicati.Server process and chose Properties, and the file properties/details tab showed 2.0.2.1 (same with the Duplicati.WindowsService)
I rebooted, which had no effect. Also, in the GUI I didn’t get any options for the new “Smart Retention”
So to try to make it work, I made a copy of my Duplicati folder named Duplicati-old, and then I replaced all of the files in the Duplicati folder with the files/folders in the “Duplicati-old\updates” folder. That seemed to work - Task Manager shows that the 2.0.3.3 files are running. However, now i have 2 instances of the Duplicati.WindowsService process running in Task Manager (both of them show 2.0.3.3)

Any suggestions on how I can make this right?

Thanks!

I’m running Duplicati as a service. I had a similar problem with not seeing the Smart Retention etc. unless I went via the non service method. I finally read someone suggesting to open up a browser in incognito mode and go to 127.0.0.1 and the correct port as set per the service command (in my case 8200). And the new GUI appeared. Once doing that I tried it in normal browsing and clearing the browser cache ‘Shift or Ctrl’ F5 and all is now OK.

Hope that helps
Dean

Thanks arndale, but that’s really not the problem that I’m trying to solve. I am trying to get the v 2.0.3.3 programs to actually run, and not have 2 copies of the windows service running in Windows Task Manager!

Ahh yes. Apologies, I didn’t read right down to the bottom of your post. Hopefully my comments may help someone else with a problem similar to mine.

UPDATE: I have just done a clean install of Duplicati 2.0.3.3 (portable mode) on a virtual machine, and the Duplicati.WindowsService is running twice in the Task Manager, even with the clean install. So, I don’t think that it has to do with the actual installation update - it is a problem in this version of the app (or maybe it’s not a problem? - I just know that this was not the behavior of 2.0.2.1).

My method of installation was to just extract the files from the msi file (I did not actually run the installation. I used the /a option on the msi to just extract the files.)
I extracted the files to a folder named “C:\Duplicati”. After the files were extracted I opened an administrative command prompt and installed the service using the following:
Duplicati.WindowsService.exe install --portable-mode --webservice-port=8200 --webservice-interface=loopback --log-retention=7D

Then I rebooted so that the service would start, and when I checked the Task Manager there were 2 instances running. (Note that there were 2 separate PID’s, but if I did an “End Task” on either of them, they both shut down.

Just to confirm, you’re seeing two instances of Duplicati.Server.exe?

Are you seeing multiple instances of Duplicati.WindowsService.exe or Duplicati.GUI.TrayIcon.exe?

image

No Jon - as I said, Duplicati.WindowsService.exe

Also, I’ve just discovered that whenever the Duplicati service starts there is an error in the Windows System Event log indicating that the service is starting under an unexpected process id:
Service Control Manger Event ID 7039
“A service process other than the one launched by the Service Control Manager connected when starting the Duplicati service. The Service Control Manager launched process 2492 and process 2784 connected instead.”

Fresh install of 2.0.3.3, then migrated from user to service.
I also am seeing 2 instances of Duplicati.WindowsService.exe

I am also getting the “Warning” in System Event log:
“A service process other than the one launched by the Service Control Manager connected when starting the Duplicati service. The Service Control Manager launched process xxxx and process xxxx connected instead.”

In addition, I cannot get: “C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe” --no-hosted-server
to launch the tray icon.

I did not seem to have these problems running 2.0.2.1 as a service prior to complete uninstall and clean install of 2.0.3.3

Thanks for your help

I also see 2 active processes with the same name (Duplicati.WindowsService.exe). I guess it has something to do with this change in version 2.0.3.3:

  • Updated the auto-updater, such that new installs will spawn an extra process instead of using the AppDomain method as previously done.

Thanks kees-z; perhaps that explains it.

Anyone else having issues getting:
“C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe” --no-hosted-server
to execute when running 2.0.3.3 as a service?

I’ll try to update when I get to my 2.0.3.3 service machine but my 2.0.3.4 service machine worked fine when running your command line.