Jottacloud Error 401 (Unauthorized)

Hi

I tried to do a backup to Jottacloud but I keep getting the error “the remote server returned an error (401) Unauthorized”. I checked the password thrice and restarted the service, nothing changes.

Duplicati is running on a Ubuntu machine (OMV).

Any suggestions are appreciated.

Greetz
Daniel

Hi @ChacalCH, welcome to the forum!

I don’t personally use Jottacloud, but I know some other users (such as @rix1337) have used it.

Could you let us know what version of Dulicati you are using and maybe post your job configuration exported “As commandline” (be sure to remove any personal data like email address, passwords, etc.)

Oh - and while it sounds like we’re not using the latest Jottacloud API, my guess is this is NOT the issue you’re running into (but I’m sharing it anyway, just in case I’m wrong):

Hi @JonMikelV

I’m using Duplicati 2.0.3.3_beta_2018-04-02 on OMV

This is the error message:

    Fatal error
System.Net.WebException: The remote server returned an error: (401) Unauthorized.
  at Duplicati.Library.Main.BackendManager.List () [0x00049] in <ae134c5a9abb455eb7f06c134d211773>:0 
  at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.String protectedfile) [0x0000d] in <ae134c5a9abb455eb7f06c134d211773>:0 
  at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.String protectedfile) [0x00000] in <ae134c5a9abb455eb7f06c134d211773>:0 
  at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify (Duplicati.Library.Main.BackendManager backend, System.String protectedfile) [0x00066] in <ae134c5a9abb455eb7f06c134d211773>:0 

This is the configuration:

mono /usr/lib/duplicati/Duplicati.CommandLine.exe
 backup
 "jottacloud://Backup Name?auth-username=User&auth-password=Password"
 /sharedfolders/data/Bilder/
 --backup-name="Backup Name"
 --dbpath=/root/.config/Duplicati/YKKEOMWVDN.sqlite
 --encryption-module=aes
 --compression-module=zip
 --dblock-size=50mb
 --passphrase="Passphrase"
 --disable-module=console-password-input

Greetz ChacalCH

It looks like you’re using the most stable version of Duplicati available at the moment, and I know other users have been able to run it on Open Media Vault so I doubt the issue is there…

And everything looks OK to me in the config and the error message just tells us that JottaCloud considers Duplicati unauthorized. Unfortunately, I don’t think we can get any more detail from JottaCloud about WHY they consider it unauthorized.

Is it possible it has stale or missing SSL certificates (which are destination independent) as seemed to have been the issue here?

Hi, is there any progress on the issue? After dozens of successful backups to my jottacloud and without any change, I started to receive “The remote server returned an error: (401) Unauthorized” error to any backup attempt for several days now.

“{“ClassName”:“System.Net.WebException”,“Message”:“The remote server returned an error: (401) Unauthorized.”,“Data”:null,“InnerException”:null,“HelpURL”:null,“StackTraceString”:” at Duplicati.Library.Utility.AsyncHttpRequest.AsyncWrapper.GetResponseOrStream()\r\n at Duplicati.Library.Utility.AsyncHttpRequest.GetResponse()\r\n at Duplicati.Library.Utility.AsyncHttpRequest.GetResponseStream()\r\n at Duplicati.Library.Backend.Jottacloud.d__33.MoveNext()\r\n at System.Collections.Generic.List1..ctor(IEnumerable1 collection)\r\n at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)\r\n at Duplicati.Library.Main.BackendManager.DoList(FileEntryItem item)\r\n at Duplicati.Library.Main.BackendManager.ThreadRun()",“RemoteStackTraceString”:null,“RemoteStackIndex”:0,“ExceptionMethod”:“8\nGetResponseOrStream\nDuplicati.Library.Utility, Version=2.0.4.22, Culture=neutral, PublicKeyToken=null\nDuplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper\nSystem.Object GetResponseOrStream()”,“HResult”:-2146233079,“Source”:“Duplicati.Library.Utility”,“WatsonBuckets”:null}

Testing connection shows this error too, although it didn’t so yesterday when I checked this exact configuration test for any errors with access to service. Perhaps until yesterday only puts failed, today auth fails too. I wrote to jottacloud about any changes in auth for API but have yet to receive any response.

I do NOT have 2FA turned on as this is prerequisite for backup to work in first place. Same backup also starts to fail on it’s database being used by other process (ProcExp shows said process is duplicati itself) although this exact files is in exclusion list. This is new behavior too.

image

Stations runs windows 10 and my other duplicati installs (archlinux with AWS S3 backend) don’t suffer with this.

1 Like

I too am facing the same situation as above, with the only difference in that I’m using Windows Server 2012 R2 Datacenter. Backups to JottaCloud were running just fine up until this morning.

Same here, running Windows 10. Worked fine until two days ago. The last successful Backup to Jottacloud happened yesterday at 00:01. When I started my computer then yesterday after work, I received those error messages.

has been fixed in rclone: https://github.com/rclone/rclone/pull/3436

2 Likes

I since received message from jottacloud guy who confirmed it’s username thing:

Yes, we have done some changes regarding emails in our systems, and this means we no longer support emails in JFS-url’s. This can cause progblems if you use third-party apps with Jottacloud if they still use this format. It should however be possible to switch the email in the url to your username.

He also sent me my true name (looks like random alfanum string) - when I replaced my email username in task configuration with this string, connection test works as does backup. I’ve asked where users can find that ID.

Error message about locked database is gone too - and I received new one “Expected there to be a temporary fileset for synthetic filelist (421, duplicati-ie16602c9781f4bccae6a31f89ed7fe1d.dindex.zip.aes), but none was found?” perhaps result of those undone backups? This one went away when I re-run same backup again.

1 Like

do you have an idea how to get your username? It’s also mentioned in rclone github issue, but no hint how to obtain the username in a non-email format.

Haven’t found it anywhere on website, so I asked where users can find that ID.

It will be somewhere in jottacloud: use new api for retrieving internal username - fixes #3434 by buengese · Pull Request #3436 · rclone/rclone · GitHub :slight_smile:

1 Like

Thank you!

You can find the username in the account settings page, view source and search for user_id. You will see something like this:

URL: https://www.jottacloud.com/web/account

<!-- Intercom -->
<script>
    window.intercomSettings = {
        app_id: "xxxxxxxx"
        ,user_id: "xxxxxxxxxxxxxxxxxxxxx"
        ,user_hash: "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
        ,name: "User Name"
        ,email: "user@domain.com"
    };
</script>
4 Likes

awesome.

however I was too quick claiming it works - what works is the connection test in the configuration edit screen, however when running a backup it fails again when trying to fetch a list of remote files.

Have you saved the configuration after testing?

I’ve just had the first succesful backup after changing email address to user id.

Duplicati using rclone backend (using a recent rclone beta) might be a workaround for the API change.

JottaCloud migration to Drive (rclone remark)

The Jottacloud remote is using the Jottacloud-API unofficially .

Slow Download speed with Jottacloud in case of recovery #3248 (Duplicati remark from @albertony)

Jottacloud seem to be moving to a newer API in their own clients.

Although workarounds seem to be underway, this may ideally call for code change to track the new API.

Can’t create or mount jottacloud remote. #3434 was the rclone issue, and it looks like how to release the fixed version is a question. Duplicati has been trying to get a beta too. If a fix is done, maybe it will ship…

Getting beta release out has been hard lately. The upcoming one is stalled on “FTP (Alternative)” update. Meanwhile other good fixes are accumulating, along with some others that might need more test or time.

yes, config was saved.
2nd time jobs run they don’t throw an error anymore.
now it works again

1 Like

So you guys just replaced the user name with the one provided by JottaCloud support?

Or you can find it yourself in the place @nescafe mentions.

If running from command-line without specifying --dbpath it’s a good idea to change the username in dbconfig.json file. Doing so allows you to continue with existing backup set and data, without reset.

Hi,
I am experiencing the same problem.
I’ve tried some things, but with no effect:

  • install rclone beta
  • use user_id instead of email-username
  • changed password to a uselessly short and non-complex value
    ** complex and non-complex password both worked with Jottacloud Web-UI
  • created new backup job
    ** connection test fails
    ** running backup job anyway fails, too

Duplicati: 2.0.4.22_canary_2019-06-30
rclone: v1.48.0-194-g898782ac-beta
OS: MacOS 10.14.6 (Mojave)

This is reproducable on other MacOS versions and on QNAP.

How can I assist in debugging?

Regards

Michael