Errors on Linux with B2 and Jotta

Hi, I’m running Linux Mint 18.3, Duplicati, I set up backups to B2 and Jotta but neither one of them work; they get stuck on “Verifying backend data” and the logs show this error:

Fatal error

System.Threading.ThreadAbortException: at (wrapper managed-to-native) System.Threading.WaitHandle:WaitOne_internal (System.Threading.WaitHandle,intptr,int,bool) at System.Threading.WaitHandle.WaitOne () <0x7f0903251460 + 0x0005c> in <filename unknown>:0 at Duplicati.Library.Main.BackendManager+FileEntryItem.WaitForComplete () <0x405d62c0 + 0x0001a> in <filename unknown>:0 at Duplicati.Library.Main.BackendManager.List () <0x405d55a0 + 0x000c7> in <filename unknown>:0 at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, IBackendWriter log, System.String protectedfile) <0x405d2000 + 0x0015f> in <filename unknown>:0 at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, IBackendWriter log, System.String protectedfile) <0x405ccb50 + 0x000ab> in <filename unknown>:0 at Duplicati.Library.Main.Operation.BackupHandler.PreBackupVerify (Duplicati.Library.Main.BackendManager backend, System.String protectedfile) <0x405cbb80 + 0x001af> in <filename unknown>:100:

I should mention that I can do local backups without any problems, it’s just the remote backups that don’t work. Could anyone help please? Thank you!

Hi @maya and welcome to the forum! This will possibly need different expertise, but let me get things going.

I tried to reproduce your exact stack trace with my own B2 account, and find forum clues. No luck with either.
There was one similar stack, also on Linux, however the problem resolved somehow, and how wasn’t stated.

The first thing to check for B2 is whether you’re using the right Account ID & Application Key from Backblaze. You would have gotten those using a link on your Buckets page, however once you get the key, you have to record it somewhere yourself because it won’t be shown again (though one can reset it, voiding the old key).

Another thing I would suggest is that while on the page where you set the Destination, do Test connection unless you’re pretty sure it will work. Destinations on the local drive are reliable. Remote can be troublesome. You can still try the test now. Even if it fails the same way, at least we know exactly what it was that had failed.

Sometimes a later Mono will help, as seen in GetRequestStream timed out during backup on Linux Mint 18.2

Mono also sometimes has SSL/TLS troubles. There is an SSL TLS support in Mono article and special tests.

I use Windows, so if you need help with the Mono issues, try a forum search or maybe an expert will stop by. There have been Linux issues. I think sometimes newer is worse, but I don’t recall all of the issues that arise.

Solved! Thanks for taking your time to point me in the right direction!

For anyone else who’s having this problem: Uninstalling Mono 4.2 that came with my distro and installing Mono 5.14 from their website solved the problem.

Uninstall: sudo apt remove --purge --auto-remove mono-runtime

Install from here: Download - Stable | Mono

Thanks for letting us know what worked. Specifics can really help build up these non-obvious connections.

Did both B2 and Jotta work? I see there are other people having some Jotta mysteries, e.g. here and here

Feel free to join in, or if you’d rather not, it would be nice to at least know that Jotta began working for you.

Yes, connecting to both B2 and Jotta started working properly after the upgrade. It seems like the other threads deal with other issues, which I know little about. For me Jotta works fine on Mint 18.3 after upgrading to Mono 5.14. Thanks again.