Duplicati.Server.exe boosts my system hard, and it freezes for 10-20 seconds

When duplicati starts, my system freezes for 10-20 seconds.
then everything works. After a while, the system freezes again for 10-20 seconds. At this point, my CPU is 50-60% loaded and my system is screaming for help.
I think this is because the data is written on HDD and the priority of the task Duplicati.Server.exe is higher.
But my settings have the lowest priority idle.
Noticed this behavior appears when such a file structure is visible

What do I do? I don’t want to give up the copying system.
if you compare it to AOMEI, it does not have such problems, although data copying is the same folders and files.

  --thread-priority (Enumeration): Thread priority
    Selects another thread priority for the process. Use this to set Duplicati
    to be more or less CPU intensive.
    * values: highest, high, abovenormal, normal, belownormal, low, lowest,
    idle
    * default value: normal

might be what you set (if not, what did you set?). If you think that HDD is the bottleneck, maybe try:

–use-background-io-priority=true

The CPU takes off up to 45-60% during the start of the backup task.
Then the CPU drops to 6-10%

Watch Task Manager during the slow spot to see if your CPU or HDD looks more like the limit.
There’s not much that can be done beyond setting both CPU and IO. Did setting IO help any?
Advanced Options does have exotics (e.g.concurrency-*) but try all the simpler ones first…

well test your option –use-background-io-priority=true
and unsubscribe how it worked successfully or not.

Here CPU load of 50%

Still waiting for HDD info (see Task Manager Performance tab). That’s an easier way to get a perceived-by-user system slowdown, especially because your Duplicati settings have --thread-priority=idle (right?). Task Manager right-click can also adjust priorities (but I haven’t tested it).

What exactly is freezing? Some app? Windows itself? Task Manager and screenshots still work.
You have half your CPU power idle, and Windows should be using it – unless HDD is the issue.

Do you know what CPU you have? You can get information at Task Manager Performance tab.

image

Most CPUs these days are at least dual core. You might have a CPU core that’s completely idle.

More device specifications are available at Settings --> System --> About if running Windows 10.
Control Panel --> System --> View basic information about your computer is an alternate source.

Memory limitations can also lead to memory paging which leads to HDD overloading and freeze.

The Windows Resource Monitor program (available from Task Manager Performance tab) has monitoring capabilities beyond what Task Manager has, but first let’s get some basic information.

CPU
image
RAM 16 gB

Windows 7 pro 64x

My settings

--auto-cleanup=true
--full-result=true
--use-block-cache=true
--log-retention=3D
--snapshot-policy=Auto
--allow-sleep=true
--number-of-retries=30
--thread-priority=idle
--concurrency-max-threads=0
--backup-test-samples=1
--tempdir=r:\Temp\
--use-background-io-priority=true

HDD performance statistics from Task Manager are still needed. Can you provide? Here’s an example:

image

Peak was the start of my backup. I don’t see a slowdown, but this is a desktop with a mechanical drive.

This used an older desktop CPU of the same generation as yours. Both should have 4 logical cores, so that reinforces the idea that you’re not CPU-limited with so much idle. What causes the freeze (which is still not described as requested) isn’t clear. You have quite a bit of memory, but I do too, and it runs out: Looking in Task Manager, Duplicati isn’t the culprit. It’s all the browser windows I’m using (like this one).

image

image

On Windows and other virtual memory systems, physical memory (in this case 32 GB) can pass into disk drive paging file,.so what used to run at memory speed (fast) can run at disk speed (slow). Your screenshot doesn’t look like it includes Duplicati memory use, but –use-block-cache=true can raise it.

Author’s description called it a real memory hog. I don’t see any other suspicious options, but getting heavily into unusual options makes unusual conditions which are hard to know. Performance is hard enough to analyze due to the many factors, and the special tools that sometimes go into an analysis.

You can test out closer-to-the-defaults options, and smaller test backups, monitoring as you go along.

If you want to look more closely at the slow spots, you can also use Duplicati About --> Show log --> Live --> Verbose to see what activity happens then. I think –snapshot-policy=Required can get drive busy for awhile at start of backup as it does the VSS snapshot. I can’t know which path “auto” took. Setting “required” would at least let us know VSS ran, and setting “off” would know that it didn’t run.

Note that you need Administrator permission actually in effect to do VSS snapshots, and it will also support –usn-policy which can sometimes avoid having to walk through source files at backup start.

Although it makes a huge amount of output, About --> Show log --> Live --> Profiling might show the activity better than Verbose level does. This would be for the slow spots only, to reduce overloading.

The etilqs file in the original post is from the SQLite database. Sometimes these files are very active however no drive information has been provided. For a real close look, you can try Process Monitor.

How large is this backup, and how many versions? Information for a job will be on the home screen.
Large backups benefit from configuration change. Versions can be thinned out with retention policy.

There’s plenty more that could be done to look at performance, but it’s technical and can’t be done remotely. At this time (after the above), I’m out of ideas unless further experiments are done by you.

Duplicati service does not automatically start in windows 7 was a prior possible performance issue, possibly on the same system whose final resolution wasn’t clear despite some quite heavy efforts…

made the Task Manager screenshots



Task Manager apparently did not show the disk graph until Windows 8 (released October 26, 2012), however your Windows 7 (released October 22, 2009) does give you Resource Monitor, so click on:

Монитор ресурсов (Resource Monitor in Russian by Google Translate)

image (from posted Performance tab screenshot)

Change the Processor Affinity setting in Windows 7 to gain a performance edge confirms that seeing four CPU Usage History graphs is from your four logical cores, and that they tend to track each other. Basically, you’ve got lots of idle CPU in your screenshots, so you’re still looking for source of a freeze which still isn’t described – clearly Windows is not totally frozen – description of it was not provided

I’m also not getting prior requested information from Duplicati live log, so I can’t say what it does then.

At this point, I think I will suggest that you search for a suitable resource (possibly in Russian) to look into performance problems (possibly with Resource Monitor – and I think you also have Performance Monitor). If search engine allows date-limited searches, you can filter out results that may be too new. That’s what I had to do to locate web pages that are still up, that came out when Windows 7 was new.

How to Use the Resource Monitor in Windows 7 shows Disk graph that you can watch during backup. Because you don’t seem to be using up the CPU, Disk is my next suspect, but no guarantees that’s it.

As a side note, Windows 7 no longer receives free support from Microsoft, and is growing increasingly insecure. There are multiple reports on the Internet that free upgrades to Windows 10 are still working from an activation point of view. Whether or not an old laptop will actually run right is another question.
I’ve upgraded three Windows 7 desktops to Windows 10, and have no Windows 7 systems remaining. This makes it extremely hard to give step-by-step OS-specific guidance that fits. It requires research…

If using Resource Monitor says that the disk is 100% busy, that doesn’t in itself explain freeze because requests get queued, however if queue length grows too long, or drive stops responding, that’s trouble.

I use DiskLED with settings below to show me a color-changing graph icon in taskbar notification area:

image

When disk gets really busy, system can get slow. This is just a more user-friendly monitoring tool idea.

If there are signs of a drive problem that might be a failing hard drive, sometimes S.M.A.R.T. has data.
CrystalDiskInfo gives a user-friendly display of the statistics, which are hard to interpret as raw values.

вот что у меня показывает.
А DiskLED не хочет работать ошибка.
Я не могу поставить windows 10 есть на это причины, пока использую win 7


Translation (please use English):

this is what shows me.
And DiskLED does not want to work error.
I can’t install windows 10; there are reasons for this while using win 7

Sorry, I should have shown the top of the screen. Maybe above will work, but this is just convenience.
Resource Monitor or Performance Monitor can give detailed information but it needs an open window.

It’s nice to see that your SMART stats don’t seem to give an issue, so maybe it’s just a busy overload.

Here Resource Monitor this calm mode, duplicati does backup







And now I have started Duplicati




When you say the system is calm, something is keeping the disk 100% busy (if I translate correctly):

Figuring out why an idle system is running the disk as hard as it will go would be a good first step…
For this you can try sorting columns (there are lines not visible now in screenshot) and researching.
I am not hugely familiar with Resource Monitor, but the information you may need is likely in there…

Interestingly, after you start Duplicati the disk is slightly less busy (per blue box) but queue is longer:

It looks like you have a VSS snapshot created, and Duplicati is looking at it. Obviously this uses disk.
Previously mentioned –usn-policy will sometimes save scanning through source files for file changes, however any files that are found to be changed must still be read to figure out what changed in them.

Beyond this, Duplicati uses temporary files for its processing, which can upset people with SSDs who worry about write cycles. RAM disk can solve that. You spoke briefly on these alternatives in this post.

The latest screenshots support my theory that the system is disk-limited, but more analysis is needed.
As previously stated, I leave this to you, and that’s even more true with 100% busy without Duplicati…

No you misunderstood what I wrote.
Now the laptop is in simple mode, duplicati does backups.
As you can see from the screenshots, recorded only does
Chrome browser and the System Volume Information folder

My laptop is not loaded with unnecessary software.
But when running duplicati can not work, the system freezes for 5-10 minutes

Length is getting inconsistent. Is it worse than it was originally?

Fourth request – please describe the freeze symptoms – what works then, or is this total – no typing, mouse movement, movement on screen display, sound, etc.? I don’t see how Duplicati can do that…

You gave two sets of screenshots with these captions. What is “calm mode” if not before Duplicati?

My reading is that Duplicati was not started before “And now I have started Duplicati”. Is that wrong?
Please clarify what “calm mode” section refers to. That was where the disk was showing 100% busy.

What is “simple mode”? That’s not a Windows or Duplicati term I know. Are you saying this is during a backup, and that it’s not showing in the disk stats (which look pretty low now BTW)? Is this good now?

What you need to do, if system is not completely frozen, is to see how things look at time of problems. Performance Monitor can do graphs and statistics too, but it’s up to you to tell it which you want to get.

idle mode is what I personally call so when duplicati is in standby and does nothing.
At this point, my CPU is in the range of 5-8% of capacity.
I have already given so much data screenshots but you do not understand it I was very sad.

If no such problem from other users. it does not mean that it is not for me.