Where did Smart Backup Retention go?

I’m running Duplicati on a Windows 10 workstation and two Windows Server 2012 R2 servers. All are set up to run Duplicati as a service. As near as I can tell, they are set up identically, running, and backing up to different directories in the same destination AWS S3 bucket.

The strange thing is that Smart Backup Retention no longer is an option on the servers, but it is an option on the workstation. I’m sure it was there when I configured the backups, but the option is now gone, and the backups were configured to retain versions forever.

Any ideas as to what could have happened?

One of the servers is configured to use the default upgrade channel and the other the beta channel, but that shouldn’t make any difference.

As far as I recall --retention-policy as an Advanced parameter was added around and the UI for it around, so it should be in

It’s certainly still there in my on step 5 (Options) of the job Edit screens.

I have the --retention-policy advanced parameter and can use that limp along until I get the time to do a reinstall.

It really feels like the UI and the service are out of sync on the servers, but matched up on the workstation.

Out of curiosity, have you tried a hard refresh in your browser?


No, I hadn’t tried a hard refresh. A browser restart, yes, but that wouldn’t make a difference. A hard refresh fixed everything on the one server. Arg!

On the other server, the default browser had been changed back to IE, which I had used in the initial Duplicati install. I changed to Chrome pretty quickly. Somehow the default got set back to IE.

1 Like

So the hard refresh solved your issue?

It did. I consider the issue closed.

Of course, I seem to be good at wiping out my Duplicati backups, because I’ve since done it on another workstation. This time, I think it was because the Duplicati Tray Icon program was set up to auto run at login.

The tray icon auto running at login shouldn’t be a problem unless you’re using the Duplicati service and NOT adding the --no-hosted-server parameter to the auto-run shortcut.

On my lunux mint image, using chrome browser the smart backup retention does not show, if i use firefox its there.

It appears that the Duplicati Tray Icon is not being started with the --no-hosted-server parameter at startup.

This seems to be related to this topic: Service upgrade loses `--no-hosted-server`?

I’ve got an export of one of the backups, but not the other. It would be really nice to find where Duplicati stores them, if they haven’t been wiped out already.

Thanks for the info - I’ve added a suggestion to that topic that might help avoid this surprise in the future.

I believe the job details are stored in the job specific sqlite database, though I’m not sure I follow what you are wanting it.