Synology Connection Lost

I have an issue with running Duplicati on my Synology DS216j.

I was able to install Duplicati, after I installed Mono. In the Package Manager Duplicati is shown as running, but when I try to launch Duplicati I get the following error message.


I’m getting the same error on my ds216j. Don’t know yet what’s the reason. Updated to the latest canary, but every now and then I get this, and the xsrf error…

It doesn’t botter me that much, as I only access the gui few times. But would love to see this fixed.

Closing duplicati and reopening fixes it normally.

Closing didn’t work for me so far, and I need the gui, to configure duplicati the first time, or is there another possibility to do that?

Are you sure it’s running? Check in a terminal if a duplicati process is running.

In ps I have the following line:

root      6569  0.0  7.9  95636 40884 ?        Sl   Nov22   0:26 mono /volume1/@appstore/Duplicati/Duplicati.Server.exe

And mono is listening on Port 8200

tcp        0      0*               LISTEN      6569/mono

Edit: Seems to be something wrong with the Duplicati “App”. When I forward that port via PuTTY, I can access the Web GUI from my PC without any problems.

Edit2: No, I was too fast. After a few seconds I get there the same error message, that the Connection is Lost.

It sounds to me like maybe the Duplicati server is crashing after the GUI connects.

I’m not sure where the log files would be in DSM 6 but perhaps one of these might help?

I have stopped the duplicati package; and started it manually.
nohup mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --webservice-interface=any

Seems like it is running more stable now, no servers stopped errors, no XSRF errors.
If you are running on a publicly accessible machine, you have to be carefull with the ‘any’ interface, as you will be exposed to the world.

I noticed something else… In the package center, starting Duplicati did not seem to work. It never showed as running, allthough it did start. I think it was caused by upgrading Duplicati (via the Duplicati GUI). I removed Duplicati, and reinstalled the latest canary. Seems to be running more stable now when I access via http://my_synology_name:8200. RUnning it inside the DSM still gives server disconnected errors from time to time.

So, I’m suspecting that the upgrade left some files of the older version or something…

So my suggestion: remove duplicati, install the latest canary, and check if that solves your problem.

I don’t have good idea for what is happening, but the “lost connection” message usually means that the server crashed.

When running from Synology’s package center, it is started with a redirect module, and then exposed through Synology’s NGIX server (which is also running the DSM UI). In this setup you are connecting to whatever port DSM is running.

The module that is loaded when started through the package center is checking all requests to ensure that they are authorized by DSM (i.e. that the user is indeed logged in to DSM).

When you access it through port 8200, you are bypassing this feature, sending requests directly to Duplicati (same as you would do if you installed it on a desktop).

1 Like

Removing doesn’t help in my case. I installed it a couple of times. And I installed the latest version, there was no update.

So my Synology should not be accessible from the internet, as I don’t use the Cloud Services offered by Synology to access the NAS from the internet. But nevertheless I cannot say for sure if it is absolutely not possible to access my Synology in any other case from the internet. But wouldn’t it be possible to use something else than any for the interface?

Yes, you can use the IP address of the interface(s) that you want.

For most cases this will work the same as with any as you can access the Synology box from the external IP.

You can set the adapter to loopback which will only accept requests on the local machine. But unless you SSH or similar to the box you are not “local” and cannot communicate.

A post was split to a new topic: Can’t connect to DSM started Duplicati after Synology DSM 6.2 update