Latest release (canary) seems "broken" on Windows 7 (Sorry, no offense!)

Hello! :slight_smile:

Sorry for my bad English…

First thing: many thanks for this tool that is simply AWESOME!

Tried to update to latest canary version and then, Duplicati refused to work.

Windows 7 told me that the application caused an error and could not be launched.
(Sorry, I have no further explainations)

Nevertheless, reverting (uninstall then new install) to solved the problem.

Duplicati saved all parameters so when “restarted”, it was a breeze, nothing to do!

Again, many thanks for this great tool!

Have a nice day. :slight_smile:

Hello @devnull, and welcome to the forum!

Are you using a custom --snapshot-policy? If so, you may be running into this issue:

Hello! :slight_smile:

Many thanks for your answer.

At first sight, no, I am not using a custom “snapshot-policy” (I will double check)

What happened?

  1. new Canary update

Because this is always good news, I just clicked on the “download/install” button.

One minute later, the same notification showed up : “There is a new release”.

Some programs are processing updates one step after one step, so I clicked again to update.

Then Duplicati refused to start (Windows refused to launch it).

There was no error message from Duplicatu because Windows was unable to start it.

Sorry for the lack of answers… :frowning:

I am a Linux user/admin, Windows is quite “cloudy” for me. ^^

If you need me to test some options, I will!

Have a nice day.

Maybe we can help clear things up for you. :slight_smile:

Do you know how to open a command shell (terminal)? If so, running C:\Program Files\Duplicati\Duplicati.GUI.TrayIcon.exe should let you see any error message related to starting problems.

Duplicati has two steps, “Install” and “Activate”. I’ll refer to Upgrading Duplicati by @JonMikelV (thanks!).

“Install” does the download and install. “Activate” quits the current version of Duplicati and starts the new. Default Tray Icon update should just take those two steps as shown in the How-To assuming all goes well. Download gives a progress bar to view. Normally it’s fast, but if the download fails, “Install” is shown again. Advanced non-default installations such as Windows service currently require a manual restart of service.

MENU --> About --> General shows the running version, though sometimes a browser refresh is required.

If a Windows (not Duplicati) error popup happens, it might be separate enough that Alt-PrintScreen could capture just that popup to paste in a forum reply with Control-V. If too much got captured, cancel the post.

Hello guys! :slight_smile:

First thing to do: puting this “alarming” topic (sorry for the title) on “Pause/Bogus/More Info Needed”.

@JonMikelV: thanks for the tip (using a Windows terminal to lauch Duplicati in order to see errors)
@ts678: sorry for the confusion about the way update task works (I am using the French Version of Duplicati)

So, what next?

Bad news: the first “bug” encountered is not reproductible (Duplicati refusing to start)
Goog news: the second “bug” is there again! (There is a new update, do you want to “INSTALL” it? Again and again…)

Tomorrow, I will try the same scenario (Canari v2.0.3.14 to latest update) with Chrome browser.

I suspect a problem with my Firefox which contains many plugins => interactions could be the issue.

But in Duplicati logs, I saw this:

System.UnauthorizedAccessException: L’accès au chemin d’accès ‘agsXMPP.dll’ est refusé. à System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound, WIN32_FIND_DATA& data) à System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost) à Duplicati.Library.AutoUpdater.UpdaterManager.DownloadAndUnpackUpdate(UpdateInfo version, Action`1 progress)

Maybe a hint?

To be honest, I have not read the documentation of Duplicati.

=> It justs works! (but the amount of available parameters is just insane…)

More news later!

Have a nice day.

That UnauthorizedAccessException error translates to something like Access to the path ‘agsXMPP.dll’ is denied. and the rest looks like it’s trying to delete a directory. If you have a timestamp on that, maybe you can tell if the error happens right around when “Install” is attempted – and since you tried many times maybe you have many?

Downgrading / reverting to a lower version talks about where your “updates” folder would be, and sometimes an install means a deletion of an old update (which might be what you’re seeing), however I think it keeps one back, so would try to make, would keep the older before, and would remove the even older one. Maybe someone else can think of why else Duplicati would be trying to delete this. If you want to see the activity directly (instead of listening to me speculate) you could install Sysinternals Process Monitor to monitor the file activity around agsXMPP.dll, and see the folder. Once you find it, you can try moving it out of the updates folder manually (as the How-To mentions) and that might save Duplicati from needing to delete it, however the deletion is supposed to be possible. Are you doing any XMPP notifications that might be holding the file open? Sysinternals Process Explorer (or Handle, if you prefer command line) can help find open files. I’m not even sure an open file would throw THAT error. I’m finding some reports that a read-only file will do so.

Or maybe the browser theory will work. Also, note that the timing observation I began with may support/refute my thinking about what that delete is about.

Let’s make sure we’re looking at the right thing. It sounds like Duplicati is starting for you but you can’t update, right?

I suspect changing browser won’t make a difference as the update happens external to it - but it’s certainly with a try. :slight_smile:

My guess is that there is a failed update that Duplicati is partially using at the same time it’s trying to do the update.

Try looking in the updates folder as @ts678 suggested and see if there’s already a subfolder. If so, stop Duplicati, delete that folder, start Duplicati again, and try the update.

If that doesn’t work you can always use the regular installer and install “over” This will effectively update your base version and ignore anything older in the updates folder.

Oh - and as far as I know Duplicati doesn’t currently clean up older updates, though it has been discussed as the process that checks the updates can cause the service to time out if there are too many older versions in there. And @ts678 is correct, Duplicati (but not manually) downloaded updates are indeed auto-cleaned.

The most thorough discussion I’ve seen is Question (and problem?) regarding successive updates #3427 which is what I tried to write up. Basically, you’re capped at what has been described elsewhere as “base + 3 updates”.

Thanks for the link - I guess my education for the day has already started! :wink:

I do “lots” of upgrade/downgrade tests so it’s likely I fall in the “manually unpacked updates aren’t auto-cleaned” camp.