Failed to connect: No such file

Yeah, that’s an option — the thing is, I want to use this stuff remotely and I really only wanted to allow SSH connections (on a non-standard port!)

But I’m glad to know I’m not the only one running into this problem. Who reports such bugs?

I guess you could log it to github.

Webdav tunneled over ssh? I run on non standard ssh port as well. Did you try on standard ssh port?maybe issue is there?

Did you check with other clients (winscp etc) if you can reach it over sftp? To rule out synology itself.

I"m still using the standard ports — once I had it up and running I will change to non standard port.

And yes, I can reach the Synology over SSH from a terminal window on any other computer in my network (Mac, Linux and even (oh god!) winscp on Windows. Once there I can create files and folders, list them, etc without any issue.

Also, I installed webdav on the synology, enabled both http and https ports but when I try to test from duplicati I get an error “Failed to connect: The remote server returned an error: (405) Method Not Allowed”

However, WebDav is clearly working fine because I can open my home folder from a Mac (same Mac that’s running Duplicati by the way) using webdav credentials and port with no problem.

It seems to me that Duplicati is just not ready for prime time. These are really basic issues (just connecting) and so it just shouldn’t be this hard, particularly since I can connect to the same services from other apps with no issue

I agree, it really shouldn’t.

The WebDAV “(405) Method Not Allowed” error might be the same one mentioned here:

That being said, it sounds like you’ve tried a lot of different methods (thanks!) but just keep running into issues. I know other Synology users are using Duplicati without such issues (at least not that they’re reporting) so I’m stuck assuming your environment or implementation is set up in a way that Duplicati doesn’t handle well.

It would be great if you had the time to help us iron out exactly what the issue is, but without us being able to guarantee results within a particular time frame I certainly understand about the time pressure of dealing with CrashPlan’s announcement.

If you end up finding another tool that works for you please let us know what it is (and what didn’t work for you) in case other Synology users trying out Duplicati run into issues like yours. We’d much rather have people backing up with another tool than not backing up at all!

And keep us in mind once your new tool is in place - Duplicati is actively being developed so at some point we’ll hopefully figure out what’s been causing you so many issues and get it resolved. :slight_smile:

found it!!

You should provide the path as follows:

Not using /volume1 or /var or…

Discovered that by connecting via ftp, and the url did not have the /volume/ or /var path in it.

Could you please confirm this works for you as well?


1 Like

Great! Though I can’t confirm it (no Synology box, saddly) but perhaps @David_Jameson hasn’t uninstalled Duplicati yet and can give it a try…

Bloody hell — that worked! You know, when I was experimenting with WebDav and opened a Finder folder to the Synology, I noticed there was a single “home” folder there as well as the “homes/user” folder. I actually went looking for that ‘home’ folder but couldn’t find it anywhere.

So ok, did that, and I have started a backup of one hard drive. Keeping my fingers crossed — and THANKS so much for figuring it out.

Of course from a technical point of view, I’m curious as to WHY this worked and why the previous mechanisms did NOT work?

you are welcome & good luck!!

my 2 cents: synology exposes the home folder differently than a normal Linux-based OS…

Probably google outside duplicati can help us further here… As I don’t think this is duplicati related…

Wow! I had no idea you needed to do that. Awesome that you figured it out.

Now that I know this, I think you could have found out by using FileZilla or CyberDuck to connect, as it would show the paths.

I do recall that Synology monkey patches sshd with some login integration. It sounds like they patched sftp as well such that it does not expose the /volume stuff, which is really confusing as they have not (and could not) patch normal ssh access the same way.

1 Like

it was with an ftp client (firefox :slight_smile: ) that I noticed the path difference…

1 Like

So is your hard drive backed up now?

If so, please consider clicking the checkmark in Wim_Jansen’s post so other users know that’s the trick that slaved the issue. :slight_smile:

God no, it still has 361,000 files (522GB) to backup — I’m assuming it’s going to be 3 or 4 more days given that we started with 750,000 files or so. But you’re right - the suggestion worked so I’ll mark that.

1 Like

I don’t have CyberDuck any more but I just tried to connect using Forklift and it displayed both “home” and “homes” and if I ask for the url of the former I just get


so yeah, that would have been a clue.

I’m having the same issue - but with my own NAS which runs a mix of Debian testing and OpenMediaVault. I’ve set up a backup using borgbackup, which is working fine, but I wanted to try Duplicati just for fun (well actually it supports Amazon Drive out of the box, which is what I’m looking for).

I have a ‘backup’ user on my NAS who has a home directory residing on /export/NAS/Backup - borgbackup is just putting its files in a directory relative to the home directory of that user.

If I try doing the same thing with Duplicati I get the ‘Failed to connect: No such file’ error. Just to be clear, I’m using SSH file transfer (SFTP).

I was trying with ‘duplicati/pcname’ or ‘/duplicati/pcname’ or ‘~/duplicati/pcname’ or ‘./duplicati/pcname’

I also tried connecting with FileZilla using SFTP which works fine, I can access the folder, create stuff, delete stuff. Just like borgbackup does as well.

I also created the directory and tried again with duplicati - to no avail. If I leave the directory empty it says okay but ends up with a permission error. Troubleshooting is hard because I have no idea where Duplicati is trying to go.

Solution: This still seems like a bug in Duplicati:


into the folder.

I find that rather strange and completely counter intuitive compared to how every other tool at my disposal handles this.

Hello Wim,

Could you maybe elaborate a little bit on that, because I still can’t make it connect. I have a Synology NAS and I entered the share and folder now like: /backup/documents

Not quite sure what you mean with: “provide the path as follows: /home/duplicati
instead of:
/volume1 or /var”

Thans in advance :slight_smile:

Hello @Zonal, welcome to the forum!

Can you clarify what you mean by “can’t make it connect”? Do you mean you can’t get to the web based UI, can’t get Duplicati to see the paths you want to become a up, can’t get the job to connect to the backend, or something else?

Did you follow I this guides for your setup? If so, if like to figure out where it didn’t work for you.

1 Like

Hey Jon,

Thanks for the quick response and sorry for the lack of information. I wasn’t actually trying to install Duplicati on my Synology NAS, I’m running it on Windows and am trying to back up to a Synology NAS through SFTP (SSH).

Now I have setup a FTP server on my NAS and that works fine, but when I try to setup a back up profile through SFTP and click “Test connection” I get the following message:

“No certificate was specified previously, please verify with the server administrator that the key is correct: ssh-rsa 2048 ??:??:??:??:??:??:??:??:??:??:??:??:??:??:??:?? Do you want to approve the reported host key?”

I ‘blanked’ out the key for posting it on an open forum, not sure if that’s needed in this case…

Then I click ‘Yes’ and I get the message: “The folder /backup/SFTPtest does not exist. Create it now?”

I click ‘Yes’ again and then I get the error: “Failed to connect: No such file”

It doesn’t make any difference if the folder was already created beforehand. I keep receiving this error. So I saw the possible solution mentioned by Wim, but I’m not quite sure what he means. That’s why I asked if he or somebody might be able to clear that up! :slight_smile:

Thanks in advance!

I’m no longer using my NAS as a destination, so can’t check.

My suggestion would be to use a ftp client, connect to your machine, browse to the folder you want Duplicati to use, and see if the client exposes the path. That’s the path to use.

This is how I found the path to use.


1 Like

I’m so stupid… forward slash instead of backslash. Windows uses backslash so I forgot…

Thanks for the quick reply though! :slight_smile:

Just in case somebody is struggling with configuring SFTP on a QNAP: the folder is /share/backup, where backup is an example root folder in the QNAP File station for your backup.