Duplicati 2 + OneDrive Business


Just checking if this is normal or not. I use Duplicati 2 with OneDrive Business to make scheduled backups(encrypted). I have 2 jobs, one from a local PC and one from NAS, each with different PATHs on OneDrive. I can backup and restore without error, but I cant see any files on destination - OneDrive. Any ideas why? :slight_smile: Are this files hidden and automatically excluded from syncing?! Thank you.


I don’t have the “Business” version, but in the normal OneDrive you can see the files.

I would expect that you can at least see the space being used? Otherwise it could be that the files are actually not stored on OD4B but locally on disk?

Do you see any problems on my setup? How can I backup locally if destination is OneDrive?!? :slight_smile:

I just made a test now. I took a new PC, installed duplicati 2 on it and Direct restore from backup files. What happened?! I got my all my backed-up files to the new PC from OneDrive.

Interesting, I don’t see any usage under Storage Metrics. Check the screenshot.

In that case I am guessing that the account is somehow connected to “something else”, such that the files you see are your “personal” files (and that is the quota you see) but the stored files belong to another account. Maybe there are multiple accounts to see somewhere in the OD4B interface?

No other account. I can share my screen via Teamviewer if you want to check that out.

I opened a ticket by Microsoft. Maybe is a Bug…but I have no idea how can be that a bug…on OneDrive…is like a black hole :slight_smile: I can give you also for testing a business account if you want.


Yes, that would be great. There are many questions about od4b, but I can never really answer as I do not have an account.

sent you a PM with credentials. :slight_smile:

1 Like

Hi, so any news on this topic? I have the same issue with OneDrive for Business.
Files are not uploads to OneDrive for Business.

I guess I have wrong Duplicati setup, but it shows me the test is passed OK.

the Path on server field seems to be a little too short.
Suppose your associated email address is name@domain.com.
The Server and port field should be: domain-my.sharepoint.com
The Path on server field should contain: /personal/name_domain_com/Documents/Docs (Assuming that Docs is a folder that you created in your SharePoint environment).


Thanks! It works now!

Hint: to see files in OneDrive for Business you should refresh (F5) the whole web page.



I have the same problem. I can backup and restore from onedrive business but I don’t see the backup files on onedrive. It is empty. How did you solve it ? Thx

Hello @rosdniw and welcome to the forum!

If refreshing web page as mentioned just above didn’t help, maybe Where are my OneDrive backup files? will. Beyond that, I probably can’t help much beyond forum searches because I don’t have OneDrive for Business.

I finally found my mistake. I wrote « personnal » instead of « personal » in the file path.

Hi, I’m new to this forum and am a regular Duplicati user on a local Backupdisk. Now I want to use Duplicati with a Onedrive for Business account on two pc’s at my customer’s office. I found the correct login and config data, inserted it in Duplicati and it does not connect to the sharepoint server. When I use the exact same credentials on my own PC it works like a charm…Do any of you have an idea about where to start looking?? I read the post of Kees-z #11 and did exactly what he suggested. And of course it works on my own PCn just not my customers PC. I change firewall settings, anti-vir settings and what not, but nothing changes…

I hope to hear from you

Piet Koenekoop

Hi @pietkoenekoop, welcome to the forum!

Can you post:

  • what version of Duplicati you are using
  • on what OS
  • does the “Test connection” button work
  • what the actual error message is

Hi, I’m using Duplicati on Windows 10 64bit.
The test connection button gives me the following error message:

These are my connection settings:
I connect to the PC over Teamviewer, could that be an issue?


You should move to the v2 backend for onedrive.

Hello Wim, that did it!!! thanks a lot.


1 Like