Default filters warning in 2.0.4.5_beta


#1

Upgraded a Linux desktop (Ubuntu 18.10) from 2.0.3.3 to the latest beta and getting this. No other changes – just ran the update from the GUI. I do have Linux filters enabled.

        2018-11-29 12:50:15 -05 - [Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --default-filters is not supported and will be ignored

#2

I got this warning to go away. It seems to have had something to do with how Duplicati converted the old OS filter setting to the new filtering options. I had to remove the filter from page (3) of the config wizard (under “filters”) as well as from page (5) near “Advanced Options”, then add it back in using the new “Exclude Filter Group” = Default Excludes.

Thanks,
Mike


#3

I have the same issue. The only filters I have defined are to exclude system/hidden/temporary files and files > 5GB. I removed those filters on page 3, saved the profile and then reselected them and saved again. I still geht the error message.

I cannot find the settings described on page 5.

What should I try next?


#4

This post helped me understand the new settings and where they are:

https://forum.duplicati.com/t/release-2-0-3-5-canary-2018-04-13/3216/2

Also, I did not see the new settings in the GUI until I did a CTRL-F5 hard refresh. Not sure why, but it seems like the Duplicati web GUI pages stay cached more than any other web page so You need to do a hard refresh after changes/upgrades. I forgot CTRL-F5 existed, because I haven’t had to do that to a web page or web front-end since Netscape in the '90’s.:grin::older_adult:


#5

Thank you, that solved it! I also had to do CTRL-F5 to see the options at all. It also brought the progress bar back.


#6

Well, I thought it solved it. But now backups (ca. 180GB of data, only a few MB changed) take an hour instead of 5 minutes. Are the settings shown in the attached image correct or do they cause “double” filtering?


#7

There’s a performance issue with regex filters (the default and cache filters contain one):

Can you try removing the filters temporarily to see if the performance is improved?


#8

Thank you @warwickmm ! I would rather not turn filters off completely since that would mean backing up heaps of useless data to paid storage. However, the performance issues started immediately after turning on the “default excludes” regex filter after upgrading to 2.0.4.5. If necessary, I can create a spearate backup set and do some more testing, but I think others have done that already.