Dashboard won't display - stuck on "waiting for localhost"

I’ve been using duplicati for a few months now without problems. Today when I try to open it from the tray icon (which is red) The browser window opens but waits on “waiting for localhost” and the dashboard never displays. I’ve tried quitting duplicati and restarting it; restarting the PC (windows 10). I even tried downloading the latest version and installing it but still the same problem.

Is there any way for me to look at the logs to see what is going wrong? Any command line things I could try to get it working again?

Which version are you using? Which OS? Did you already try doing something via Duplicati.CommandLine.exe? If so, does any error appear? Sorry for the high number of questions

Hi, I’m using on Windows 10. I did try to run some commands using Duplicati.CommandLine.exe from a command prompt but I’m not sure what command to try to run using the CLI.

For example, I don’t know what to put for the [storage-URL] part. My data was backing up to Backblaze B2 and to Google Gsuite. Thanks for any suggestions.

At first Duplicati.CommandLine.exe system-info might contain some useful information, probably not though. A way to see the logs is by accessing directly the db, but I don’t want to recommend that before trying anything else.

Can you try launching the Server or the TrayIcon from the terminal and see what is the output?

I tried Duplicati.CommandLine.exe system-info but it didn’t seem to give any useful info.

I ran Duplicati.Server.exe from the command line and it just hangs - without returning to the prompt. There is no output. It doesn’t show up in the task manager. If I CTRL-C to end it, then run it again I get the message
Another instance is running, and was notified

Running Duplicati.GUI.TrayIcon.exe from the command line produces no output.

I don’t think it’s supposed to return to the prompt, but beta said a single line on its way up, e.g.:

Server has started and is listening on, port 8200

which for some reason beta doesn’t do, but maybe this was a side-effect of the logging rewrite.
–log-file logging can show a line like that (probably also need –log-file-log-level=Information or above) however most of the logging seems to be on Duplicati’s primary work, with the web UI not having much.

Make sure you’re on Details tab, or if on Processes tab make sure you look at Background processes.

This is another sign that Duplicati.Server.exe was actually up. I hope you can find one in Task Manager because the solution for that is to kill the process. Most Duplicati processes come in pairs, with the child process running any update that’s installed, and doing the actual work. A Ctrl-C kills only parent (bug?).

I think Duplicati.GUI.TrayIcon.exe differs from Server in that it gives your command prompt back, but on Windows it’s not able to produce output. There might be a workaround involving output redirection, but configuring a log file might be more likely to work if you want to see if you can get any useful messages.

Possibly another thing to try would be to use netstat like the below, to see what’s listening on what port.

netstat -ano | find ":8200"

Then take the LISTEN PID and look it up in Task Manager details, then see if anybody is taking “:8300”.

The error sounds like it connected to something (a good first step), then didn’t get any HTTP response. Testing with a different browser might be helpful, and also testing with Duplicati completely down (which probably results in a different message about the failure) would help the understanding of the situation.

Does Task Manager Performance tab show anything noteworthy in Disk or other graphs during startup?

Thank you for the detailed reply. I had already tried the netstat command in case it had been listening on a different port or something, but it was the correct port.

However - good news! I opened it in firefox and the GUI opened as normal. Don’t know why I didn’t try that before. So I am back up and running.

Not sure why it will no longer open in Chrome though? I’ve tried clearing cache, etc, but it still won’t open. Its been working fine on chrome for months previously.

Do symptoms and workaround match Interface stops working in Chrome perhaps?

might give other ideas, but you already tried most of the regular browser-fix things.
Perhaps clearing cache doesn’t clear in-use data, so Control-F5 refresh will help?

Yes, That’s what happens. It works in incognito mode in Chrome (I hadn’t tried that before). I am also using Bitdedender as one of the other users was, but I can’t work out what to whitelist to make it work.

So it looks like its either to do with Bitdefender or with cookies.

If it works in Incognito I’m guessing it’s NOT BitDefender - though you could probably test that by disabling it for a few minutes and see if the Duplicati UI starts working. If you do this, don’t forget to turn BitDefender back on!

As an alternative to Incognito you could also try a Guest User profile in Chrome. It opens a new user profile but NOT an incognito window.