Backup version numbering off by one?

While struggling to get my feet back on the ground with another issue, I played with selectively deleting backup versions until I reach a working state again.
I ran a DELETE command with --dry-run and versions --version=0, 1, 2, 3, 4, 5. Comparing the version numbers I get in the “Restore” dialog to the ones listed in the command’s result (in the GUI) I found that they seem to be off by one, e.g.: in Restore, version 0 has a time-stamp of Jun 29, 11:29, version 1 is from June 29, 11:16
whereas version 0 in the command’s result has the time stamp of 11:16, which corresponds to the one of version 0 in restore.
FWIW, both backup versions are probably incomplete (because they failed to complete) - the one from 11:16 is labeled “partial” in restore - but I don’t think it should matter for this question.

What am I missing to understand this mismatch?

Hello, I tried your steps but couldn’t reproduce the problem. The versions shown in the DELETE --dry-run matched perfectly with the restore dropdown list.



What version of Duplicati is this?

When you say “both”, which are those? The partial backups might be the key here. Normal works for me. Partial, on the other hand, just got created (then redesigned) prior to beta. Might be a missed bug.


reffering to my screenshots: I mean the one from 11:29 and from 11:16. The latter is marked (partial) but the latest one isn’t. However both runs failed. So I don’t know what to think of “partial” …