server appears to be broken on Synology

Yes, that’s exactly right. I had no idea about that “official” URL! What are the main reasons for using one over the other?

In reality, probably none, but it’s the URL that DSM sends you to if you use their menu -
as I suspect most folks do after installing it from Package Center unless they’re already familiar with Duplicati on some other platform. I know I only discovered port 8200 while I was struggling to diagnose the problem that started this whole thread - I had simply bookmarked the other URL after DSM sent me there the first time. :slight_smile:


Thanks for the tip.

For both URL’s (See below), it’s not working - or… Well… It works for a few sec. I’m able to navigate through the options, but hereafter this shows up:


If i navigate to About, i’m able to open up the tabs, before i got the Connection Lost:

But fx. About > Show log > Stored is just stuck at “Loading”…

After Connection lost shows up, i can simply reload the page, and the GUI works again.

I can see that the error shows up after a call to: https://[SYNO-IP]:5001/webman/3rdparty/Duplicati/api/v1/serverstate/?lasteventid=-1&longpoll=false&duration=299s, and the check for serverstate goes over and over again:

I’ve tried to find log-files in /var/packages/Duplicati but i can’t find anything usefull. And i can’t find anything interesting in /var/logs.

If i look for mono /volume1/@appstore/Duplicati/Duplicati.Server.exe in top, i’m able to find it under pid 9640.

Can you check the CPU level on your Synology? I’ve noticed if my CPU is pegging on my unRAID box then my Duplicati Docker container tends to show the “connection to the server is lost message”.

It’s actually happening to me right now - and oddly most of the CPU is being taken by Duplicati (which is OK - as I’m stress testing). :slight_smile:

3-6 procent CPU. It’s almost at idle. Meeeeh. But. thanks for the point!

I’m not sure what i can do. Any advices?

Unfortunately not - I don’t have a Synology myself so can’t do any comparison testing.

I don’t suppose you’re using one of the models mentioned here that are reported to have issues…

Sorry if I missed it but did you try the steps @jetkins posted above? It helped some people that were getting the “connection lost” messages on

This is probably not related, but do you know what version of mono you are running?

No, it’s not listed :slight_smile:

Yes, see below. Other details is listed in the same post.

No - guess i missed that. But, doesn’t work. Or - well, it works if i run it manually:

mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --webservice-interface=*

I edited hostname (added a few, seperated with ; as suggested in the text), saved it, Ctrl+C, checked for other processes, and started the service through the Synology-solution. Same error, once again.

If i run it manually, it’s clear to see that i have the right connection to the backend, cause language is in danish (I’m from Denmark), and not english as is it on the sessions where it’s reporting the error after a few seconds.

I also tried to start manually again, and confirmed that the hostname-value was still defined (and it was).

Whoops - sorry about that. I hadn’t figured out you were posting in both places. :slight_smile:

I went ahead and added your DS414 to the list in the other topic and included a link to your issue reported here.

I was hoping you were using the ‘bad’ mono version so we could chalk it up to that, but apparently that’s not the case.

So it works in Danish with a manual run but not English with a through-the-GUI run?

I don’t suppose you could try a manual run in English to see if that also crashes?

Np :slight_smile: And great.

I could give it a try. Am i able to change that in one of the configs?

I’ve added a few things to the start-script, to get a few more details. But sadly i can’t find any logs.

The following advance options is tried - no 1:
--log-file=/var/packages/Duplicati/logs/log.txt --log-level=profiling

And no 2.:
--log-file=/volume1/@appstore/Duplicati/log/log.txt --log-level=profiling --webservice-interface=*

I can see that the paramters is added to the end of the command - and logging is also working, and ansers is on :8200 :

root     10689     1  0 19:14 ?        00:00:02 mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --log-file=/volume1/@appstore/Duplicati/log/log.txt --log-level=profiling --webservice-interface=*
root     10819 10689  1 19:14 ?        00:00:07 /volume1/@appstore/Mono/usr/local/bin/mono-sgen /volume1/@appstore/Duplicati/Duplicati.Server.exe --log-file=/volume1/@appstore/Duplicati/log/log.txt --log-level=profiling --webservice-interface=*

Here is a fresh log with advance options no. 2, where i just started Duplicati, visited it, waited for the message to show up, and stopped the service:

The same error happens on http://[SYNO-IP]:8200/ngax/index.html, with the advance options.

SO... That means it's time for give the manual run another try, with logging enabled:
mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --log-file=/volume1/@appstore/Duplicati/log/log.txt --log-level=profiling --webservice-interface=*

And… It works just fine, and the Danish GUI shows up:

The only thing found in the log this time, is:

2019-01-09 19:37:24 +01 - [Information-Duplicati.Server.WebServer.Server-ServerListening]: Server has started and is listening on, port 8200

EDIT: And more debug…

Tried to tunnel into my NAS on :8200 with --log-level=profiling --webservice-interface=* in use, but it’s still the same error.

If i run it manually it’s working just fine with tunnel to :8200 on the Synology…

I also renew my certifiate, cause… why not? Still same issues in the log.

Regarding Danish vs. English, i don’t think that it’s the reason, cause these details is just based on the language of my browser… And the only reason why it it’s not jumping to Danish on DSM, is cause the connection got lost. I actually think that no connection is transfered between the GUI and the Duplicati backend - or, at least just a bit… But… What do i know :stuck_out_tongue_winking_eye: I

I also changed a few settings, fx. theme and so on, but after loading up through DSM on :5001 it’s back to the default things, so i don’t think that the GUI even connects to the server.

Lastly i have another question… Why is it that the following process keeps running, after i stopped the service in DSM? Is that a bug? (Normally i kill it manually)

root     15102     1  0 19:57 ?        00:00:08 /volume1/@appstore/Mono/usr/local/bin/mono-sgen /volume1/@appstore/Duplicati/Duplicati.Server.exe --log-file=/volume1/@appstore/Duplicati/log/log.txt --log-level=profiling

An earlier post links to the solution, but it came after It’s a tiny edit if you want to do it manually.

Oh, embarrassing. I had my full focus on the other issue. I really hope that someone has a suggestion/fix for this. I’m unsure why there’s even a problem with running it by DSM, now that it works just fine by running it manually through SSH.

Thanks for the information about the hotfix to the script :slight_smile:

Do you have your user added into http group as per step 3) in the INSTALL instructions? User needs to be added even if the user is admin level. After adding my user my connection lost issues disappeared.

Are there any “hard” symptoms of missing that step?

I’m hoping to add an"If X happens check Y" troubleshooting block to the instructions. :slight_smile:

No hard symptoms. The install goes through, the web interface initially opens, then shortly after it’s overlayed with “Connection lost …” message.

Steps to fix this issue:

  1. Add current user to the http-group
  2. Jump out of the window

Another embarrassing recognition. I changed multiple things on my NAS, after going from 4*3TB to a single one, due to all the way to mush space for my personal stuff (Actually started from scratch). I skipped step 3 in the instructions, cause my user used to be in that group… But like everything else, “used too be like…” is not always “as it currently is”.

Hours wasted, and now i’m flying.

TL;DR: Read the damn instructions, and double check if you arn’t 100% sure.

Thanks Brano :smile: :+1:

Glad you figured it out! Added this as first item in “troubleshooting” section. :slight_smile:

1 Like

Am i the only one experiencing, that i can’t get access to my NAS, however it seems running fine, if i look at the status LED’s. Can’t get access through SSH, NFS, DSM (web) and so on… This started after Duplicati was enabled. I’ll just like to hear if other have seen anything like that before, before i starting check for other issues.

If i use the soft-button to power it down, it’s starting the process, but it keeps blinking like it normally only do for a few secounds. So the only way is to take the power, and bring it back up.

I’ve never experienced that and don’t see how Duplicati could be the cause.

Can you ping your NAS? Have you tried connecting by IP address?