Where are my backup files?

Hello, I’m new here, and therefore, I might not make much sense initially, or be able to understand what you say on the first go 'round.

I installed Duplicati on Ubuntu Mate (I’m also an amateur linux user). I have a router that supports attaching a hard drive, to which I set up a samba connection: smb://WORKGROUP;routeruser@tplinkwifi.net/volume(sda2)

That’s how I connect to it from linux. I created a Duplicati backup targeting: smb://WORKGROUP;routeruser@tplinkwifi.net/volume(sda2)/Duplicati
as the backup location. Duplicati did not complain that I recall.

I ran the backup, it did it’s thing. I restored from the backup to a different location. All looks good.

Except, I looked on my shared drive, in the Duplicati directory - and there are no files.

I tried everything to see the backup files where I expected them to be. They are not there. I finally removed the drive from the router altogether, yet I still able to restore from the backup!!!

Okay, where are my backup files, or how can I find out where they’re supposed to be? I assume they are somewhere on my internal drive, but I haven’t found them yet (searches for *.dblock.zip haven’t come up with anything, but once again, I’m an amateur, and I could be messing up the searches).

I wasn’t able to see anything in the web ui that would tell me the details of my backup - in case I misremembered or mistyped something (this would be great to add, in my opinion).

Any help is appreciated. Thanks!

Hello @MisterAcoustic, welcome to the forum!

Did you use encryption for your backup job? If so the files might end in .aes so you might be better off doing a search for .dblock..

Could you use the job “Export” -> “As Command line” command and paste your setup in a post (be sure to remove anything personally identifiable or secure such as email address, passwords, etc.)?

Hello JonMikeIV,

Thanks for the reply and the welcome.

Yes, I did use encryption - I will re-start my search for only the dblock portion, while I try to get set up to peek in the database file the configuration mentions.

Here is my configuration export:

mono /usr/lib/duplicati/Duplicati.CommandLine.exe backup “file://smb://WORKGROUP;routeruser@tplinkwifi.net/volume(sda2)/Duplicati?auth-username=nope&auth-password=nope” /home/stan/Documents/ /home/stan/Downloads/ --backup-name=SMBTest --dbpath=/home/stan/.config/Duplicati/SDGGAXWNQB.sqlite --encryption-module=aes --compression-module=zip --dblock-size=50mb --passphrase=nope --disable-module=console-password-input

Let me know what else I might try beyond looking for the .aes version of .dblock, and trying to get a look in the sqlite database.


Found 'em!

Ha :). I would have gotten there if I had more time to think about the path in the config, but as it is, one of my long-running searches completed, and I spotted them.

For those following along, my ‘smb://’ was turned into ‘file://smb:/’ - note the single slash at the end :).

So, it really knew nothing about my mount - it just decided to make a directory named ‘smb’, then a directory named ‘:’ (which really threw me for a moment). Then, I don’t know what it did. It looks like it made a directory named ‘WORKGROUP;routeruser@tplinkwifi.net’ - but I can’t cd into it at a bash prompt. However, it does display like that in the ubuntu file explorer when I opened the parent folder of the files that I found.

Being a linux newbie, I would have thought that some of those characters would have played havoc with the path creation process, but I guess not :).

Okay - even though I currently plan to move my hard disk off of my router - my question remains - what’s the right way to set up a samba share as a backup destination?

Thanks in advance,

It sounds like you’re running into the same thing as mentioned here:

Unlike Windows, Linux is very generous in what it allows in file / path names. :slight_smile:

I dabble with Linux, so I might be wrong, but I believe you can escape certain characters with a \ backslash, so you if you care to play around you could try something like cd WORKGROUP\;routeruser\@tplinkwifi.net. Not that it will help anything, but you might learn a little more about the Linux CLI. :slight_smile:

When running Duplicati in Windows, a samba share can be access just by the normal UNC path (e.g. //WORKGROUP/volume(sda2)/Duplicati) however on Linux you would need to mount that share to a mount point then use that “local” mountpoint as your destination.

As a slightly-more-than-newbie Linux user, I would assume this means you either have to have that moutpoint always connected or you MIGHT be able to mount and unmount in --run-script-before-required and --run-script-after scripts, though to do it “right” you would likely want to verify it’s not already mounted before mounting and that it IS mounted before unmounting.

Note that there is an older Github ticket about this, along with some comments about potentially adding a CIFS client to Duplicati. Maybe adding a bounty to this might help it come about more quickly!

Thanks very much for your help, and all the information.

I guess the only remaining questions are about linux and mounting and smb/cifs, which I don’t really expect to have answered here. Basically, I can look at the share using the ubuntu mate file explorer, so somebody has a ‘mount’ somewhere. I don’t remember how I set it up (not least because I had to try what seemed like a dozen different ways just to get it to work at all), and so I’m kind of lost regarding why the mount isn’t really visible anywhere.

Oh well, I guess it’s time for another dose of research to see if I can learn enough about this mess to make it useful to me.

Thanks again,

It’s likely that the file explorer has a CIFS client built in - which is what Duplicati needs to be as easy to use as the explorer. Of course it’s also possible that the share is actually mounted on your machine in which case Duplicati could use that mount point.

When you see it in the file explorer, what sort of “path” does it appear to be on? (If you want to, you can just paste a screenshot into a post - though editing it down to just the stuff that you want to share would be a good idea.)

There are a number of users here (such as @Pectojin) who are quite good at helping people get stuff working on MacOS and Linux, so if you don’t find anything elsewhere check back here. :slight_smile:

The file explorer likely queries the server without emulating a filesystem on your disk. You will want to use mount or smbclient to get a basic network share mounted, for example

# mount -t cifs //host/share /mnt