V2.0.4.14: Create-Report fails


#1

Attempt to create a report for the devs regarding the Root drive path fatal error bug and found that this fails too:

System.Data.SQLite.SQLiteException (0x80004005): SQL logic error or missing database near “)”: syntax error
at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain)
at System.Data.SQLite.SQLiteCommand.BuildNextCommand() at System.Data.SQLite.SQLiteDataReader.NextResult()
at System.Data.SQLite.SQLiteDataReader…ctor(SQLiteCommand cmd, CommandBehavior behave)
at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery(CommandBehavior behavior)
at Duplicati.Library.Main.Database.ExtensionMethods.ExecuteNonQuery(IDbCommand self, Boolean writeLog, String cmd, Object values)
at Duplicati.Library.Main.Database.LocalBugReportDatabase.Fix() at Duplicati.Library.Main.Operation.CreateBugReportHandler.Run()
at Duplicati.Library.Main.Controller.RunAction[T](T result, String& paths, IFilter& filter, Action`1 method)
at Duplicati.Library.Main.Controller.CreateLogDatabase(String targetpath)
at Duplicati.Server.Runner.Run(IRunnerData data, Boolean fromQueue)

I tried to create a report both from the Web GUI and from the command line. Same result each time.

Tried again after reverting back to v2.0.4.12 (futzing with the files under %LOCALAPPDATA%\Duplicati\updates) but then got this error message:

The database has version 9 but the largest supported version is 8. This is likely caused by upgrading to a newer version and then downgrading. If this is the case, there is likely a backup file of the previous database version in the folder C:\Users<xxxxxxxx>\AppData\Local\Temp.

No such backup appears to exist.

At this point, I’ll see if I can restore the database from a previous backup (though, I’ll keep the current one).


No errors,but no backup for mssql 2005 database
#2

Found a backup in %APPDATA%\Duplicati (as opposed to %APPDATA%\Local\Temp suggested by the error message in the OP) but then I get the

Found 2 remote files that are not recorded in local storage, please run repair

error. Given that the last time I tried a repair, I gave up after 2 days and just recreated the backup from scratch, I’m somewhat reluctant.

Also restored a database from another backup with the same issue. At this point, I’m kinda stuck.


#3

Tried CREATE-REPORT (running v2.0.4.12) for a backup that hasn’t been touched by the v2.0.4.14 update (some backups I run weekly) and that completed without issue.