Update to 2.0.3.3_beta_2018-04-02 failed?


#1

I thought I’d updated my Duplicati installation to 2.0.3.3_beta_2018-04-02 the other day. Over the last couple of days I noticed I was getting backup warnings saying the “retention policy” option was not supported.

I cleared my browser cache and checked by backup configuration and the Smart Retention option is no longer there.

I also see the following in the logs:

8 May 2018 22:35: Error in updater

System.Exception: Found unexpected file: /Users/david/Library/Application Support/Duplicati/updates/2.0.3.3/OSXTrayHost/rumps.pyc
at Duplicati.Library.AutoUpdater.UpdaterManager.VerifyUnpackedFolder (System.String folder, Duplicati.Library.AutoUpdater.UpdateInfo version) [0x00297] in <2e3a1be277654a188f84e503094300c3>:0

… and my version is now showing as back at 2.0.2.1_beta_2017-08-01.

Any idea why the update failed, and if there’s anything I should do before trying again?


#2

Do you think you’re having the same issue as described here?

There were a lot of changes in the update process between 2.0.2.1 and 2.0.3.3 and it has been known to cause issues in certain cases, though it seems once people are on the new code the GUI update issues go away…


#3

Certainly looks like the same issue. I noticed that after the update process I have to manually start the Duplicati app. I will try again now and will report back!


#4

I retried the updater and noticed Duplicati.app was still at the old version; I downloaded the latest version and installed it, and all seems well!


#5

Sorry for the long delay - I’m glad to hear you got it working! I assume you don’t have to manually start the app anymore as well. :slight_smile:

Just to confirm, instead of using the GUI based updater you just installed the latest version (in your case 2.0.3.6 beta) “over” your current version and that solved your problem - correct?


#6

I tried to use the GUI updater; it appeared to work but then I noticed Duplicati.app was at the old version still, so I decided to re-download the installer and installed it over the old one.

One other thing I did notice: the version string in the latest Duplicati.app is wrong:

36


#7

I don’t have immediate access to a Mac to conform, but I suspect this is correct / expected behavior due to how Duplicati does the in-GUI updates using the ~/.config/Duplicati/updates folder (for more detail, see “How Duplicati installs / updates work” @ Downgrading / reverting to a lower version).

If you go to the main menu “About” -> “System info” page you should see both a ServerVersionName (most recent update being run) as well as a BaseVersionName (INSTALLED version not including any GUI updates).

Hopefully somebody else can check for the Mac reported !LONG_VERSION! version number before I can do it 4 or 5 days from now. But until then, can you confirm:

  • your screenshot is for Duplicati.app v2.0.3.6 canary
  • what version of MacOS are you running

#8

Thanks, seeing the different server/base versions was what prompted me to re-download, and reading that “how installs/updates” work wiki page helps clarify how this is intended to work.

To answer your questions:

The screenshot is for Duplicati.app v2.0.3.3_beta_2018-04-02 as downloaded from the download page, and I’m using macOS 10.13.4.