The database has version 11 but the largest supported version is 10

Hi guys, my best greetings at all. Excuse me for my poor english, i’m working to improve that :slight_smile:

I’m sorry to disturb you (probably it was already discussed) but I wasn’t able to find something like this to solve my problem.

I normally use Duplicati 2 as a service on Windows Server 2019 VMs (updated from on original iso). Everything works until, for unreasonable matters, scheduled backup processes stop work and Duplicati 2 send me an email like this :

*Failed: *
The database has version 11 but the largest supported version is 10.

This is likely caused by upgrading to a newer version and then downgrading.
If this is the case, there is likely a backup file of the previous database version in the folder C:\Windows\system32\config\systemprofile\AppData\Local\Duplicati.
*Details: Duplicati.Library.Interface.UserInformationException: *
The database has version 11 but the largest supported version is 10.

This is likely caused by upgrading to a newer version and then downgrading.
If this is the case, there is likely a backup file of the previous database version in the folder C:\Windows\system32\config\systemprofile\AppData\Local\Duplicati.

  • in Duplicati.Library.SQLiteHelper.DatabaseUpgrader.UpgradeDatabase(IDbConnection connection, String sourcefile, String schema, IList`1 versions)*
  • in Duplicati.Library.SQLiteHelper.DatabaseUpgrader.UpgradeDatabase(IDbConnection connection, String sourcefile, Type eltype)*
  • in Duplicati.Library.Main.Database.LocalDatabase.CreateConnection(String path)*
  • in Duplicati.Library.Main.Database.LocalBackupDatabase…ctor(String path, Options options)*
  • in Duplicati.Library.Main.Operation.BackupHandler.d__20.MoveNext()*
    — Fine traccia dello stack da posizione precedente dove è stata generata l’eccezione —
  • in System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()*
  • in CoCoL.ChannelExtensions.WaitForTaskOrThrow(Task task)*
  • in Duplicati.Library.Main.Controller.<>c__DisplayClass14_0.b__0(BackupResults result)*
  • in Duplicati.Library.Main.Controller.RunAction[T](T result, String[]& paths, IFilter& filter, Action`1 method)*

I tried to open sql.lite file and found database version 11 as expected but Duplicati 2 Server Version is come back to
On Informations tab now i can see :

You are currently running Duplicati -

Update is available, download now

To fix it i need to manually update Duplicati 2 and restart Duplicati 2 service.

It takes effect immediately but after some days (i didn’t yet understand the real reason) it displays the same error and i need to start update again.

Any suggestions?
Many thanks again.

what do you mean by that ? there is an auto-updater, it’s supposed to be used. If you download again Duplicati and install it, there is a risk that Duplicati could work as an user task, not a service and all sort of bad things could happen.

Thanks for the reply.

I mean, i have to use download link below and then the activate link (it will appear after the download completes) :

Update is available, download now

I understand your doubts and i’m agree with you but can’t find another way to save all my backups without reinstalling Duplicati (and save my sleeps too).

you can check that you are not using the user version by opening an admin terminal session and starting

netstat /ab >result.txt

then open result.txt in Notepad (or whatever) and search for 8300 and 8200. You should only find 8200.

1 Like

First, make sure you’re on the service. Besides port 8200, you can also look over About → System info.
UserName is probably the easiest way to recognize a Windows service. Do you even also run TrayIcon?

Finding the reason would be good. Autoupdates that become corrupted are ignored, leaving you with the .msi install in C:\Program Files\Duplicati 2 which is an old version until you install new from .msi.

is where to look, but detecting corruptions may be a bit hard. Easy test is to sort by date. Any too new?

You coule rename the folder, autoupdate again, then compare them, e.g. do all folder statistics match?


Backup failed - Error in updater was a similar problem. There the corruption was caused by extra data.

I’m not sure where the message would appear. Maybe look in About → Show log → Stored for startup?

1 Like

Hi ts678, many thanks for your reply.

Yesterday i updated again to and everything worked fine. This morning it’s come back again to

From System Informations :

## Proprietà di sistema

** APIVersion : 1*
** PasswordPlaceholder : ***********
** ServerVersion :*
** ServerVersionName : -*
** ServerVersionType : Beta*
** StartedBy : Server*
** BaseVersionName :*
** DefaultUpdateChannel : Beta*
** DefaultUsageReportLevel : Information*
** ServerTime : 2023-01-18T09:18:55.7922766+01:00*
** OSType : Windows*
** DirectorySeparator : *
** PathSeparator : ;*
** CaseSensitiveFilesystem : false*
** MonoVersion :*
** MachineName : xxxxxxxx*
** UserName : SYSTEM*
** NewLine :*
** CLRVersion : 4.0.30319.42000*
** CLROSInfo : {“Platform”:“Win32NT”,“ServicePack”:“”,“Version”:“10.0.17763.0”,“VersionString”:“Microsoft Windows NT 10.0.17763.0”}*
** ServerModules : []*
** UsingAlternateUpdateURLs : false*
** LogLevels : [“ExplicitOnly”,“Profiling”,“Verbose”,“Retry”,“Information”,“DryRun”,“Warning”,“Error”]*
** SuppressDonationMessages : false*
** SpecialFolders : [{“ID”:“%APPDATA%”,“Path”:“C:\Windows\system32\config\systemprofile\AppData\Roaming”},{“ID”:“%HOME%”,“Path”:“C:\Windows\system32\config\systemprofile”}]*
** BrowserLocale : {“Code”:“it-IT”,“EnglishName”:“Italian (Italy)”,“DisplayName”:“italiano (Italia)”}*
** SupportedLocales : [{“Code”:“bn”,“EnglishName”:“Bangla”,“DisplayName”:“বাংলা”},{“Code”:“ca”,“EnglishName”:“Catalan”,“DisplayName”:“català”},{“Code”:“cs”,“EnglishName”:“Czech”,“DisplayName”:“čeština”},{“Code”:“da”,“EnglishName”:“Danish”,“DisplayName”:“dansk”},{“Code”:“de”,“EnglishName”:“German”,“DisplayName”:“Deutsch”},{“Code”:“en”,“EnglishName”:“English”,“DisplayName”:“English”},{“Code”:“en-GB”,“EnglishName”:“English (United Kingdom)”,“DisplayName”:“English (United Kingdom)”},{“Code”:“es”,“EnglishName”:“Spanish”,“DisplayName”:“español”},{“Code”:“fi”,“EnglishName”:“Finnish”,“DisplayName”:“suomi”},{“Code”:“fr”,“EnglishName”:“French”,“DisplayName”:“français”},{“Code”:“fr-CA”,“EnglishName”:“French (Canada)”,“DisplayName”:“français (Canada)”},{“Code”:“hu”,“EnglishName”:“Hungarian”,“DisplayName”:“magyar”},{“Code”:“it”,“EnglishName”:“Italian”,“DisplayName”:“italiano”},{“Code”:“ja-JP”,“EnglishName”:“Japanese (Japan)”,“DisplayName”:“日本語 (日本)”},{“Code”:“ko”,“EnglishName”:“Korean”,“DisplayName”:“한국어”},{“Code”:“lt”,“EnglishName”:“Lithuanian”,“DisplayName”:“lietuvių”},{“Code”:“lv”,“EnglishName”:“Latvian”,“DisplayName”:“latviešu”},{“Code”:“nl-NL”,“EnglishName”:“Dutch (Netherlands)”,“DisplayName”:“Nederlands (Nederland)”},{“Code”:“pl”,“EnglishName”:“Polish”,“DisplayName”:“polski”},{“Code”:“pt”,“EnglishName”:“Portuguese”,“DisplayName”:“português”},{“Code”:“pt-BR”,“EnglishName”:“Portuguese (Brazil)”,“DisplayName”:“português (Brasil)”},{“Code”:“ro”,“EnglishName”:“Romanian”,“DisplayName”:“română”},{“Code”:“ru”,“EnglishName”:“Russian”,“DisplayName”:“русский”},{“Code”:“sk”,“EnglishName”:“Slovak”,“DisplayName”:“slovenčina”},{“Code”:“sk-SK”,“EnglishName”:“Slovak (Slovakia)”,“DisplayName”:“slovenčina (Slovensko)”},{“Code”:“sr-RS”,“EnglishName”:“Unknown Locale (sr-RS)”,“DisplayName”:“Impostazioni locali sconosciute (sr-RS)”},{“Code”:“sv-SE”,“EnglishName”:“Swedish (Sweden)”,“DisplayName”:“svenska (Sverige)”},{“Code”:“th”,“EnglishName”:“Thai”,“DisplayName”:“ไทย”},{“Code”:“zh-CN”,“EnglishName”:“Chinese (Simplified, China)”,“DisplayName”:“中文(中国)”},{“Code”:“zh-HK”,“EnglishName”:“Chinese (Traditional, Hong Kong SAR)”,“DisplayName”:“中文(香港特別行政區)”},{“Code”:“zh-TW”,“EnglishName”:“Chinese (Traditional, Taiwan)”,“DisplayName”:“中文(台灣)”}]*
** BrowserLocaleSupported : true*
** backendgroups : {“std”:{“ftp”:null,“ssh”:null,“webdav”:null,“openstack”:“OpenStack Object Storage / Swift”,“s3”:“Compatibile S3”,“aftp”:“FTP (Alternativo)”},“local”:{“file”:null},“prop”:{“s3”:null,“azure”:null,“googledrive”:null,“onedrive”:null,“onedrivev2”:null,“sharepoint”:null,“msgroup”:null,“cloudfiles”:null,“gcs”:null,“openstack”:null,“hubic”:null,“b2”:null,“mega”:null,“box”:null,“od4b”:null,“mssp”:null,“dropbox”:null,“sia”:null,“jottacloud”:null,“rclone”:null}}*
** GroupTypes : [“Archivio locale”,“Protocolli standard”,“Proprietario”,“Altri”]*
** Moduli backend: aftp azure b2 box cloudfiles dropbox file ftp googledrive gcs hubic jottacloud mega msgroup onedrivev2 sharepoint openstack rclone s3 od4b mssp sia ssh tahoe webdav*
** Moduli di compressione: zip 7z*
** Moduli crittografia: aes gpg*

## Server status properties

** lastEventId : 296*
** lastDataUpdateId : 8*
** lastNotificationUpdateId : 2*
** estimatedPauseEnd : 0001-01-01T00:00:00*
** activeTask :*
** programState : Running*
** lastErrorMessage :*
** connectionState : connected*
** xsfrerror : false*
** connectionAttemptTimer : 0*
** failedConnectionAttempts : 0*
** lastPgEvent :*
** updaterState : Waiting*
** updatedVersion :*
** updateReady : true*
** updateDownloadProgress : 0*
** proposedSchedule : [{“Item1”:“1”,“Item2”:“2023-01-19T00:00:00Z”}]*
** schedulerQueueIds : []*
** pauseTimeRemain : 0*

Why ServerVersion = and updatedVersion = ? :face_with_raised_eyebrow:

In reply to your questions :

  • 8200 is the only port listening for Duplicati (no 8300)
  • no TrayIcon appears
  • no .msi files found on c:\Program Files\Duplicati 2
  • all folders and files are dated xx/xx/2020 except for “preDuplicati.log” (18/01/2023 01:00)

This is the situation on c:\ProgramData\Duplicati\updates:

And this is where the message appears :


A .msi file is an installer file, so not likely there. You download it and run it to install Duplicati.
For your install, you probably went to the download page (working poorly today) for it. still has the different types of installer files available for downloads. could replace, but I think you found what broke autoupdate:

I can’t find such a name in the source code or anywhere on the Internet (according to Google).
Is this your file, perhaps logging output from your run-script-before script? If so, log elsewhere.
Ideally, use a full path name, not a simple file name which will drop the log file onto the update.

I edited in an example of extra-file breakage on last post. If you didn’t notice it, see if it applies.


and if you think that’s the only unexpected alteration in the update (hard to say without
the comparing-folder-statistics mentioned), you can delete that then restart and check version.