Sucessful backup, but always 3 warnings


#1

Hello,

I have a configuration, to backup a USB-stick (G:) to my local NAS System.
The backup is done, Looks good, but always three warnings:

Warnings: [

Failed to process metadata for "G:\System Volume Information\", storing empty metadata => Es wurde versucht, einen nicht autorisierten Vorgang auszuführen.,

Error reported while accessing file: G:\System Volume Information\ => Der Zugriff auf den Pfad "G:\System Volume Information" wurde verweigert.,

Error reported while accessing file: G:\System Volume Information\ => Der Zugriff auf den Pfad "G:\System Volume Information" wurde verweigert.

]

May I ask for some tips, tricks, what´s wrong, or how to avoid these messages.

Thank You!

Matthias.


Access to System Volume Information denied
#2

The easiest way to solve this is probably to exclude G:\System Volume Information\ from your backup. You don’t want that backed up anyway:

Edit: I realize that I may have made a wrong assumption here, namely that you/duplicati is trying to backup the contents of G:\System Volume Information\ but it may well be the case that you have --snapshot-policy = on in which case (I think) duplicati would be trying to access that folder in order to create a Volume Shadow Copy. According to the help text, it should fail silently if it fails and create a warning in the logs:

  --snapshot-policy = off
    This setting controls the usage of snapshots, which allows Duplicati to
    backup files that are locked by other programs. If this is set to "off",
    Duplicati will not attempt to create a disk snapshot. Setting this to
    "auto" makes Duplicati attempt to create a snapshot, and fail silently if
    that was not allowed or supported. A setting of "on" will also make
    Duplicati attempt to create a snapshot, but will produce a warning
    message in the log if it fails. Setting it to "required" will make
    Duplicati abort the backup if the snapshot creation fails. On windows
    this uses the Volume Shadow Copy Services (VSS) and requires
    administrative privileges. On Linux this uses Logical Volume Management
    (LVM) and requires root privileges.

In any case, you might want to turn ¨–snapshot-policy = off` as I don’t think it makes sense for USB drives. But others here may be able to provide a more generic solution…


#3

I don’t think so. Duplicati would just be triggering the VSS API to create the snapshot, and Windows itself is responsible for doing the actual work and putting data in System Volume Information.

I bet the OP has the entire G:\ drive selected for backup. Excluding System Volume Information would be the right approach to solving this problem. As you stated you do not want to back up this area anyway.


#4

Good Morning,

in short words …
perfect help… Thanks.

My itension/aim is to backup all “user data” from the stick. I am not interested in an other information, maybe the operation system need this.

With a modification of my backup configuration, the backup will be done, without error and warnings.
I’m a bit ashamed that I did not find the solution myself.

high time, and spend a round … hmmmm, how … donate the project is possible
or you come to south germany (Bayern) … :slight_smile:

For me, duplicati is a very useful, helpful powerful tool.

Regards

PS: what means the abbravation OP …


#5

It’s good to hear things are working for you now! If there was a particular post that gave you the “fix” feel free to check the Solution box image. :slight_smile:

OP means “original post” or “original poster” - it’s just a shortcut way to refer to the first post or the person who made the first post.


#6

Yesterday, I experienced the same issue (3 warnings about not being able to access Z:\System Volume Information\)

29 Nov 2017 23:25: Message
Error reported while accessing file: Z:\System Volume Information\
System.UnauthorizedAccessException: Access to the path 'Z:\System Volume Information' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileSystemEnumerableIterator`1.CommonInit()
   at System.IO.Directory.GetFiles(String path)
   at Duplicati.Library.Snapshots.NoSnapshotWindows.ListFiles(String folder)
   at Duplicati.Library.Utility.Utility.<EnumerateFileSystemEntries>d__22.MoveNext()
29 Nov 2017 23:25: Message
Error reported while accessing file: Z:\System Volume Information\
System.UnauthorizedAccessException: Access to the path 'Z:\System Volume Information' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileSystemEnumerableIterator`1.CommonInit()
   at System.IO.Directory.GetDirectories(String path)
   at Duplicati.Library.Snapshots.NoSnapshotWindows.ListFolders(String folder)
   at Duplicati.Library.Utility.Utility.<EnumerateFileSystemEntries>d__22.MoveNext()
29 Nov 2017 23:25: Message
Failed to process metadata for "Z:\System Volume Information\", storing empty metadata
System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.
   at System.Security.AccessControl.Win32.GetSecurityInfo(ResourceType resourceType, String name, SafeHandle handle, AccessControlSections accessControlSections, RawSecurityDescriptor& resultSd)
   at System.Security.AccessControl.NativeObjectSecurity.CreateInternal(ResourceType resourceType, Boolean isContainer, String name, SafeHandle handle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)
   at System.Security.AccessControl.FileSystemSecurity..ctor(Boolean isContainer, String name, AccessControlSections includeSections, Boolean isDirectory)
   at System.Security.AccessControl.DirectorySecurity..ctor(String name, AccessControlSections includeSections)
   at Duplicati.Library.Snapshots.SystemIOWindows.GetAccessControlDir(String path)
   at Duplicati.Library.Snapshots.SystemIOWindows.GetMetadata(String path, Boolean isSymlink, Boolean followSymlink)
   at Duplicati.Library.Main.Operation.BackupHandler.GenerateMetadata(ISnapshotService snapshot, String path, FileAttributes attributes)

So I excluded any System Volume Information directory like this:

But when the job ran today, I got the same 3 warnings again. Am I doing something wrong?


#7

IIRC, ending the exclude with anything other than \ or / treats the filter like a file.

If that’s correct then your rule will exclude all contents of the folder, but will still try to access the folder, thus causing the error.

I’m not where I can check, but I also think the “Exclude expression” selection automatically adds the leading dash, in which case it’s trying to exclude “anything in the folder found at dash followed by anything followed by \System Volume Information”

Try putting -*\System Volume Information\ in the “edit as text field”.


#8

Unfortunately, this didn’t help either. Still getting the warning.
Wait a minute, I am starting to understand what you are saying here:

You are basically saying that what you suggested will probably not work, right? Well you were right. So I have to try *\System Volume Information\ then?

@Matthias, how exactly did you get rid of the warnings?

Edit: See also here:


Include examples for filters
#9

Good Morning,

I was asked …
@Matthias, how exactly did you get rid of the warnings?

My system:

  • Notebook, Windows Operating System 10
  • Standard USB Stick 32 GByte, plugged in, connected with G:\

post 2

That´s all …
Due to the case, that my USB stick is always G:\ … the Exclude Folder Option works fine.

Note: In this backup run, there was only small changes, only 10 files,
therefore the backup runs very fast …
and no warnings, errors, and the red (message) box on the screen

Regards


#10

post 4

Adding to my last post, the result … no warnings, no errors …

note: new users can only add 3 Images per post … :expressionless: |


#11

Yes. In the two-field setup for “Exclude Folder”, you would put in *\System Volume Information\ (the “-” is added automatically behind the scenes), but if you’re using the “Edit as text” option (the three dots menu just across from the “Filters” line) then you need to use -*\System Volume Information\.


#12

Nope, doesn’t work. Now I was going to try

But then I thought, since I want to exclude those system volume folders globally anyway, I might aswell go for the global option --exclude="*\System Volume Information\*"

But those filters are confusing. So:


#13

Doesn’t work either . :tired_face: It gives me:

Warnings: [
    The supplied option --exclude is not supported and will be ignored
]

So, I’m wondering why the GUI accepts that option in the first place if it is not supported at the global settings level.

I also tried --exclude=*\System Volume Information\* but with the same results.

I can’t believe how much time I’m spending at doing a simple thing like excluding a some folders. :dizzy_face:

So now I tried this:

image

And it finally seems to have worked. The disadvantage is that I have to enter this for every single backup job. Why is it not possible to globally exclude stuff?


#14

It might be worth including \System Volume Information\ in the standard “System files” Exclude option.


#15

My assumption is that that is covered with this:

But I don’t have that yet since I’m on the beta channel…


#19

This should actually work because it will not look in the folder after it has been excluded.

But * means “zero or more characters” so the original filter should also work.

I should fix it …

Unfortunately it is because “order matters”. As we allow both include and exclude filters, there is no sane way to simply mix two lists of filters without getting a lot of surprises.

Imagine one rule is exclude *, putting that first and last has two very different outcomes.