Starting Duplicati server-wide (as root) & server-only on the Mac

I am trying to get Duplicati running system-wide (so not per user, but as root) on a Mac. When I start Duplicati as a user (double clicking the /Applications/ it starts and works fine against my backend storage (minio behind nginx).

To start it system wide (at boot time) I’ve created a LaunchDaemon (which I can’t quote because preformatted xml is not displayed correctly in the forum) which attempts to launch :


as root. I notice ~root/.config has been created and filled. I can connect to the service at localhost:8200

I’ve been working with various versions of this one. It fails when trying to create a backup with:

Failed to connect: Error making request with Error Code MethodNotAllowed and Http Status Code MethodNotAllowed. No further error information was returned by the service.

or with:

Failed to connect: A WebException with status NameResolutionFailure was thrown.

When I put in


I get the same problems.

Has anyone found out how to run Duplicati as just a service on macOS?

1 Like

There was a discussion on this some time back. The plists linked there worked for me but not for Jon. You could try giving them a shot.

Also, if you want to share your own plist, you can create a gist on github and paste the link here.

I used the LaunchDaemon plist you referred to on a clean machine where I installed mono with brew and Duplicati. That worked. So apparently, my plist had settings or my system is somehow hosed with settings that it doesn’t work. As a clean setup worked, I’ll look into what was the trouble.

1 Like

Well, after a bit of experimentation (first with the LaunchDaemon that worked on the other Mac, but that had the same problem, then with removed ~root/.config, and so forth) this is what I suspect: cookie or browser cache. Because when I cleared the browser’s history/cache it worked. If this is something that the browser code of the Duplicati server can prevent it would be nice.