SQLite Error No Such Column S.BlocksetID

We attempted a restore this morning with Duplicati and received “SQLite Error No Such Column S.BlocksetID”.

We are on Canary 2020-09-26.

Only when we attempt to restore to a different location do we see this error. We notice that if we restore to the original location, the restore works.

Just to test, we have 8 backups and we have attempted to restore each backup to an alternate location and the restore fails on every one of them.

Interesting… I just tested an out-of-place restore with and it worked fine.

What operating system are you using? If non-Windows, what version of mono?

Hi, and thanks for testing.

We’re using Duplicati in a Linux, UnRAID Docker.

As far as the mono version, I’m not sure. UnRAID doesn’t have a package manager so, I’m not sure how to find out the version.

Just to clarify, when selecting “Pick a Location”, to restore to is when we are seeing the No Such Column S.BlocksetID. Even if we select the original location using the “Pick a Location” function, we still see this error. Again, if we restore to the “Original Location”, the restore seems to work fine.

Oh, you see the error in the web UI as soon as you click the “Pick location” option? Good to know.

Which docker image are you using? There is the official duplicati docker image but also linuxserverio has one. I personally use the official one on my Synology NAS. I just click the pick location option and didn’t have an issue with it. Strange.

I’m also having the same problem. But I’m also running on a Synology. Have the latest canary What could be different? How did you configure the docker, especially the path to where you restore?

This topic kind of dead-ended. Was there a cure, and if so, what? There’s a newer topic that hit this:

SQLite error no such column: S.BlocksetID

Above was Docker too, but I don’t run Docker. I don’t know if issue is Docker-specific or coincidence.

Thanks for any help you can offer the new topic, where I also identified a change in area for,
Now I don’t know whether there’s a general new bug (which I can’t hit) or if it’s somehow only Docker.

I added some more info to my last post in the linked topic. If I can help here, please let me know!

I solved it by restarting the backup fresh. It was painful to do it over again but so far no problems. I couldn’t replicate the error. Sorry.