Speed limiter not working

When a backup is taking place, it can really consume the bandwidth to the point browsing is painful, etc. The speed throttling is a useful tool. However, it doesn’t appear to take effect.

So the backup is chugging along at 516 KB/s (which task manager also confirms) despite the max upload speed being 200 KB/s. I’ve stopped (quit) and restarted Duplicati in case it doesn’t take changes to this value which a backup is in progress.

I’m using on Windows 10.
Appreciate this is only a beta, and things may be broken, etc, but is this a known ‘broken thing’ ?

Welcome to the forum @chrisjlocke

What storage destination is this? OneDrive is probably the closest to known-broken, but a workaround is simply setting lower fragment-size option, and the problem is already fixed (but not yet in a Beta release).

Throttle Not Working describes that one and has some other commentary, such as that a router may do better (if yours supports speed limiting) because it controls the packets directly, while Duplicati does not.

Because your goal is to go easy on the network, unlike the people who wish to use as much as possible

  --asynchronous-concurrent-upload-limit (Integer): The number of concurrent
    uploads allowed
    When performing asynchronous uploads, the maximum number of concurrent
    uploads allowed. Set to zero to disable the limit.
    * default value: 4

set to 1 would probably keep the upload limit better capped, otherwise it looks like imperfect throttler (that tries to maintain the target speed by sending timed releases of data to the upload processing) looks good individually (this is Google Drive), however Task Manager shows a much more uneven flow, probably due partly to Duplicati not being a router, and possibly due to independent multiple uploaders. Here is 50 KB/s:

2021-06-21 09:52:50 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 935.92 KB in 00:00:23.1605780, 40.41 KB/s
2021-06-21 09:52:52 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 1.92 KB in 00:00:01.1397807, 1.68 KB/s
2021-06-21 09:52:56 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 926.45 KB in 00:00:29.6207353, 31.28 KB/s
2021-06-21 09:52:58 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 1.43 KB in 00:00:01.0738967, 1.33 KB/s
2021-06-21 09:53:07 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 980.61 KB in 00:00:23.4868149, 41.75 KB/s
2021-06-21 09:53:08 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 14.78 KB in 00:00:00.9323208, 15.85 KB/s
2021-06-21 09:53:08 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 790.50 KB in 00:00:15.8454728, 49.89 KB/s
2021-06-21 09:53:10 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 14.72 KB in 00:00:01.0112737, 14.55 KB/s
2021-06-21 09:53:13 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 990.47 KB in 00:00:29.4906248, 33.58 KB/s
2021-06-21 09:53:16 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 1.34 KB in 00:00:03.1258725, 439 bytes/s
2021-06-21 09:53:45 -04 - [Profiling-Duplicati.Library.Main.Operation.Backup.BackendUploader-UploadSpeed]: Uploaded 53.45 KB in 00:00:28.0359606, 1.91 KB/s
2021-06-21 09:54:06 -04 - [Profiling-Duplicati.Library.Main.BackendManager-UploadSpeed]: Uploaded 365.75 KB in 00:00:21.1555288, 17.29 KB/s
1 Like

Thanks for the prompt response! :+1:
Yes, forgot the target destination - its a Google Drive destination. This software seems to work quite well with it.
I’ll try reducing the fragment-size option and concurrent upload limit. Thanks!

Did you mean OneDrive (and similar Microsoft offerings)? That’s the one that needs fragment-size.
Google Drive was throttling, though not very evenly until I trimmed down the concurrent upload limit.

No, Google Drive.
So fragment-size doesn’t work with that destination? Interesting.

It’s a Microsoft concept from their Graph API. Upload bytes to the upload session.

On Google Drive, throttling works though imperfectly. Remember to convert bits to bytes as needed.
Reduce concurrent uploads to 1, try a lower throttle value if you like. The only other reason I can see preventing throttling from working is if you set GUI control to the right of the status bar to high speed.