Some kind of disk I/O error occurred

I’m using the duplicati docker and I’m getting the following error on a job to B2 Cloud storage. I have 10 directories being backed up. Is there a way to pinpoint the files that are causing this error? In troubleshooting I decided to test one directory at a time. I have found that 7 directories backup perfectly well. At least 2 different directories cause the same error below. Each directory has LOTS of files. Can anyone shed some light on the error below and how to best troubleshoot such a thing? I thought my next step might be to backup the same directory to a local location just to see if its somehow a cloud based problem…I’m also unsure if this might be some sort of resource issue with the docker container or docker host. I noticed that when I did a local backup containing about 1.5 TB of data, it was SUPER DUPER slow. I gave up and switched that to normal rsync as I don’t need encryption for that.


Mono.Data.Sqlite.SqliteException (0x80004005): Some kind of disk I/O error occurred
disk I/O error
at Mono.Data.Sqlite.SQLite3.Prepare (Mono.Data.Sqlite.SqliteConnection cnn, System.String strSql, Mono.Data.Sqlite.SqliteStatement previous, System.UInt32 timeoutMS, System.String& strRemain) [0x001f8] in :0
at Mono.Data.Sqlite.SqliteCommand.BuildNextCommand () [0x000d3] in :0
at Mono.Data.Sqlite.SqliteCommand.GetStatement (System.Int32 index) [0x00008] in :0
at (wrapper remoting-invoke-with-check) Mono.Data.Sqlite.SqliteCommand:GetStatement (int)
at Mono.Data.Sqlite.SqliteDataReader.NextResult () [0x000b3] in :0
at Mono.Data.Sqlite.SqliteDataReader…ctor (Mono.Data.Sqlite.SqliteCommand cmd, System.Data.CommandBehavior behave) [0x0004e] in :0
at (wrapper remoting-invoke-with-check) Mono.Data.Sqlite.SqliteDataReader:.ctor (Mono.Data.Sqlite.SqliteCommand,System.Data.CommandBehavior)
at Mono.Data.Sqlite.SqliteCommand.ExecuteReader (System.Data.CommandBehavior behavior) [0x00006] in :0
at Mono.Data.Sqlite.SqliteCommand.ExecuteNonQuery () [0x00000] in :0
at Duplicati.Library.Main.Database.LocalDatabase.LogMessage (System.String type, System.String message, System.Exception exception, System.Data.IDbTransaction transaction) [0x00067] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.BasicResults.LogDbMessage (System.String type, System.String message, System.Exception ex) [0x00027] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.BasicResults.AddError (System.String message, System.Exception ex) [0x000b1] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.Operation.BackupHandler.Run (System.String[] sources, Duplicati.Library.Utility.IFilter filter) [0x008c6] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.Controller+<>c__DisplayClass16_0.b__0 (Duplicati.Library.Main.BackupResults result) [0x0030f] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.Controller.RunAction[T] (T result, System.String[]& paths, Duplicati.Library.Utility.IFilter& filter, System.Action`1[T] method) [0x0014b] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Library.Main.Controller.Backup (System.String[] inputsources, Duplicati.Library.Utility.IFilter filter) [0x00068] in <118ad25945a24a3991f7b65e7a45ea1e>:0
at Duplicati.Server.Runner.Run (Duplicati.Server.Runner+IRunnerData data, System.Boolean fromQueue) [0x00454] in :0

I have googled a bit around for this, and this post suggests that it is a problem with the disk:

Alternatively, something was interfering with the journal file during the operation?

Thank you much for the input. I tried doing local backups of the same data, one directory at a time. I have found some specific directories that seem to have issues…i think…but i dont know why yet.

I also noticed now that when the I/O error occurs it somehow crashes my freenas box. Both source and destination are nfs shares to the freenas box. Destination is a 4 TB backup drive and source is a 4 drive RAID 10. Its the craziest thing.

The duplicati is a docker sitting on a separated machines that runs ESXi with Ubuntu/dockerhost. I gave it 4 GB of memory to the host…maybe thats not enough…i wish that the logs were a bit more specific in duplicati…

There are no errors reported on the drives…so i think it might be a memory thing…but i dunno.

Any thoughts on the setup?

4GB should be plenty of memory. I run it on a 512MB ARM processor without hitting memory issues.

Are you using the Mono packages from Xamarin inside the docker image? The Mono version from Ubuntu/Debian is 3.2 and the latest Xamarin version is 5.2: Download | Mono