[SOLVED] Losting advanced options when the backup job is changed

Hi to all, I noticed that if I change somewhat to a backup job and I save it, “alternate-target-paths” and “alternate-destination-marker” are losted. Why? Is it a normal behavior?

I did a quick test and am not able to reproduce this.

What version of Duplicati are you using?

If you’re picking these options on Step 2 then yes I’ve seen this.

Workaround: Make the job without the advanced options, save the job. Once saved, edit the job (bringing you back to the same place), this time go straight to Step 5 and you can add the options from there. The menu scrolls quickly and I often jump over the “local folder or drive” options.

There is another post around here somewhere regarding this issue, which is where I found this workaround.

To reproduce: Create a new job, Step 1 options don’t seem to matter. On Step 2 pick a “local folder or drive” option from the “advanced options” menu. I picked alt-dest, gave it a path “*:\MyPath”. Pick a folder in Step 3, doesn’t seem to matter. Step 4, either way scheduled or not. Step 5 click Save.
Reopen the job and the “advanced options” will be missing.
To make things a pinch more confusing, on that initial job creation the “local folder or drive” options only show in Step 2 and they are absent from the “advanced options” list in Step 5. If you save the job and then edit, all works as expected when added from Step 5. Not sure if Step 2 “advanced options” work post save, I just add them via Step 5 now.

Duplicati -


Good catch! I was setting them on Step 5 without issue. If you do it in Step 2 then I can reproduce the problem as well.

When setting the options in Step 2, Duplicati puts them in the storage URL which is visible if you “export to command line” … for example:


The next time you edit the job, these get stripped off.

If you set the options in Step 5, they get stored as standard options. Exporting as command line shows:


These standard options are preserved next time you edit the job.

Definitely buggy behavior.

1 Like

Thanks guys, problem solved.

Bug is filed (but not moving much – anybody know JavaScript, which might be what’s involved here?).

I put a note in that issue that “I’m having problems with all screen 2 options for local folder destination.” however there’s definitely more poking at the issue that could be done to try to understand its extent…