Setting Backup Time

How do I set the time of day at which I would prefer each backup takes place?

If you have a backup created you can click on it under home and then click edit and then click on the schedule section and you can set the time of day.

If you are creating a backup, it is on the schedule section once you get to it or you can click on schedule and then set time of day and then continue onto the rest of the sections.

That’s it really. You can do more advanced things that I won’t be covering.

I edit the schedule to make it 10:00 PM tomorrow and when I get back to the home page it still says the next backup is 1:00PM tomorrow

What is going on here? Thanks for the assistance,

Welcome to the forum @Davida

Did that include

because Editing an existing backup has a Save button on the last screen that’s needed to apply change.
If you used it and it didn’t apply, please give your Duplicati version, and ideally a simple bug step-by-step.
A change from 1:00 PM tomorrow to 10:00 PM tomorrow worked fine for me on the backup I tested with.

1 Like

Naturally, I missed telling about the save button lol.

Re backup schedule time, I must have missed the documentation where it says UTC is used - not local time. My timezone is UTC-7 so to schedule a backup at 12pm I must enter 7pm. The backup then runs at 12pm. After the backup runs all times in the log data are UTC not local time. Thus not user-friendly when reviewing log data. Why does Duplicati use UTC and not local time? Not happy with this “feature”.

Very odd, I don’t think I’ve seen that behavior on any of my systems. The time I enter on the schedule is when the backup runs.

Out of curiosity, what web browser are you using? Can you try a different one to see if it has the same issue? (I’m just making a wild guess that maybe the Duplicati web UI is not properly detecting your local time zone when you’re setting the schedule time.)

Yes, very odd. No one reading my earlier Reddit post said they’d encountered the same problem.

I have Duplicati running on Firefox v92.0.1.

I’ll try running Duplicati on Opera or Chrome browser and post here with the results. Thanks for your suggestion.

Let’s get more data. In Windows Settings, go to Time & Language. What zone is it? Does it time-sync?

Checking at the browser level, do Google search for timezone and it might show yours at results page. looks like another way.

On Duplicati About → System info screen, look at the ServerTime. Do the time and zone look correct?

“On Duplicati About → System info screen, look at the ServerTime. Do the time and zone look correct?”

Yes, matches my local time.

So not only the time is correct, but the zone also says UTC-7 (per Reddit information saying it’s MST)?
You can post value if you like, but zone is at end. EST example is 2021-12-22T09:47:43.8916059-05:00

What about the other two tests? The question about time-sync is looking for information from this area:


ServerTime : 2021-12-25T13:53:29.4731691-07:00

Yes, ‘Sync’ works perfectly.

Weird - shows I’m GMT+0000 (Coordinated Universal Time) in Firefox - but shows GMT-0700 (Mountain Standard Time) in Opera browser! ???

Firefox -
The current time is Sat Dec 25 2021 21:06:00 GMT+0000 (Coordinated Universal Time)
The GMT current time is Sat, 25 Dec 2021 21:06:00 GMT
You are currently at GMT+/-0:00
Covid-19 Date: March 664, 2020

Opera -
The current time is Sat Dec 25 2021 14:07:31 GMT-0700 (Mountain Standard Time)
The GMT current time is Sat, 25 Dec 2021 21:07:31 GMT
You are currently at GMT+/-7:00
Covid-19 Date: March 664, 2020

FYI - This time problem is solved when I run Duplicati in Opera browser - and I’m sure the same in Chrome browser.

So this is obviously some sort of problem with Firefox. I posted a description of this problem on a FF support forum - so hopefully a solution will be forthcoming. Sure hope so!

Apparently I’m the only person on the planet having this problem!

Thanks ts678 much for your assistance - most helpful! Stay tuned.

Do you have any privacy-based extensions installed in Firefox? One may be blocking local time zone detection.

This apparently is my problem - but I have not yet confirmed.

Note this: “Your timezone is reported to be UTC”

My guess was that it’s an anti-fingerprinting thing, but I figured it was a third party extension since I don’t see that behavior with my Firefox.

I have my privacy mode set to “Strict” and Enhanced Tracking protection is enabled, yet when I go to that whatismytimezone site it correctly states I’m in PST.

Edit to add - if I enable the privacy.resistFingerprinting setting, then that web site reports UTC. So yeah that’s the issue. If you want to leave it enabled, you can probably add the domain portion of your Duplicati web server URL to privacy.resistFingerprinting.exemptedDomains.

Yup, agreed, it’s the “privacy.resistFingerprinting” thing.

I’ve set “privacy.resistFingerprinting.exemptedDomains” to:


Hope that works. Stay tuned!