Restore: Failed to connect: No filesets found on remote target


I know there are several threads here on the forum, about the same error:
"Failed to connect: No filesets found on remote target "
But they seem to address somewhat different situations.

My situation:
I accidentally overwrote a file so I want to restore it from my Duplicati backup on (‘buckets’).

In Firefox I login to Duplicati here: http://localhost:8200/ngax/index.html#/

I choose ‘Restore’ in the left menu, then “Direct restore from backup files …”
I select “B2 cloud storage” and select the folder I want to restore from.
On the next screen I enter the B2 bucket details and “Test connection” → “Connection worked!”
I press Next, I enter my Passphrase, and press “Connect”, and then I get the error:
“Failed to connect: No filesets found on remote target”

I just updated to Duplicati - (from 2.0.5). So both versions gave this problem.

When I try to see the details of the error above, I get this - new - error:
“Failed to connect: SQLite error no such table: LogData”

Can anyone help please.

Best regards,
Henrik R.

Do you have a defined backup job in the web UI? If so, don’t use the above option. That’s intended for restores on a different computer where the backup job is not set up. You’ll have to enter a lot of settings and it will have to rebuild a temporary database - time consuming operations that are not needed if the job is defined already.

If the backup job is defined, click on it in the main UI and then click the “Restore files …” link:


OR click the “Restore” option in the main menu on the left and select the name of the defined backup job:


Thank you!
I don’t know why I didn’t think about that…
But I discovered that I am not backing up that part of the disk, so I couldn’t restore the file anyway…
But I restored something else, just to test, and it worked perfectly. Thank you!

1 Like