Reporting error gave error

Hi all,

I am now 1.5 days busy to get Duplicati run headles. I am finally so far that i can login but get a bunch of errors. I removed a few times mono, duplicati. Try other releases but really nothing works…

For the info: i run it on (Armbian) Debian Buster kernel 5.4

Strange enough when i delete in my opinion all the directory´s the log is back when i reinstall mono and duplicati. Here are all the errors:

Help is very welcome! :slight_smile:

No one who has a idea or suggestion?

Hi and welcome to the forum!

What version of mono is installed?

Hi and thank you for the welcome.

This is the Mono version i have now installed.

~ $ sudo mono --version
Mono JIT compiler version 6.10.0.96 (tarball Mon Mar 23 09:18:56 UTC 2020)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       normal
	Notifications: epoll
	Architecture:  arm64
	Disabled:      none
	Misc:          softdebug 
	Interpreter:   yes
	LLVM:          yes(610)
	Suspend:       preemptive
	GC:            sgen (concurrent by default)

Well, you have a good mono version… this is strange though, not sure what is causing your problem. A quick search on the forum shows no previous discussions of the message “Error initializing the configuration system.”

I run Duplicati without issues on regular Debian testing (bullseye) with a 5.4 kernel. I haven’t tried Armbian.

How did you install Duplicati?

I have installed it on the .deb and also manual de headless instruction. But what in my opinion is really weird that when delete everything and installed the log from before the deleting is back… So i think not really all is deleted. What is the directory where the log is saved?

IT WORKS!!!

After long long seeking did i the following to get it working:

  1. in the directory /usr/lib/duplicati we got all the files for Duplicati
  2. I tried to start Duplicati manual with mono ./Duplicati.Service.exe --webservice-port=8200 --webservice-interface=any but got the same error.
  3. Then i saw also there are 2 files. Duplicati.Service.exe.config and Duplicati.Server.exe.config
  4. I looked into the files and read something about support of old versions of Duplicati.
  5. I renamed bot file to add OLD in the file name
    6 Et voila!! Working perfect as expected.

Short is the work arround:

  1. cd usr/lib/duplicati
  2. mv sudo mv Duplicati.Service.exe.config OLD_Duplicati.Service.exe.config
  3. sudo mv Duplicati.Server.exe.config OLD_Duplicati.Server.exe.config
  4. sudo systemctl restart duplicati.service
  5. Should work now!

It cost me a lot of days to find and thank you for all the help. :slight_smile:

Hmm, I don’t really understand why you are having an issue, but those .config files shouldn’t need messing with. They are installed by the Duplicati package and do not actually contain any of YOUR configuration details. Your config is stored in ~/.config/Duplicati by default.

That being said, I’m glad it’s staying working for you but I’m not confident that this was the right/actual solution. Fingers crossed…

I don´t understand also not really the reason. Specially because i installed a few times again and again. I should looking if the config is really stored in that directory.

I see there:

.config/Duplicati $ ls
control_dir_v2  Duplicati-server.sqlite  updates

But every new install i didn´t find this directory. So maybe is here something wrong…

If i rename the .config/Duplicati dir and restart Duplicati there is no new directory. Als when i run the .deb file comes the the directory not back… so i think there is a problem to find the directory or something.

The installer doesn’t create that folder, but Duplicati will when it is run. You need to check the home folder under the user account that Duplicati is running. If you have it running as a system service, you may need to check /root/.config/Duplicati, for example.

Hmm indeed. There was also a Config. Both deleted als installed again. If i hold Duplicati.Server.exe.config do i hold the above errors. When i delete works it better but not problemless. I got a error with update:

System.Net.WebException: An exception occurred during a WebClient request. ---> System.NotSupportedException: The URI prefix is not recognized.
  at System.Net.WebRequest.Create (System.Uri requestUri, System.Boolean useUriBase) [0x000ae] in <9853e56a794343d49933857af559945e>:0 
  at System.Net.WebRequest.Create (System.Uri requestUri) [0x00014] in <9853e56a794343d49933857af559945e>:0 
  at System.Net.WebClient.GetWebRequest (System.Uri address) [0x00000] in <9853e56a794343d49933857af559945e>:0 
  at System.Net.WebClient.DownloadFile (System.Uri address, System.String fileName) [0x00034] in <9853e56a794343d49933857af559945e>:0 
   --- End of inner exception stack trace ---
  at System.Net.WebClient.DownloadFile (System.Uri address, System.String fileName) [0x00096] in <9853e56a794343d49933857af559945e>:0 
  at System.Net.WebClient.DownloadFile (System.String address, System.String fileName) [0x00008] in <9853e56a794343d49933857af559945e>:0 
  at (wrapper remoting-invoke-with-check) System.Net.WebClient.DownloadFile(string,string)
  at Duplicati.Library.AutoUpdater.UpdaterManager.CheckForUpdate (Duplicati.Library.AutoUpdater.ReleaseType channel) [0x000ee] in <74dd9b2be27c412e929e872fc5457c24>:0 

And also when i try to connect to webdav. So there is more to explore :expressionless:

But thnx for all the help now!

The per-backup log is in ~/.config/Duplicati in a file with a random name, and.sqlite at the end.
This is a per-backup database file that also tracks the remote contents sort of like local cache.
Its path is in the Database tab of the backup, if you ever need to figure out which DB is which.

There’s a Recreate button if the DB breaks and it needs to be rebuilt from remote file contents.
This unfortunately loses log, right when one might want it for debug… One can manually copy.

The Duplicati-server.sqlite has all the backups’ settings and some statistics but not tiny details.
There is actually also a bit of logging in this DB, but it’s the About --> Show log --> Stored one.

What Duplicati version is this? 2.0.5.1 has updated Amazon dll versions, and it might matter…

‘Amazon.AWSConfigs’ type initializer threw an exception

solved that similar-sounding problem somehow. Perhaps @Thales_Queiroz can offer details.
Or maybe (like yours) enough fiddling eventually made it behave for reasons that aren’t clear.