Repair and recreate doesn't work "missing remote file"

I’ve migrated an old Mac (macOS High Sierra) to a new Mac (Mojave). When I first ran Duplicati I got errors. Rebuilding the database(s) did not help. So, I did a recreate. That ends with a “missing remote file”. What next?

[Additional info:]

What I did exactly:

  • On the old system: ran duplicati backups, this worked fine (two sets: one on local disk, one on remote storage)
  • Booted from the new Mac
  • Migrated to the new Mac from a TimeMachine backup that was 10 hours old and before the backups
  • Hence, the local database was from before the storage (for both backups)
  • I ran repairs and recreates before I realised what had happened
  • When I realised what had happened, I copied the local databases in /var/root/.config over to the new system
  • Backup on the first set failed again
  • Repair on backup on the first set failed with the same error as before
  • Recreate database on the first set also failed, now with two missing remote files instead of one, so I’m afraid my actions has further degraded the actual storage

What do I do to fix this? And: The Duplicati command line help is all Windows. How do I run these commands on the Mac?

IIRC, you use mono to execute the Duplicati.CommandLine.exe, the rest is the same.