Release: 2.0.6.105 (canary) 2023-04-09

2.0.6.105-2.0.6.105_canary_2023-04-09

Changes in this version:

  • Disable automatic use of v2 authid for Jottacloud, thanks @albertony
  • Fix gui tests, thanks @gpatel-fr
  • Make Xamarin-based CocoaRunner the default on Mac, thanks @dgileadi
  • Fix #4716 by falling back to System hasher, thanks @vilaureu
  • Allow install on Debian bookworm by using libayatana-appindicator1, thanks @gpatel-fr
  • Build Debs with gzip compression for old debian releases, thanks @gpatel-fr
  • Add Impossible Cloud provider for S3 backend, thanks @daniel0m0baker
  • Add possibility to set custom SQlite pragmas, thanks @gpatel-fr
  • Updates Newtonsoft, Mega and SSH.NET libraries, thanks @gpatel-fr
  • Raise the file time shift to 2s for Mac unittests, thanks @gpatel-fr
  • Remove obsolete Letsencrypt cert in Docker builds, thanks @Bubblesaway (forum)
5 Likes

Thanks for the effort for the release.

  • re: minimum Mac compile target, missing Fedora package, Mac OS notarizing, I will try to get better knowledge of all that.

  • forum outdated keys, new private IP for the VM not much I could do about that I think.

I have upgraded a test Canary install under Windows and nothing seems to be broken - it would have been particularly galling given the very conservative approach for this release.

Now waiting for reports from Mac users and if all is good, then to a new beta. Hopefully no new breakages in the release script will happen in only one or two weeks.

2 Likes

It’s absolutely great to see progress! :rocket: Even if the compact / corruption issue isn’t fixed. Which is (imho) currently the only major issue afaik.

3 Likes

Nice work! Testing the docker version first…

Do you have a link to this issue?

Hi there! :wave:

I have just updated to the this new version via the webUI. After clicking to activate it, it got stuck into a loop for some time and when I tried to access the webUI again, the service was down.

I restarted the service via SSH, but I still could not access the webUI. Would it be the case to restart the webserver that supports this UI?

I’m running Duplicati on a Ubuntu 22.04 box.

Thanks!

Rodolpho

Hello @rodolphoarruda

I am currently investigating a very similar problem. In the mean time, I suggest that you use the Debian installer from here:

Activate downloaded upgrade sometimes fail #3371 is an old known bug that has so far escaped fix.
I got this myself on upgrade to 105 from 103. The symptoms for me are that Duplicati doesn’t restart automatically as it should and requires a manual start. This is a Windows install which has TrayIcon.

Duplicati components explains where functionality lives. You’re probably on the Duplicati.Server.exe.

The earlier explanations set the context for me to say that this webserver is in the Server, so restarted.
I guess you can check processes. There should be two. Also see where you’re browsing to. Should be port 8200, and you can verify the LISTEN by using netstat or sudo ss -tapn | grep 8200 | grep LISTEN

While writing this, the post above it suggests maybe there’s an issue beyond the usual. If so, thank you for finding it. You can test out systemctl status duplicati, also stop, start, etc. to see if it starts.

Example data from Linux Mint 19.3:

# systemctl status duplicati
● duplicati.service - Duplicati web-server
   Loaded: loaded (/lib/systemd/system/duplicati.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2023-04-12 08:44:45 EDT; 6s ago
 Main PID: 2573 (mono)
    Tasks: 17 (limit: 3494)
   CGroup: /system.slice/duplicati.service
           ├─2573 DuplicatiServer /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=loopback
           └─2577 /usr/bin/mono-sgen /usr/lib/duplicati/Duplicati.Server.exe --webservice-interface=loopback
# ss -tapn | grep 8200 | grep LISTEN
LISTEN      0        50              127.0.0.1:8200              0.0.0.0:*       users:(("mono-sgen",pid=2577,fd=9))

Maybe a newer Ubuntu than mine is based on is key to a different issue? My system is based on 18.04.
The fix listed for the hasher was aimed at a 22.04 problem. If there’s a start issue too, what is its scope?
Before assuming there’s a start problem, please see what results you can find from further investigation.

Yes, that’s what I did right after the UI became unavailable, but it did not bring the UI up again. And now I see from your reply that /duplicati.service - Duplicati web-server/ so I would guess the web-server is restarted in tandem with the app server.

I was not making much progress, so I decided to reboot the server. Once it was done, I could access the webUI and things seem to be back to normal.

That’s what it says in Duplicati components, linked above. The Server:

a web server is included in the server component

and from a systemctl perspective, they’re all one thing (to go up or down).
Maybe someone else will see this and test, or maybe we’ll hear more news.

That’s good to know. One more clue, plus it helps if anyone else sees this…

Yes the auto update is working fine… with only the caveat that when something is wrong in the downloaded files from the update site for any reason (lack of disk space or antivirus shenanigan), there is not much of a warning and things fail silently.

If “fine” means “no worse than before”, that’s good to know. There was no improvement expected here.

2.0.3.14_canary_2018-11-08 was the removal of the 2.0.3.13 fix attempt, and the discussion was here:
Activate downloaded upgrade sometimes fail however we didn’t get the time to look at today’s problem. Mine is always transient, meaning it’s not like a file was mis-installed. Just hand-start, and it runs fine…
Unless @rodolphoarruda recalls more information on what was running, I think we lost that opportunity.

my problem was transient too once I deleted the failed update and tried again after making enough available free space and waiting dutifully for the antivirus to terminate its operation before clicking too early on the wrong button :slight_smile:

I might have new information to share by next morning BRT after the conclusion of the backup jobs that are supposed to run overnight.

If you don’t hear from me, though, it will indicate jobs ran as expected.

Alas, the dmg build doesn’t work for me—the process exits a second or two after launch without ever showing a tray icon :frowning:

Ditto ‘no tray icon’ on a new Mac dmg install.

I was able to start the server manually and observe the GUI after a restart. On the good side, the scary (unverified developer) warning is no longer popping up.

can you launch the trayicon by hand in a terminal window

mono Duplicati.Gui.TrayIcon.exe help

and report the output (only the first lines with the supported toolkits matter)

if there is no output, try the same but pipe the result:

mono Duplicati.Gui.TrayIcon.exe help | more
gileadis@Daves-iMac Resources % mono Duplicati.GUI.TrayIcon.exe help
Supported commandline arguments:

--toolkit: Choose the toolkit used to generate the TrayIcon, note that it will fail if the selected toolkit is not supported on this machine
    Supported toolkits: winforms, gtk, cocoa

Is gtk the smoking gun?

could be. Can you try to launch it with --toolkit=cocoa ?

gileadis@Daves-iMac Resources % mono Duplicati.GUI.TrayIcon.exe --toolkit=cocoa
2023-04-13 15:43:16.167 mono-sgen64[57918:2060961] Could not find `appindicator-sharp` referenced by assembly `Duplicati.GUI.TrayIcon, Version=2.0.6.105, Culture=neutral, PublicKeyToken=null`.
Unexpected error: System.IO.FileNotFoundException: Could not load the file 'appindicator-sharp'.
File name: 'appindicator-sharp'
  at System.AppDomain.Load (System.Reflection.AssemblyName assemblyRef, System.Security.Policy.Evidence assemblySecurity) [0x0007a] in <bab7d1a00376483b944db50cdc31e41d>:0 
  at (wrapper remoting-invoke-with-check) System.AppDomain.Load(System.Reflection.AssemblyName,System.Security.Policy.Evidence)
  at System.AppDomain.Load (System.Reflection.AssemblyName assemblyRef) [0x00000] in <bab7d1a00376483b944db50cdc31e41d>:0 
  at (wrapper remoting-invoke-with-check) System.AppDomain.Load(System.Reflection.AssemblyName)
  at System.Reflection.Assembly.Load (System.Reflection.AssemblyName assemblyRef) [0x00005] in <bab7d1a00376483b944db50cdc31e41d>:0 
  at ObjCRuntime.Runtime.CollectReferencedAssemblies (System.Collections.Generic.List`1[T] assemblies, System.Reflection.Assembly assembly) [0x000a0] in <e4522fda950a42e1a61f97b36f071593>:0 
  at ObjCRuntime.Runtime.RegisterEntryAssembly (System.Reflection.Assembly entry_assembly) [0x0002f] in <e4522fda950a42e1a61f97b36f071593>:0 
  at ObjCRuntime.Runtime.RegisterAssemblies () [0x00006] in <e4522fda950a42e1a61f97b36f071593>:0 
  at AppKit.NSApplication.Init () [0x00022] in <e4522fda950a42e1a61f97b36f071593>:0 
  at Duplicati.GUI.TrayIcon.CocoaRunner.Init (System.String[] args) [0x00001] in <e98c34ad898147e8a9669bdece28c5ac>:0 
  at Duplicati.GUI.TrayIcon.Program.StartTray (System.String[] _args, System.Collections.Generic.Dictionary`2[TKey,TValue] options, System.String toolkit, Duplicati.GUI.TrayIcon.HostedInstanceKeeper hosted, System.String password, System.Boolean saltedpassword) [0x000f9] in <e98c34ad898147e8a9669bdece28c5ac>:0