Impossible to connect to mega.gz (API response: ResourceNotExists)


For 10 days, backups are not working with duplicati. The connection between duplicati and failed.


I use duplicati with docker-compose :

Duplicati version :

I read this support about a problem similar : Unable to connect to - API response: -26. But I don’t use 2FA on my mega account.

I tried to use old version of duplicati container, I mean 1/2 months ago. Same result about the error.

Any ideas?


Welcome to the forum @coaut

I’m assuming this has been on for awhile, you haven’t been changing things, and it just broke.
MEGA is typically non-receptive to use by software that’s not their own, and likely won’t help with that.

is the definition in the third-party library used, and it sounds pretty broad. Is your login still working?
Does MEGA provide ways to see Duplicati files? Are they present? Does Test connection work?
That’s typically a file listing that doesn’t care about the files seen, but your failure is a file listing too.

Duplicati.CommandLine.BackendTool.exe will let you experiment, possibly safest in different folder.
Export As Command-line will give you the URL for your backup destination, but you can easily edit.
Duplicati.CommandLine.BackendTester.exe can run an automated test, if you’d rather go that route.

Hello @coaut

latest Canary (105) has an update to library.

Good suggestion.

was the known caused-by-MEGA-change problem that the new lib fixes. Maybe it fixes this too?
So there’s another option. Release: (canary) 2023-04-09 seems to be testing out well.
Canary is pretty untested at first release, so long term one might prefer Beta, when it comes out.

Thanks for your answers.

“I’m assuming this has been on for a while, you haven’t been changing things, and it just broke.” Yes, totally.

I have tested with the version v206.105.canary and I have the same result.

I can’t pass the “Test connection” :

Thank you for giving Canary 105 a whirl. Next steps would be in the other things that were posted.