Release: (canary) 2018-10-23

Nope, mine is a purely vanilla Windows install.

Linux (Ubnuntu) upgrade from worked (and restarted) fine with the following pre-existing exceptions:

  1. If connected to GUI “Show” screen with a password window never refreshes (I think it’s waiting, but not prompting, for a password) - manual reload of main page URL resolves this.

  2. After update, still get prompted that update is available.
    Found update

@kenkendk, it looks like there was a database version update from 5 to 6 in this release. Has anybody tested if it’s possible to downgrade back to yet?

Note that I’ve already updated this #howto on the assumption that a downgrade will NOT work:

After upgrading to the latest canary, I started receiving the following error on the OneDrive v2 (personal) backend (some information redacted for privacy):

Failed to connect: BadRequest: Bad Request error from request Portatil Method: GET, RequestUri: ‘ Portatil’, Version: 1.1, Content: , Headers: { User-Agent: Duplicati/ Authorization: Bearer <bearer> } StatusCode: 400, ReasonPhrase: ‘Bad Request’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers: { Transfer-Encoding: chunked request-id: <request-id> client-request-id: <client-request-id> x-ms-ags-diagnostic: {“ServerInfo”:{“DataCenter”:“North Europe”,“Slice”:“SliceC”,“Ring”:“2”,“ScaleUnit”:“000”,“Host”:“AGSFE_IN_27”,“ADSiteName”:“NEU”}} Duration: 10.5459 Strict-Transport-Security: max-age=31536000 Cache-Control: private Date: Sat, 27 Oct 2018 10:02:09 GMT Content-Type: application/json } { “error”: { “code”: “BadRequest”, “message”: “Resource not found for the segment ‘root:Backup Portatil’.”, “innerError”: { “request-id”: “<request-id>”, “date”: “2018-10-27T10:02:09” } } }

Maybe it is just a temporary issue with OneDrive, but the onset of the error does seem to coincide with my installation of the update. I haven’t been able to complete a backup job to this backend since.

May be relevant: I currently use the OneDrive v2 backend because I have second factor authentication enabled on OneDrive (this did work seamlessly in the previous canary).

I have a fix for the OneDrive issue and will post it for review after some more testing. See the GitHub issue here:

1 Like

The database change was to add descriptions to backups. In principle that shouldn’t break anything.

I just confirmed that downgrading from -> (on Windows 10) causes this error:

A serious error occurred in Duplicati: System.Exception: Failed to create, open or upgrade the database.
Error message:
The database has version 5 but the largest supported version is 4.

Putting back in the updates folder got things running again.

That’s why it’s in principle. The db version check still fails :slight_smile:

1 Like

I found that when i try to cancel a backup (stop after uploading) it never stops. Other than that, I’m pretty good.

Hi @DisplayNerd, welcome to the forum!

Did you choose cancel “now” or “after upload completes”?

It was stop after downloading. I just realized i had a very high async upload limit with not as much bandwidth, so it would normally take a long time to stop (don’t know why I did that). However, I left it stopping for over an hour and it changed back to regular uploading. When I forced stopped I got a warning next time I tried to upload. I promptly downgraded back to Did the same procedure in w/ same upload limit and everything was fine. It seems like this feature may be broken (could somebody test this)
P.S. I’m using the docker version and I also got the same bug with the upgrade dialog being shown after upgrade.

Just FYI, it’s not recommended using the upgrade functionality inside docker. You’d have to mount out the updates folder to not lose the update immediately on container restart. And even then you may run into trouble.

Yes, the version check is there because it is hard to have a foolproof way to check if the changes are compatible or not.

The update is very simple, so something like this SQL query should be able to revert the update (not tested!):

CREATE TABLE "BackupTemp" AS SELECT "ID", "Name", "Tags", "TargetURL", "DBPath" FROM "Backup";
DROP TABLE "Backup";
ALTER TABLE "BackupTemp" RENAME TO "Backup";
UPDATE "Version" SET "Version" = 5;

It should ideally just DROP COLUMN "Description" FROM "Backup" but SQLite does not support DROP COLUMN

I was planning to push out an experimental build based on the latest canary, because OneDriveV1 is shutting down on nov 31st. But with this problem, would it make sense to wait for a verified fix before we push the experimental out?

The comment from @kenkendk worries me unless Microsoft has changed plans. I still can’t find a nov 31st date mentioned elsewhere, but I can find November 1, 2018 still said at Migrating from Live SDK to Microsoft Graph

A DROP COLUMN method via DB Browser for SQLite buttons is here in forum, linking here in stackoverflow. Windows users need to have Duplicati open their database with --unencrypted-database option first though.

I switched one of my configurations to use the MS Graph API to reproduce the problem and for me, the fix has resolved the issue. However, it would be nice to get some independent verification…

Sounds like that might be related to my issues here:

The workaround provided in the Github issue (double slashing) did solve the problem in my case. Thank you for your help!

Yes, you are correct, I meant oct. 31st, but the real date is nov. 1st