Release: 2.0.2.18 (Canary) 2018-02-11

canary

#1

2.0.2.18_canary_2018-02-11

  • Fixes to the “advanced options” list in the GUI, thanks @Pectojin
  • Fixed OpenStack URI selector in the GUI, thanks @Pectojin
  • Added workaround to broken OneDrive file listing, thanks @osmogar
  • Improvements to the log page, thanks @Pectojin
  • Fixed a scheduler issue with clock drift, thanks @Pectojin
  • Added option to ignore metadata when importing a backup, thanks @Pectojin
  • Improvements to backup retention, thanks @TekkiWuff
  • Added --parameters-file to the server, thanks @Pectojin
  • Fixed incorrect size requirements for Synology package
  • Fixes to the DuplicatiVerify.ps script, thanks @mnaiman
  • Fixed showing backup durations longer than 24 hours, thanks @Pectojin
  • Fixed leaving orphan data in the settings database after deleting a backup job, thanks @Pectojin
  • Fixed many caching issues, which should also fix the XSRF error message
  • Fixed sending “run now” commands in front of the backup queue, thanks @Pectojin
  • Added warnings when the backup is nearing the quota limit, thanks @tygill
  • Fixed all reparse points were treated as symlinks, which fixes backup of OneDrive folders, thanks @tygill
  • Fixed a crash on very fast copy operations, thanks @TekkiWuff
  • Added .m2ts (BlueRay container) to the list of non-compressible extensions, thanks @Pectojin
  • Fixed a bug in the box.com backend that prevented backups
  • Fixed a weird “0 warnings” message
  • Made the GUI menu stay in place instead of scroll away, thanks @Pectojin
  • Fixed a problem where default filters were not applied when running from the server, thanks @tygill
  • Added limitations to the usage reporter, so it does not attempt to submit a large backlog of data
  • Fixed two cases where commandline arguments were not correctly formatted when sent to new processes
  • Added support for disabling the file-size read-ahead scanner

Cannot start Duplicati - "Error: UsageReporter failed"
#2

@Pectojin
I’m not gonna say I’ve not been busy, but it really looks like more than it is. I just close all the easy ones :wink:

This one is like 50/50 with you @kenkendk, you submitted most the code before me :stuck_out_tongue:


#3

@kenkendk Did you compile the less for this release? I’m looking at the fix for Log information cut off after prefix · Issue #2812 · duplicati/duplicati · GitHub and I still have overflow:hidden on the live log entries, even after clearing my cache.


#4

Unfortunately this one doesn’t work for me…
Menu at left side still scrolls off the screen along with the list of backup jobs.


#5

Did you clear cache as well?

Then I’m definitely going to say less wasn’t compiled. That’s two separate issues, depending on CSS, that don’t work.

These 100% work when I manually compile the less in my dev build.


#6

I’ve tried 4 different browsers (IE, Edge, Chrome, FF), connected to 2 Duplicati instances (Windows 10, Netgear NAS), cleared cache, all with the same symptoms: menu keeps scrolling up and down, there’s no difference with the previous versions for me.

Duplicati reports V2.0.2.18, used the internal updater to install the latest version.

image


#7

Just for kicks, can I get you to open the live logs in Chrome under About -> Show Log -> Live and selecting Profiling?

They’ll be invisible unless you have the new CSS that is supposed to be in 2.0.2.18


#8

No, I did not compile it :frowning:


#9

New version out, with recompiled CSS and updated translations.

Well … your code went into the repo, not mine :partly_sunny::cocktail:


#10

Issue resolved in 2.0.2.19!


#11

Once again, when I had --keep-versions=1 and now I change it to custom backup retention, the UI stores both options and I am doomed. Because UI still does not clean up the command line with the new settings.

It will not backup and complains:
“Setting multiple retention options (–keep-versions, --retention-policy) is not permitted”

I then can add the keep-versions via advanced options, save, remove it, save, no it will stay there. Now with Canary I have made all backups dysfunctional this way. Will probably have to export and re-import all backup definitions, or create from scratch.

EDIT/SOLUTION: I forgot, I found out about the solution some days ago.

  1. Set to “Keep all backups”
  2. Save
  3. Set to whatever retention setting
  4. Save

Should 2.0.2.19 be promoted to the experimental channel?
#12

I’m now having this issue (or similar). I previously had my backup versions set to remove all backup versions older than 2 years, and (separately) a retention policy set via the Advanced Options setting to thin out backups until then. Now (for reasons I can’t guess at), Duplicati errors out when I try to run a backup job because of 2 retention settings (which worked fine before, and logically stack).

Also if I try to simply move my old “advanced options” retention policy setting (copied below), Duplicati refuses to save the configuration, complaining “Retention value must be more than 5 minutes”.

3D:0s,2W:1D,3M:1W,1Y:1M

I can’t get it to stop complaining about this, no matter what I set the value to.

Edit: @Tapio’s solution from above appears to have worked in my case too.

My followup question: If I want to use retention policy but ALSO delete all backup jobs OLDER than a certain date, matching the “Delete Backups that are older than…” setting, how do I do this? Or are we simply to assume that the retention policy completely replaces the “delete older than…” functionality altogether?


#13

Will remove anything older than 1 year. Your new policy should be:
3D:0s,2W:1D,3M:1W,2Y:1M
To keep it for 2 years and get the exact same functionality

Edit: we made them give errors when combined to avoid causing data loss. If they didn’t you’d suddenly find you only had 1 year retention :slight_smile:
Although it’s weird with the problems reported about not being able to change the settings. Also I think we have an active issue in GitHub on "Retention value must be more than 5 minutes”.


#14

Thanks, I was close but was slightly mis-interpreting the syntax I guess. I’ve now settled on this

3D:0s,2W:1D,3M:1W,1Y:1M,3Y:6M,5Y:1Y

which by my understanding means “…, for 1 year keep 1 backup per month, for 3 years keep one backup every 6 months, for 5 years keep one backup per year, and delete everything older”. This is for my work laptop so even the 5 year lifespan is over-generous :wink:


#15

That sounds right. After 5 years you should have X+14+13+12+6+5 backups.

I like to do 13W:1W instead of 3M:1W because 3 months is like 12.8 weeks which triggers my obsessive compulsive non-disorder :wink:


#16

lol, fair point, i’ll probably revise to follow that since “month” is a pretty vague term when thinking about specifics.


#17

So you’re saying it’s a good thing there’s no code for “decade” 'cause we’d have to make it be 10.0014 years? :wink:


#18

I dont even know what to say…


#19

Yeah, I would also like support for Roman numerals notation. :wink:


#20

And don’t forget mathematical expressions

"60*60*24s:60*60s"

:wink: