OVH Public Cloud: new Keystone API


OVH is updating the Keystone API from v2 to v3.

Thus, the old endpoint should be changed to

It seems Duplicati already supports Keystone v3, so this is only a matter of adding a new endpoint.

FYI, here is the email I received:

Dear customer,

A few weeks ago, we notified you by email[1] that we are discontinuing v2 of the Keystone API on 24th March 2020. All users of the Keystone API must now use version 3, and make the changes required to do so.

Our last analysis shows that you are still using v2 of the API.

With most updates of this nature, you just need to modify the endpoint and the API version, but this change requires specific attention, which must be executed before 24th March 2020. Please update your tools or applications accordingly.

You can find more information on our status page[2].

Thank you once again for choosing OVHcloud.

The Public Cloud Team


is probably the line. It sounds like v2 is history. The hardest thing is the short deadline. The last Beta took 14 months to push out. Possibly this could be done as a rarely-done patch, now that the number scheme is able to allow them. The patch to make Beta ( plus patch) confused people.

Are you on GitHub? An Issue gets more attention and tracking. Support topics are lost way too easily.

OpenStack OVH discontinuing Keystone 2.0 API is reporting that it doesn’t. I don’t have OVH myself.
That’s the bad news. Can you help @Backarchy any? The good news was the URL can be entered.

Hi @Indigo744
Have you been able to use OVH with the following configuration?


Sorry @Backarchy, I didn’t see your post before posting mine. I hope you don’t mind.

I am very happy to report that I managed to connect to the v3 API.

I set the URL to the new one as a custom URL (, then I select Keystone API v3.

But I struggled with the Domain Name value. I didn’t know what to use, and OVH does a really poor job in explaining any of this.

So I went to the OpenStack v2/v3 doc page, which actually says:

Both the user name ( my-username ) and project name ( project-x ) are namespaced by an owning domain (where id = default ). The “default” domain exists by default in Keystone, and automatically owns the namespace exposed by Identity API v2.0.

So I set to Domain Name to default. And it worked!

So this is really good news: Duplicati can still push the new endpoints for a future version (and helping future user to set up Duplicati with OVH), but we won’t have to wait to be able to migrate.

Have a nice evening!

@ts678 : I do have Github, so do you want me to open an issue so we can update the OVH Keystone v3 auth endpoint?

1 Like

Please do, and I wonder how many of the other predefined values are doing the same transition now?

It’s great to hear that (at least for now) OVH looks like it can made to work without Beta patch release.

Done: OVH Public Cloud: new Keystone API · Issue #4087 · duplicati/duplicati · GitHub

I really don’t mind !
Your solution worked perfectly.
Just for other users, you cannot let Domain Name “blank” but have to write “default”.
Thanks a lot @Indigo744

Hi @Indigo744

The connection parameters have working perfectly for a week. I have done my daily backup with no issue.
Since today (a few minutes ago) I get the “Failed to connect: The remote server returned an error: (401) Unauthorized.” error again.

Do you have the same issue or it is just on me?

Just tested, and still works for me! Maybe a temporary issue from OVH?

Hope it will work out!

It just worked again.