OneDrive backups no longer work after Windows April 2018 Update

Since upgrading Windows 10 to the April 2018 Update (v. 1803) my OneDrive folder has stopped backing up. It seems that every folder within OneDrive fails with a warning, and subsequently the files within are no longer being backed up. (It worked fine prior to the Windows upgrade.)
An example of the warning that duplicati reports is below. This happens on every folder that is within my OneDrive local folder. Note that I have OneDrive configured to always have a local copy of the files, and I have the Duplicati symlink-policy set to “Follow”
Note that, as a test, I placed a file directly in the OneDrive folder (i.e. not in a subfolder) and that file backed up. So it appears to be an issue with the folders within the OneDrive folder.

Failed to process metadata for "C:\Users\bkob\OneDrive\Videos\", storing empty metadata => (19) The media is write protected: 
[\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy12617\Users\bkob\OneDrive\Videos],
Error reported while accessing file: C:\Users\bkob\OneDrive\Videos\ => (19) The media is write protected: 
[\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy12617\Users\bkob\OneDrive\Videos\*],	
Error reported while accessing file: C:\Users\bkob\OneDrive\Videos\ => (19) The media is write protected: 
[\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy12617\Users\bkob\OneDrive\Videos\*],

I can’t test this (haven’t updated yet) so hopefully somebody else using OneDrive can chime in about their experience.

Normally empty metadata messages are warnings, not errors, which shouldn’t cause things to no longer back up. Is it possible there might be some actual errors in your logs that would cause a backup to fail?

Granted, the warning shouldn’t be happening either so lets see if we can figure out what’s up with that…

Do you get the same “storing empty metadata” error in either of these scenarios?

  • create a new folder with a new file in it (this could help narrow down if the issue is solely related to content created prior to Windows 10 v1803)
  • create a new file in an old folder (this could help narrow down if the issue is folder or file related)
  • copy file from an old older to a new folder (this could help narrow down if the issue is new vs. old folder or file related)

(By the way, I edited your post by adding “~~~” before / after the error message to help it stand out.)

Hi Jon,
Thanks for the reply.

I made a test of each of your suggested scenarios, and here’s the results:
New folder with new file - backs up!
New file in an old folder - fails
File copied from old folder to new folder - backs up!
File moved from old folder to new folder - fails

Also, note that it is not only “storing empty metadata” errors, there are also “media is write protected” errors.

Thanks,
Bob

Thanks for doing those tests!

Since all (file & folder) new content works I’m guessing something has indeed changed in how Windows handles “legacy” content.

I believe both @kenkendk and @Pectojin have used OneDrive so I’m going ask if either of them has a post-April 2018 Windows 10 box showing similar issues.

Thanks Jon,

One other test that I did was to create a new backup to see if it may be something wrong in the Duplicati backup information, but I had the same results with the new backup.

Hi, @rkobriger Are you making use of the ‘files on demand?’

This is a new (revived, old) feature where the files/folders on disk are actually not locally present but are an exotic filesystem object called an NTFS Reparse point. When the OS encounters request to open the file, it’s supposed to sync it automatically from the OneDrive service.

However, I think there can sometimes be issues. These have caused (different) issues w/ duplicati in the past:

-The recommendation there (Comment #6) re symlink policy may still be valid-

EDIT: oops: I didn’t notice that part of your post.

I have just verified that I have the “Files On-Demand” feature turned off, and my symlink-policy is set to “Follow”

I believe that I have found the solution to the OneDrive backups failing after the April 2018 Update on Windows 10…
I found a forum post for a different backup application that was complaining about the same issue, and it was suggested to use the fsutil utility to delete the reparsepoints. Fsutil has 2 options - query and delete. So I used the query option and verified that my pre-existing files and folders had reparsepoints, but the new folders and files that I created after the Windows 10 update did not have reparsepoints. So I deleted the reparsepoint for one of the folders and a file inside of it, and sure enough, that file then backed up!
Unfortunately, the fsutil only allows you to delete a single reparsepoint at a time, and I did not want to do so with the thousands of files in my OneDrive folders.

So, my theory is that the April 2018 Update either: creates reparsepoints even though i have “Files on Demand” disabled, or somehow the reparsepoints were ignored prior to the Update.

My solution was to re-enable “Files on Demand”, reboot, and then re-disable “Files on Demand”. The result of this was that all of the reparsepoints went away, and now the backup runs without error!!

Thanks to all who gave input to my issue.
Bob

1 Like

Thanks for figuring it and and sharing your Fix with us! I’ve gone ahead and flagged your post as the solution.

I don’t know much about how OneDrive works, but it sounds like we might want to better handle reparsepoints going forward… or has this already been covered @kenkendk?

Hi,

I have been experiencing this same problem as well. But I finally disovered, that I also had moved some files out of my OneDrive and into my Dropbox. So then the solution above did not work for me.

The fsutil, did how ever seem to be able to remove the reparsepoints, so that my backup now completes successfully.

I wrote a script if it could be useful for anyone else.

cd "C:\Users\MyFolder\"
  for /R %%f in (*.*) do (fsutil reparsePoint delete "%%f")

Be aware that it will loop through all files and folders in the folder, recursively, and try to remove the reparsepoints. :slight_smile:

2 Likes

storing empty metadata = (19); Is still an issue on some of my backups. I have tried the reparsepoints. Enabling and disabling offline storage with onedrive. Reinstall duplicati symlinks store, follow, off does not make a difference.

There still seems to be an issue regarding the onedrive reparsepoints from my point of view. If you hgave any suggestions that i could try, ill test it and post the feedback in this thread.
best regards,
Ruud.

What version of Duplicati are you using?