New OMV Installation - Multi-User Password Fails

Installed Duplicati on OMV 4 via OMV plug-in. During installation, I was prompted to set a password for server access if in a multi-user environment, so I did. As soon as I set the password, I was immediately sent to a password request display for Duplicati, where the password that I had just setup doesn’t work.

I have searched and found a number of others reporting the same issue, but no one has been provided a solution. I have tried uninstalling/reinstalling Duplicati, but I am immediately presented with the password request prompt when I try to access Duplicati at the end of the installation.

Hello @binxbolling and welcome to the forum!

What happens? Nothing? Entry field cleared? Error message said somehow?

Alternatively, can you post any links describing exactly the symptom you see?

What I’m finding for some issues is workarounds and fixes, but it’s not clear your OMV plug-in is current. Last one released as OMV plug-in appears to be what Duplicati calls Release (beta) 2018-04-02 and if this gets in OMV or plug-in specifics, forum help here may be limited. Did you reinstall using same version, done the same way using the plug-in system? Have you restarted Duplicati (or the entire NAS)?

Are you able and willing to install packages directly? I’m not sure how that would interact with the plug-in system, but Release: (beta) 2018-11-28 is downloadable direct from Duplicati as a .deb package.

If you want to find your Duplicati version, but none of the above techniques let you in, you can see if your system has a /usr/lib/duplicati/changelog.txt on it. It’s also probably possible to remove the password by restarting Duplicati (maybe /usr/bin/duplicati or /usr/bin/duplicati-server – what does ps show up?) with:

–webservice-password: The password required to access the webserver. This option is saved so you do not need to set it on each run. Setting an empty value disables the password.

(quoting from the help you can read if you run Duplicati with the help command as its command)

Uninstalling and reinstalling applies to Duplicati code, not Duplicati configuration (and you certainly would not want it otherwise, because you’d lose the backup databases commonly in ~/.config/Duplicati), so the password persistence is not a surprise. Do you have a configuration or backups you care about already?

The response from Duplicati is “Failed Authorization.”

The Duplicati plug-in was the most recent version available. It provided no verson information.

I have uninstalled, reinstalled, purged, rebooted and have tried all of those things multiple times.

I have tried using the cli to disable the password, and I just receive a notification that another instance of Duplicati server is running and the request has been passed to it with no change.

This is my first attempt to get Duplicati running on OMV, so I have no backups, and I just want to get it completely removed, including all settings.

I’m not finding reports of that exact message in this forum or GitHub issues. You mentioned other reports?

Yes, but maybe not the most recent version available directly. Maybe you need to ask for a newer one like
Duplicati was requested three days after its release. That post also says one can directly install, if there is not a plug-in, meaning (if it’s correct) you can install directly if you don’t have that, and you can probably find out if you have that from the changelog.txt I described, assuming you have shell access.

The OpenMediaVault Plugin developers sound like they don’t want to keep up with Duplicati releases, but possibly a case could be made if there’s a generic password problem with (and there is, however failure presents differently than your message from what I can tell). Still need to debug what’s going on…

Your other instance of Duplicati server probably needs to be stopped first, which requires using systemctl from your OpenMediaVault 4 installation which is described as very close to Debian 9, known as stretch. systemd - system and service manager is more information on how to deal with services on your system.

Because you want to remove Duplicati thoroughly, you can also look for the config directory I mentioned to see if you can remove it underneath the running Duplicati. If so, then a reboot shouldn’t have a password. Going on without one can find the Duplicati version in About on the home screen. This password can be added and removed at any time in Settings on the home screen (but possibly you’ll get a lock-out again).

Gave up on trying to get the plug-in to work by itself and installed the most recent vs of Duplicati on the OMV server. I then followed the instructions below to resolve the password issue:

1 Like

I’m glad that worked for you. Although we don’t know what you were on before, my comment about a previous problem had the below in mind (even though your symptoms were different). To further weaken my idea that was buggy, because it came from which came mostly from, is that the source code for looks like it pulled in the fix. Regardless, these issues were the suspects…

Setting password for the first time causes never ending failed request loop #2844
Login impossible after setting GUI password #3035 fix was release-noted as:

Fixed a problem with setting the initial password on the server and some change-password issues, thanks @mnaiman

Whatever the problem was, I’m glad it’s gone now, and thanks for posting what the solution was for you…