Installed latest Duplicati but can't see it as a service


I have installed latest version of Duplicati and have read that it should install as a service.
I’m running windows 10 x64 and have looked in “Control Panel\All Control Panel Items\Administrative Tools” and then clicked “Services”. What is the name of the service? I thought it should be named “Duplicati” but it isn’t there so maybe I has a different name.

NOTE: There’s a red Duplicati icon in the tray.

Best Regards

Hi @Jarek_Tylenda

Until there is an actual service installer, you need to run Duplicati.WindowsService.exe as an extra later step after an initial install (e.g. from .msi) that does NOT do the automatic or manual start (which is the tray icon).

By default the tray icon contains a Duplicati server, and it can also open the web browser to connect to that. When running as a Windows service, you probably want either no tray icon or run it with --no-hosted-server.

Huge thanks for helping me out with this, I can now see the service. I thought I have read the manual but I didn’t know I had to run deeper in to the settings :blush:

I really don’t understand your last sentence. Why wouldn’t I want to see the tray icon? Isn’t that good to see that Duplicati is up and running as well as start the web server from there? I mean just to have the control over it visually.

Also what would it mean to set the “–no-hosted-server” option-“.
I would like VSS to work is the above option good for doing that?

Sorry for these simple mind questions, but I’m eager to learn.


Duplicati generally has a lot of pieces that go together in many ways, and this can cause problems/confusion.

Seeing the tray icon is fine, and it takes your browser to Duplicati, however the web server is Duplicati server.

Generally the server is accessed at http://localhost:8200, but if 8200 is in use, the NEXT one takes 8300, etc.

One generally doesn’t run multiple servers, so you may wish to decide if you prefer the service which runs at boot and can backup any user, or if you want Duplicati to run at login, and lacks VSS for non-Administrators.

Out-of-the-box, the current install does the latter nicely, and if the user is an Administrator they can get VSS.

Service is more trouble now, and requires editing Windows shortcuts, e.g. on the desktop and login autorun. Sysinternals Autoruns or Google can help find it, and you can edit the desktop shortcut directly by right-click. One problem is the next Duplicati install from .msi will write over your custom shortcut, but you can rename it.

If you don’t need a tray icon, you can omit the previous paragraph and use a browser shortcut or something, however you also have to deselect some things during the .msi install, or it will helpfully create the shortcuts.

For your VSS, if user is an Administrator and you just need backups when logged in, you don’t need service other than the one that’s built into the tray icon, but if you fall the other way, you probably want to push tray icon’s version of the service aside by adding --no-hosted-server to its shortcut (probably in the Target field).

Still not a complete step-by-step, but I hope that helps clear up what’s going on. Thanks for wanting to learn.

Wow, thanks for an extensive answer. It’s a lot of stuff to learn and probably it’s all try and learn by the mistakes, like everything else. Duplicati is logged in as a Local System Account and it’s an admin account. But again, I will have to try out the different possibilities you have mentioned.

I really appreciate that you took your time and helped me out.

Best Regards

I forget where the databases (e.g. Duplicati-server.sqlite and the randomly named per-job databases) land by default for the local system account, but if you don’t see them in the user account that did the install, then see

Installed Windows 10 Fall Creators Update - Now Everything is Missing In Duplicati for another complication of running as a Windows service. Environment variable DUPLICATI_HOME can control where things get stored…

Unfortunately, service is still the harder path, but it does bring benefits. Someday it should get more automatic. There is definitely some learning curve to lots of things, but at least it’s out in the open so that it’s learnable…

Glad to help. When you’ve got enough figured out, you can come back here and help some other person. :grin:

OMG. Better to use that variable as soon as possible, (DUPLICATI_HOME). Better safe than sorry. I’ll dig on to the Windows Service.

Once again thanks for helping out and yes, for sure I will be logging in to the forum to see the tips and tricks and of course if I can answer questions where I have the knowledge.


Hi, well this is what I was worried about it won’t backup my opened Outlook file:

_System.IO.IOException: The process cannot access the file because another process has locked a portion of the file. at System.IO._Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.ReadCore(Byte[] buffer, Int32 offset, Int32 count) at System.IO.FileStream.Read(Byte[] array, Int32 offset, Int32 count) at Duplicati.Library.Main.Blockprocessor.Readblock() at Duplicati.Library.Main.Operation.BackupHandler.ProcessStream(Stream stream, CompressionHint hint, BackendManager backend, FileBackedStringList blocklisthashes, FileBackedStringList hashcollector, Boolean skipfilehash) at Duplicati.Library.Main.Operation.BackupHandler.HandleFilesystemEntry(ISnapshotService snapshot, BackendManager backend, String path, FileAttributes attributes)

I log in as a local account. It says in “Control Panel\All Control Panel Items\User Accounts” that I am an administrator. Where do I go wrong?

First thing to check would be snapshot-policy which defaults to off and has multiple versions of enable. Locked file, errors on outlook.pst has some discussion on the finer points of figuring out which setting you want to use.

Migrating from User to Service install on Windows (and elsewhere) has discussion about various service issues, however it sounds like you might not be heading there immediately, so maybe you can migrate when/if needed.

Hi, thanks for the input. I have set the “snapshot-policy” to “on”.
I will take it step by step and see what happens tonight.

I let you know tomorrow :blush:




I followed your advice and tried out the “snapshot policy” and now it defaults to “on”.
Your advice is perfect! Huge thanks.

Note that I also rebooted my computer. I don’t know if that’s necessary but I just did it to be sure all was working from scratch, and it did.

Now I’m a happy camper and once again thanks for the steps to take :blush: