Install instructions for Ubuntu 24.04 LTS ('libappindicator0.1-cil' has no installation candidate)

Hi There,

Been using duplicati on Mac, Windows and Linux for a while, very happy. In a moment of ambition I’m installing Ubuntu 24.04 on a new system and would like to back it up using duplicati. So far I’ve not been able to install it.

The instructions on Installation - Duplicati 2 User's Manual go up to Ubuntu 23.10, this results in apt issues tho:

sudo apt-key adv --keyserver hkp:// --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

This works, gives a warning about depricated method, no errors tho.

echo "deb stable-focal main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list

Works as well.

sudo apt update

No issues.

sudo apt install mono-devel gtk-sharp2 libappindicator0.1-cil libmono-2.0-1

This results in the following error:

sudo apt install mono-devel gtk-sharp2 libappindicator0.1-cil libmono-2.0-1
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libappindicator0.1-cil is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libappindicator0.1-cil' has no installation candidate

I’m not too familiar with mono and have been fooling around with different packages. Also tried to install mono using the instructions on their site. (unfortunately those instructions only go up to ubuntu 20.04).

Any advice would be greatly appreciated.

Tried the suggestions from this post on this forum. And only installed mono-devel. This resulted in the following error:

sudo apt install ./duplicati_2.0.7.1-1_all.deb 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'duplicati' instead of './duplicati_2.0.7.1-1_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 duplicati : Depends: libappindicator0.1-cil but it is not installable or
                      libappindicator3-0.1-cil but it is not installable or
                      libayatana-appindicator1 but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve made a VM with a snapshot, so testing with with risky suggestions shouldn’t be a problem.

I’ve been digging a bit, on the page for Ubuntu 23.10 libappindicator was still listed: Ubuntu – Details of package libappindicator0.1-cil in mantic

This entry is missing on the page for Ubuntu 24.04

Ok, and some more googling led me to the page for the newer libappindicator3-1. I suppose this superceeds libappindicator3-0.1-cyl, but that is just an uninformed assumption based on the name.

So that doesn’t really help me directly, installing that doesn’t fulfull the dependencies for duplicati. It might however help get to a solution?

Thank you for reading this far.

Welcome to the forum @hermankopinga

This could use help from someone who knows the area better, but FWIW here are some more clues:

Change logs for libappindicator source package in Noble

Drop support for GTK+2.0 (libappindicator1, libappindicator-dev,
libappindicator0.1-cil, libappindicator0.1-cil-dev).

suggests that substitutions sometimes work. Next Duplicati Beta is possibly about to ship, but this issue sounds potentially serious, and Canary test couldn’t spot it easily because this Ubuntu came out April 25.

For a test, perhaps you can just unzip the .zip version then try a mono Duplicati.GUI.TrayIcon.exe

1 Like

Thank you! Hadn’t noticed that one, slight derp.

That set me up for discovery, took these instructions and modified the package to include the newer package as an optional dependency.

mkdir tmp
cd tmp
ar p ../duplicati_2.0.7.1-1_all.deb control.tar.gz | tar -xz
# edit control added ` | libappindicator3-1` on Depends line
cp ../duplicati_2.0.7.1-1_all.deb ../duplicati_2.0.7.1-1_all~hk1.deb
tar czf control.tar.gz *[!z]
ar r ../duplicati_2.0.7.1-1_all~hk1.deb control.tar.gz

This results in an installable .deb.
Running the resulting duplicati results in some errors and warnings, this could use some more investigating. Also the menu bar icon doesn’t appear automatically (webserver on port 8200 runs and I can configure back-ups).

Any pointers as what I can do to advance this further?
Specific testing? Logs?

Nice work. That’s more elegant (but harder) than the test method that I suggested.

If you want help, please clarify. OTOH it sounds like you have a lot of Duplicati experience already.

TrayIcon includes the functionality of Server which is what does that. TrayIcon adds its icon though.
Windows install tends to favor the all-in-one plan. Linux arguably favors Server plan using systemd.
Hooking TrayIcon up to a server that isn’t its own needs its no-hosted-server option to be specified.

You might have been through that already, and just wanted to report what works. Thanks for testing.

I’m not clear on what’s not working.

Do you mean the menu bar appears, but without Duplicati icon, or is Duplicati icon acting strangely?

There have been some changes in this general area both from the distros and (upcoming) Duplicati.

Get Back Top Panel App Menu Indicator in Ubuntu 24.04

Ubuntu 23.10 - No running apps on top bar

Since we are switching the underlying framework to .Net8, this release will be the last that runs on .NET 4 / Mono.
The new releases will be built with the framework included for minimal dependencies.

so this might help the dependencies issues in general, but probably not the OS design change issues.

Early preview of .Net8 builds, codename exists if you want something riskier than a Canary.
Reports have been pretty good so far (testing is very limited though) except for tray icon. Latest status:

Support for dark-mode tray icon #5148 and follow its links. I don’t know when next one will be released.

I was trying to say a lot but didn’t use enough words. Thank you for understanding.

The errors I can live with, I did my initial start from the command line not as a service. That had some warnings I unfortunately didn’t save. The persisting error when I start it manually is Gtk-Message: 21:20:16.220: Failed to load module "canberra-gtk-module"

The trayicon behaviour is curious. It’s only there after I start from the command line and even then I’ve seen it dissapear while the interface was still available. Also the first couple of times it was just a black/grey square, now it’s this one:
Screenshot from 2024-05-02 21-24-46

I haven’t seen it appear when started as a service.

I’ll give the new .Net8 build a try, thanks for pointing them out.

In general: thank you.

If you mean you ran /usr/bin/duplicati, that’s a script that runs Duplicati.GUI.TrayIcon.exe in the foreground which is kind of clunky, and also emits strange outputs occasionally. Windows desktop equivalent is in the background, so stays clean. It looks like there’s an intent to put Duplicati on the OS application start menu, where possibly it gets launched in the background. I’m not on Linux much, but an Xubuntu 22.04 seems to work this way, so if you don’t like the command line launch noise, see if Duplicati is available in app menu.

The systemd service runs the Server, so there is no TrayIcon unless you start that up as described.

I don’t know what the disappearing is about, but on the Xubuntu 22.04 VM I tried, I get double icons…