How to install Duplicati on Synology / DSM

#16

For de DS213j I don’t remember the first version of test, but I updated to the last (6.2.1-23824-2) and I get the same issue.

For DS918+ with versions 6.1.7-15284 and 6.2.1-23824-2 too.

Thanks

#17

I tested the latest release (2.0.4.5 beta) on a DS211j and a DS218+.

For the DS211j I found that Duplicati didn’t work reliably. Roughly half of the connection attempts with B2 cloud storage failed due to HTTP errors. When a connection did work, starting a backup run already took minutes – that was before the first file started transferring. Lack of space on /tmp further complicated matters. The latter problem could likely have been resolved with some effort. The former couldn’t. I concluded that the DS211j is likely too slow to run Mono/Duplicati.

My attempt with the DS218+ fared much better. Installation was smooth, and I had the first backup running with little effort.

Some comments:

  • For both systems, it was necessary to manually install root certificates (instructions)
  • I’ve observed the “Missing XSRF Token” bug with both systems (link)
  • I haven’t checked yet if the restore bug is present on the DS218+, but can report back on this.
#18

DS418play (DSM 6.2.1-23824 update 2) … Installed mono (4.6.2-0096 ) and Duplicati (2.0.4.5) and Duplicati won’t run. Tried to launch using package icon and all I get is “connection to the server is lost”.

Suggestions?

#19

Hi @Random, welcome to the forum!

Can you tell if the connection lost message coming from a Duplicati page or DSM one?

If the Duplicati server is starting then crashing there should be a lot file recoding the error, but in not sure where it would be located on you machine.

#20

I’ve got a “baby” DiskStation - a DS115j - but it’s got 3TB of storage available (I just cleaned out the junk last night). I just lost of bunch of personal data to a drive with a corrupted filesystem, and despite knowing better, I didn’t have a backup system in place. I’m running Manjaro (Arch) LInux, and I’m a developer. Thankfully, I regularly push my code to GitHub, so I can get that stuff back. What’s gone is all my pictures, music, settings, etc. Argh.

It’s really surprising to me that Synology doesn’t have a backup “backend” program that supports Linux. I’m going to keep reading the site (and studying this thread more carefully), but I hope there’s something better than having to manually schedule rsync or rdiff runs myself.

Has anyone tried putting a Linux backup server instance inside a Docker container on a NAS? That thought came to mind, but I’m not a Docker guy, so I’d have some learning to do.

#21

When I’m in Package Manager I see Duplicati… it’s button says “Run” or “Uninstall”. I select run, and after a few seconds the button shows “run” again, instead of stop.

When I use the Duplicati icon (on the installed package dropdown (from DSM in browser tab), a Duplicati window appears with the “connection to the server is lost” message and then a countdown to the next connection attempt is displayed. I doubt there ever was a connection since the Run button is always present in Package Center.

UPDATE: After rebooting the NAS, I can now start Duplicati. Initially there was a popup that said Missing XSRF token, but that is now gone. So… off to experiment…

split this topic #22

A post was split to a new topic: Restore bug on Synology if path has spaces

#23

Hi @bundito, welcome to the forum! Sorry to hear about your data loss. :frowning:

If you are asking about running Duplicati in a Docker container then yes, that’s doable (at least it with for me). I use it to back up my unRAID NAS files to an off-site location.

If you’re wanting to run Duplicati on your Synology box you may find using their package easier to with with than a Docker container.

Of course, there’s no reason you can’t try out both and see which to prefer - just don’t try to share the same destination folder. :slight_smile:

split this topic #24

A post was split to a new topic: Connection issue on Synology

#25

Installed Duplicati followed by Mono, and did not work.

Tried the other way around too (Removed Duplicati, and installed it again - where Mono was present and running on the system). Restarted the system to give it another chance, but same results.

Details:
DS414 with DSM 6.2.1-23824 Update 4
Mono 4.6.2-0096 (Beta-version from the official Synology-store)
duplicati-2.0.4.5_beta_2018-11-28.spk

2.0.4.5 server appears to be broken on Synology
#26

Have you tried the workaround I posted in this thread?

1 Like
2.0.4.5 server appears to be broken on Synology
#27

Just to flesh this out a bit, does anybody know Synology paths to the Duplicati folders (like for doing a downgrade) or do DSM package not work that way?

Also, have any of you tried uninstalling Duplicati and, if so, were they any left over files needing manual cleanup?

#28

The default location for databases seems to be /root/.config/Duplicati

I ended up redirecting this (by using a symlink) to my 16TB NAS disk volume, as root is only 2.3GB on my NAS.

#29

Thanks!

I could have sworn there was a server parameter to let you specify the “home” folder (as an alternative to a symlink), but I can’t seem to find it now.

#30

On regular Linux there is - you can just modify /etc/default/duplicati. But Synology doesn’t seem to have that equivalent. Symlink seems to work OK for me.

#31

Did you follow the step 3) in the install guide above? The message you see is exactly the symptom if you did not add your user to http group.

2.0.4.5 server appears to be broken on Synology
#32

Hey, I also have problems with Duplicati on my DS216j running DSM 6.2.1-23824 Update 4.
I use Mono 4.6.2-0096 and Duplicati 2.0.4.5. And my user is member of http group. So looking at the Threads I found so far here, I should not get the “Connection lost” error. Any idea?

#33

My solution was to have a docker instance with Duplicati, I’m running it with OpenVPN without any problems, you can check my post here : https://community.synology.com/forum/9/post/119463
I didn’t check the “path with spaces” problem.

#34

Hi @kliclick, welcome to the forum!

Thanks for sharing your method of running Duplicati on your NAS. Do you find / feel using A Docker container is any better or worse than a native spk?

#35

I used a Docker container because I couldn’t install a working spk in my Synology (DS1511+). But it took some time for a simple user like me to have all the settings working with the Docker container. A working native spk for me will be much easier to set up. I don’t know how to upgrade the Duplicati version in Docker (never looked for how-to’s in the internet), I don’t know if it’s better in terms of memory usage or other performance specs, etc. I tried the spk first, and I think it’s the easiest way. My answer (I repeat, as “normal” user) is that spk would be better.