Freshly installed Duplicati does not seem to be working on macOS Mojave (new user)


I decided to explore Duplicati this morning, but could not get it working it on macOS Mojave after quite a few attempts. The symptoms are the same for both beta and canary:

After downloading the DMG and moving Duplicati to Applications, I launch it and see a warning saying that this application is downloaded from the web (this is usual). Accepting this, I don’t see any GUI popping out, a tray icon or anything else. Going to http://localhost:8200 in Chrome shows ERR_CONNECTION_REFUSED just like for any closed port.

The app, however, shows up in the mac’s Activity Monitor and I also see ~/.config/Duplicati created every time I open the app (even if I delete it). The folder contains Duplicati-server.sqlite and control_dir_v2/lock_v2 with pid in it. Mono is installed via Brew Cask and mono --version returns mono "/Applications/" also works (I get the help screen).

Running /Applications/ --webservice-port=8200 returns

Unable to start up, perhaps another process is already running?
Error message: System.Exception: The lock file was locked, but the locking process did not respond to the start command
  at Duplicati.Server.SingleInstance..ctor (System.String appname, System.String basefolder) [0x00259] in <12d72daa8ce346c1b94252deaaa39270>:0 
  at Duplicati.Server.Program.RealMain (System.String[] _args) [0x00310] in <12d72daa8ce346c1b94252deaaa39270>:0 

If I go to Activity Monitor, kill Duplicati and also delete ~/.config/Duplicati, the same command does not return anything and ‘freezes’ as if there is some process running in the foreground. However I still can’t go to localhost:8200.

While I was writing this post, I once saw the Duplicati tray icon showing up out of nowhere and could also open localhost:8200 (canary version). This was long after I tried any command last time. However, after clicking on the tray icon and pressing Quit, I could no longer re-open the app no matter what I tried.

What could go wrong? How can I help with investigation?

Hello @kachkaev, welcome to the forum!

I don’t recall having any of these types of issues with Duplicati on the one Mac I support, though my machine already had Mono on it (from where I don’t know).

If you try starting duplicati-server without specifying a port do you still get the error?

Note that the server itself only had a web interface and the tray-icon only has the icon (which is just anb way way too see status and get to the web UI).

After a few attempts of starting the app, it finally worked. I’m still not sure what exactly contributed to its failures, but I’m glad that I can now run backups with your awesome tool!

1 Like