Error while running "name of the job". Expecting chunk trailer

Hello!

I´m new to Duplicati. And my first backupjob shows me the following message/error.
What does that mean? I only find one similar forum topic. But that doesn´t help me. :frowning:

Thanks for reading!

Marc

Error while running “name of the job”. Expecting chunk trailer.

  1. Jul. 2020 22:47: Failed while executing “Backup” with id: 1
    System.Net.WebException: Expecting chunk trailer.
    at System.Net.MonoChunkStream.ThrowExpectingChunkTrailer () [0x0000e] in <91935ad653254a93b9d73a9f8f2f7a2d>:0
    at System.Net.MonoChunkStream.FinishReading (System.Threading.CancellationToken cancellationToken) [0x00140] in <91935ad653254a93b9d73a9f8f2f7a2d>:0
    at System.Net.HttpWebRequest.RunWithTimeoutWorker[T] (System.Threading.Tasks.Task1[TResult] workerTask, System.Int32 timeout, System.Action abort, System.Func1[TResult] aborted, System.Threading.CancellationTokenSource cts) [0x000f8] in <91935ad653254a93b9d73a9f8f2f7a2d>:0
    at Duplicati.Library.Main.BackendManager.List () [0x00049] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Operation.FilelistProcessor.RemoteListAnalysis (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.String protectedfile) [0x0000d] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Operation.FilelistProcessor.VerifyRemoteList (Duplicati.Library.Main.BackendManager backend, Duplicati.Library.Main.Options options, Duplicati.Library.Main.Database.LocalDatabase database, Duplicati.Library.Main.IBackendWriter log, System.String protectedfile) [0x00000] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Operation.BackupHandler.PostBackupVerification () [0x00062] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Operation.BackupHandler.RunAsync (System.String sources, Duplicati.Library.Utility.IFilter filter, System.Threading.CancellationToken token) [0x01033] in <8f1de655bd1240739a78684d845cecc8>:0
    at CoCoL.ChannelExtensions.WaitForTaskOrThrow (System.Threading.Tasks.Task task) [0x00050] in <9a758ff4db6c48d6b3d4d0e5c2adf6d1>:0
    at Duplicati.Library.Main.Operation.BackupHandler.Run (System.String sources, Duplicati.Library.Utility.IFilter filter, System.Threading.CancellationToken token) [0x00009] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Controller+<>c__DisplayClass14_0.b__0 (Duplicati.Library.Main.BackupResults result) [0x0004b] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Controller.RunAction[T] (T result, System.String& paths, Duplicati.Library.Utility.IFilter& filter, System.Action`1[T] method) [0x0026f] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Library.Main.Controller.Backup (System.String inputsources, Duplicati.Library.Utility.IFilter filter) [0x00074] in <8f1de655bd1240739a78684d845cecc8>:0
    at Duplicati.Server.Runner.Run (Duplicati.Server.Runner+IRunnerData data, System.Boolean fromQueue) [0x00349] in :0

Welcome to the forum!

What version of Duplicati are you running?
On what operating system?
What version of mono (if non-Windows)?
What back end are you using?

Hey!

What version of Duplicati are you running?

2.0.5.1_beta_2020-01-18

On what operating system?

Unraid Docker
https://hub.docker.com/r/linuxserver/duplicati/

What version of mono (if non-Windows)?

I only installed “perl-5.30.2-x86_64-1.txz” with help of “Nerd Tools”.

What back end are you using?

Unraid Version: 6.8.3 <- WebDAV <- Synology DS414

After a restart I get a new message: “Error while running NAME OF THE JOB” “Attempted to write a stream that is larger than 4GiB without setting the zip64 option”. Where can I change the job to 64bit?

Marc

I think I found the 64bit setting. Can I just change it on an existing job? Or will this cause a whole new backup or problems/errors?

Marc

Interesting, how many files are you attempting to back up? There is a discussion elsewhere about how that zip64 option may be required for extremely large datasets (as in number of files).

You should be able to just enable it. It shouldn’t affect past backups.

Approx. 4 TB. A lot (!) of files and some bigger files. Documents, audio+video files, photos, ebooks and so on…

I added the zip64 and the logfile option. Let´s see if the errormessage appears again. And if its so what the log will show.

Maybe anyone can tell me what [Error while running “name of the job”. Expecting chunk trailer] means in the meanwhile. I just want to know if it is a problem for my backup (and of course whats the problem was). Due to the many several files it spent 3-4 days to do the full backup. I don´t want to do that again.

Marc

Again the “Expecting chunk trailer.” message. And now the job tells me: “Last successful backup: Never”?
Earlier it was shown as successful.

Me again…

I created a new job with just a part of the previous big update job. It tells me “Found 27807 files that are missing from the remote storage, please run repair” after this new job has finished. And of course: “Last successful backup: Never”

But I see many 50 MB files and saw that it copies a lot of files in the past approx 12 hours (All “missing files” are on the Synology).

:confused:

733 Files missing at the remote locations but all are there sounds similar. Does solution there solve this?

The problem could be WebDAV not allowing to see the list of files in the end?

That could be the problem. But how can I solve it?


thank you @ts678 for your prompt reply, i was going through some other posts in the forum and found that a slash in the path giving me the error. So i removed that slash, explained below

I think my path is ok.

Generally storage URLs use forward slashes (except maybe on Windows folders). You can try that.

Generally storage URLs use forward slashes (except maybe on Windows folders). You can try that.

That solved it! Thank you!!! :slight_smile:

But why did it pass the connection test with a " \ " in the path? Shouldn´t there be an error message or at least a warning?

As a guess, “Test connection” is a minimal connection test. It proves you got in, and a list request worked. Empty listings are completely normal at initial backup setup, where the button lives on Destination page.

Follow-question is too low-level, e.g. where your server looked, and under what conditions it gives an error. There’s at least one forum expert with a Synology, so perhaps they have more to say about its WebDAV…

EDIT:

You can, of course, test your own Synology to see its behavior with different paths. I don’t have one to test.

My new 4 split tasks has finished. I had several problems to get them finished. But now every job says:

Quelle (Source): x GB
Sicherung (Backup): X GB / 1 Version

How can I be sure that the saved backups are all ok nevertheless of any error message? I read that Duplicati has a check routine, so that 1 finished Version means that is definitely ok!

Is that correct? Or should I do a database repair or a “check files” job?

What is this? You created 4 new smaller jobs and ran 1 backup? If so, then 1 version sounds correct.

This worries me, and could use description. In general, though, completion is better than no completion.

Going for risky business. Not having any description, I can’t comment. Even with description, it’d be hard.

Verifying backend files, if that’s what you mean, does do some internal consistency checks in addition to sampling a tiny number of files to be sure the contents are as expected. Also see The TEST command. You can verify all your remote files, if you like. There’s also a new sampling option not yet in the manual:

  --backup-test-percentage (Integer): The percentage of samples to test after
    a backup
    After a backup is completed, some (dblock, dindex, dlist) files from the
    remote backend are selected for verification. Use this option to specify
    the percentage (between 0 and 100) of files to test. If the
    backup-test-samples option is also provided, the number of samples tested
    is the maximum implied by the two options. If the no-backend-verification
    option is provided, no remote files are verified.
    * default value: 0

Just because file contents are as expected doesn’t absolutely prove the backup is good. For any backup (not just Duplicati), an actual restore test is best. For Duplicati, you should also set no-local-blocks true, which forces Duplicati to go to the remote to obtain file data, even if data for a restore is available locally.

Similar “force” is pretty much automatic if testing Direct restore from backup files on some other system.

Giving Repair a run probably won’t hurt, but it may or may not find anything that it believes it needs to do.

1 Like