Error message while adding backup job

Hello commnunity,

Try to setup Duplicaty on Windows Server. When adding a new backup job this error message came up:

Failed to enumerate Microsoft SQL Server databases: Microsoft SQL Server VSS Writer not found - cannot backup SQL databases.

Can anyone give me a hint for this issue? Thanks.

A search for “Error: Failed to enumerate Microsoft SQL Server databases” brought up this topic which mentions needing to install the 2015 or 2017 C++ Redistributable package, did you try that yet?

Thanks for your quick reply. Both, 2015 and 2017 C++ Redistributable packages are installed on server. Unfortunately same error message appears.

I am experiencing the same symptom. I am wondering if it could be a .net framework issue?

I had this same issue. Using the link above, I determined my local system account was not given the “sysadmin” role in SQL. I’m guessing this may be because I have an SQL Express version installed, and not a full version installed. Hope this helps you. Once I gave NT Authority\System the role of sysadmin, Duplicati works great.

1 Like

How did you give the NT Authority\System the role of sysadmin?

Never mind. My SQL Server VSS Writer service was disabled.

I changed startup type to Automatic then started the service.

I no longer get the “Failed to enumerate Microsoft SQL Server databases” message.

Probably should respond anyway, even though you figured it out. In SQL management, if NT Authority\System isn’t an SQL login it needs added. If it is, it’s roles need changed to include the sysadmin role. I think I stumbled into the answer from this stack overflow post.

I have the same issue that is yet to be resolved. it’s puzzling , because I have another computer with the same setup using Duplicati as a service and I do not receive this error. When adding a backup job, I get “Failed to enumerate Microsoft SQL Server databases: Microsoft SQL Server VSS Writer not found - cannot backup SQL databases.” SQL Server VSS Writer is running and set as Automatic and Duplicati is running as well. I have even tried setting theDuplicati service to logon as the Administrator account, but it’s still not working.

Any help would be much appreciated.
One thing, when I first installed Duplicati as a User, there was no error message, but after adding it as a service I get this pop up. I am running Duplicati

I think I may have figured out what the issue could be. I have Duplicati completing a similar backup on another server with the same settings. However, apparently the SQL Database version for the software we are using is different so it allows Windows Authentication. That backup using Duplicati as a service has no errors. The current one I am working on however has the SQL VSS writer error when Duplicati is running as a service. When I have it installed as an application which appears in the tray, there is no VSS Writer Error, but there are errors FileEnumerationProcess-FileAccessError when trying to backup Shared Server folders for Users. That error appears to disappear if I right click the Duplicati icon and run the application as an administrator when starting it.

I am trying to find a happy medium to solve all the errors.