Error message while adding backup job


#1

Hello commnunity,

Try to setup Duplicaty on Windows Server. When adding a new backup job this error message came up:

Failed to enumerate Microsoft SQL Server databases: Microsoft SQL Server VSS Writer not found - cannot backup SQL databases.

Can anyone give me a hint for this issue? Thanks.


#2

A search for “Error: Failed to enumerate Microsoft SQL Server databases” brought up this topic which mentions needing to install the 2015 or 2017 C++ Redistributable package, did you try that yet?


#3

Thanks for your quick reply. Both, 2015 and 2017 C++ Redistributable packages are installed on server. Unfortunately same error message appears.


#4

I am experiencing the same symptom. I am wondering if it could be a .net framework issue?


#5

I had this same issue. Using the link above, I determined my local system account was not given the “sysadmin” role in SQL. I’m guessing this may be because I have an SQL Express version installed, and not a full version installed. Hope this helps you. Once I gave NT Authority\System the role of sysadmin, Duplicati works great.


#6

How did you give the NT Authority\System the role of sysadmin?


#7

Never mind. My SQL Server VSS Writer service was disabled.

I changed startup type to Automatic then started the service.

I no longer get the “Failed to enumerate Microsoft SQL Server databases” message.


#8

Probably should respond anyway, even though you figured it out. In SQL management, if NT Authority\System isn’t an SQL login it needs added. If it is, it’s roles need changed to include the sysadmin role. I think I stumbled into the answer from this stack overflow post. https://stackoverflow.com/questions/24822076/sql-server-login-error-login-failed-for-user-nt-authority-system