Enabling --disable-file-scanner


#1

Does the --disable-file-scanner option have any affect on files that are backed up, or does it only affect the visual progress indicator? I run Duplicati as a service, so I’m not particularly concerned about the progress bar and the “counting” process really kicks up the CPU (and fans) on my Macbook Pro.

Thanks,
Mike


#2

I have not tried this option, but Incremental backup seems to be slow #3212 has some information from @mr-flibble about its behavior. Unfortunately, the person who opened the issue didn’t find a performance increase simply from this option, so went looking for others. Possibly the CPU use you’re seeing is not the counting but processing, which I think is overlapped. You can see some information and a setting at –synchronous-upload. [solved] Improve Performance for unchanged files might also help if your backup isn’t finding a lot of changes.


#3

@mikedunn It’s only affects progress bar, as far as I know :slight_smile:


#4

Keep in mind that if you have any antivirus type tools installed they may kick in when Duplicati has to open a file to scan for what parts have changed.

Depending on your hardware, the disk access alone maybe causing high CPU usage (for example, if you’re using a software RAID with a lower powered CPU) in which case something like --use-background-io-priority=true might help.


#5

Thanks all. I went ahead and added --disable-file-scanner and today was encouraging (no fans!). I did also add --use-background-io-priority as well. Both good suggestions that work in my situation (where I just want Duplicati to be as far in the background as possible).

I do have Avast (antivirus) installed. That could absolutely be a factor. It does show high CPU time in Activity Monitor – not as high as Mono, though.


#6

Glad to hear things are running cooler / quieter for you! :smiley:

May we flag your previous post as the Solution or do you think there’s more to be covered here?


#7

Flaggin as solution per inactivity